• AVR Freaks

Hot!Does the Harmony 3 configurator have to match the version?

Author
RodoPIC
Senior Member
  • Total Posts : 180
  • Reward points : 0
  • Status: offline
2019/08/17 10:45:11 (permalink)
0

Does the Harmony 3 configurator have to match the version?

Hi all,
I'm waiting for Harmony v3.4 for the GFX stuff. I see something of a v3.4 in the git for GFX but the plug in available in the plug in list for MPLAB X says harmony configurator v3.3.0.1. If I want to install harmony  v3.4 should I wait for the plug in v3.4?
Thanks
#1

2 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 17847
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: Does the Harmony 3 configurator have to match the version? 2019/08/17 11:17:58 (permalink)
    0
    For harmony 1.xx and 2.xx they needed to match ( except for that one time )
    I would expect they need to match. But with harmony you can never be sure
    #2
    jdeguire
    Super Member
    • Total Posts : 475
    • Reward points : 0
    • Joined: 2012/01/13 07:48:44
    • Location: United States
    • Status: online
    Re: Does the Harmony 3 configurator have to match the version? 2019/08/19 10:46:21 (permalink)
    0
    I actually don't think they need to.  I say that because all of the menu items and the nodes you drag onto the Project Graph window are generated via Python scripts within the Harmony tree.  That means that the MHC3 really just needs to be able to read the Python files and do whatever they say.  The version of the plugin might matter if, for example, the devs add new Python functions to their API, but that would matter only if the Python stuff were part of the MHC3 instead of Harmony itself.
     
    It wouldn't hurt to give it a try.
    #3
    Jump to:
    © 2019 APG vNext Commercial Version 4.5