• AVR Freaks

Hot!ICD4 not recognized by MPLABX when plugged into Firewire hub

Author
atb11
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2016/12/06 08:38:48
  • Location: 0
  • Status: offline
2019/08/09 09:34:52 (permalink)
0

ICD4 not recognized by MPLABX when plugged into Firewire hub

So I recently got a new laptop and docking station.  The new docking station connects through USB3.0 / firewire.   I'd like to connect the ICD4 through the dock, and it is recognized by windows, but is not recognized by MPLABX ide or ipe.   The ICD4 does work connected directly to the laptop
 
MPLABX 5.25 lists this exact situation in the release notes,  is it possible windows isn't updating my drivers correctly?
 
System:
Dell 7730
Dell  Dock  TB16,  Model: K16A
Windows 10
MPLAB X 5.25
also installed MPLAB X 5.20
 
Device Manager:
Microchip Tools
-> Microchip WinUSB Device
Driver File Details  (7/10/2019)
winusb.sys  10.0.18362.1
WdfCoInstaller01011.dll  1.11.9200.16384
winusbcoinstaller2.dll  6.1.7600.16385
WUDFUpdate_01011.dll  6.2.9200.16384
 
Thanks,
- Adam
#1

10 Replies Related Threads

    Jim Nickerson
    User 452
    • Total Posts : 6185
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 09:52:32 (permalink)
    0
    atb11
     
    MPLABX 5.25 lists this exact situation in the release notes

    Which section of the release notes are you referring to ?
    #2
    Jim Nickerson
    User 452
    • Total Posts : 6185
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 09:55:11 (permalink)
    0
    Have you tired the USB Diagnostics ? https://www.microchip.com/forums/FindPost/1106888
    #3
    atb11
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2016/12/06 08:38:48
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 11:05:39 (permalink)
    0
    Jim,
     
    I misspoke,  I meant to said firewire and meant thunderbolt/usb3.
    Section 15 Repairs and Enhancements:

    MPLABX-3892
    MPLAB X IDE does not always recognize debuggers connected to a docking station which has a thunderbolt USB.

     
    See attached USB_Tools_Diagnostic output file.
     
    #4
    Jim Nickerson
    User 452
    • Total Posts : 6185
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 11:54:34 (permalink)
    0
    Then I would have to say it still does not "always".
    I note your output says "NOTE: Unit is NOT plugged in", mine says it is plugged in ( connected to a USB 3 HUB )
    Maybe it is time to open a support ticket.
    #5
    prj
    Super Member
    • Total Posts : 214
    • Reward points : 0
    • Joined: 2009/12/01 14:35:45
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 15:17:58 (permalink)
    0
    Please see the attached file.
    #6
    prj
    Super Member
    • Total Posts : 214
    • Reward points : 0
    • Joined: 2009/12/01 14:35:45
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 15:19:30 (permalink)
    0
    We have found that in most cases this will work on the Dell TB16 dock problems.
    #7
    ric
    Super Member
    • Total Posts : 23544
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/09 15:28:22 (permalink)
    0
    I see the infamous Microchip firewall wouldn't let you post the text file directly.
    Here it is below, but with "system32" changed to "systemXX"

    altfile.txt
    Please try the following:
    Create a file named "USBAccessLinkAltD.txt". The contents are currently not
    important (just put something in it). Drop this file into your
    C:\Windows\systemXX subdir. This will act as a flag for our utilities to
    use an alternate tool discovery process. We have found that in most cases
    this will work on the Dell TB16 dock problems. You will need to exit and
    re-invoke MPLAB X. To ensure that this alternate method took place, you
    can load the USB Tool Connection Diagnostic plug-in in the IDE
    (Tools->Plugins, Available Plugins) and run the diagnostic. It should show
    in the output that an alternate discovery method is in use (though if your
    tools now show up and are usable, you don't need the diagnostic).


    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #8
    atb11
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2016/12/06 08:38:48
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/12 05:29:10 (permalink)
    0
    Thanks PRJ and Ric,
     
    Adding that file seemed to do the trick
    #9
    prj
    Super Member
    • Total Posts : 214
    • Reward points : 0
    • Joined: 2009/12/01 14:35:45
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/12 09:20:34 (permalink)
    0
    Yes, the forum "censorship"... Thanks. Just remember it must be in system 32 (without the space).
    #10
    prj
    Super Member
    • Total Posts : 214
    • Reward points : 0
    • Joined: 2009/12/01 14:35:45
    • Location: 0
    • Status: offline
    Re: ICD4 not recognized by MPLABX when plugged into Firewire hub 2019/08/12 09:20:49 (permalink)
    0
    Glad it worked for you.
     
    #11
    Jump to:
    © 2019 APG vNext Commercial Version 4.5