• AVR Freaks

Hot!p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ?

Author
karsen
Starting Member
  • Total Posts : 47
  • Reward points : 0
  • Joined: 2012/02/07 01:49:31
  • Location: Bangalore
  • Status: offline
2019/07/22 02:56:19 (permalink)
0

p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ?

Hi,
p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? Please provide me with the latest device file. searched so many times I couldn't find it?

Attached Image(s)

#1

9 Replies Related Threads

    ric
    Super Member
    • Total Posts : 23862
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 02:59:15 (permalink)
    +1 (1)
    The "latest device file" is whatever comes with the latest version of MPLABX.
    That's not your problem anyway. It's simply failing to see your device at all.
    How about a bit more context to what you are doing?
    What board is the PIC on?
    How is it powered?
    How have you connected the programmer to the PIC?
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #2
    NorthGuy
    Super Member
    • Total Posts : 5672
    • Reward points : 0
    • Joined: 2014/02/23 14:23:23
    • Location: Northern Canada
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 05:58:59 (permalink)
    +1 (1)
    In addition to what ric said:
     
    PIC18F25K22, which you have selected, has completely different programming interface. You need to select PIC18F25Q10 instead.
     
    #3
    karsen
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2012/02/07 01:49:31
    • Location: Bangalore
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 06:51:51 (permalink)
    0
    Thanks for your reply. 
    I just try to program a simple code. Its not detected in both the softwares. 
    I attached the connection image for your reference. 
    External power is connected. 
    yes i connected the programmer to the PIC. 
    I checked with P18F25K22, its detected and no issues. 
    But 25Q10 doesn't .

    Attached Image(s)

    #4
    karsen
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2012/02/07 01:49:31
    • Location: Bangalore
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 06:53:22 (permalink)
    0
    Sorry . the image is not correct. I checked with 25k22 also. Its detected and np issues. 
    The problem is with 25Q10. Its not detected.
    post edited by karsen - 2019/07/22 07:05:50
    #5
    NorthGuy
    Super Member
    • Total Posts : 5672
    • Reward points : 0
    • Joined: 2014/02/23 14:23:23
    • Location: Northern Canada
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 07:05:35 (permalink)
    +1 (1)
    Looking at the picture, your ground wire is not connected.
    #6
    karsen
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2012/02/07 01:49:31
    • Location: Bangalore
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 07:15:02 (permalink)
    0
    No problem in connection. Only the "No connection" wire is not connected. 
    In the same wire connection , I checked with p18f25k22. Its detected No issues. 
     

    Attached Image(s)

    #7
    oliverb
    Super Member
    • Total Posts : 207
    • Reward points : 0
    • Joined: 2009/02/16 13:12:38
    • Location: 0
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 07:48:02 (permalink)
    +1 (1)
    It might help to scroll back a bit or enlarge the output window. It should be paste-able anyway rather than screenshots.
     
    Can you confirm that it is actually failling to connect to the PIC, and not just the older issue where a PICkit3 fails to update its own firmware meaning the programming operation gets aborted?
     
    #8
    karsen
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2012/02/07 01:49:31
    • Location: Bangalore
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 08:08:05 (permalink)
    0
    Please see the images.
    Failing to connect to the PIC. 
    I checked with both software. 

    Attached Image(s)

    #9
    karsen
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2012/02/07 01:49:31
    • Location: Bangalore
    • Status: offline
    Re: p18F25Q10 IS Not detected in pickit 3 and mp lab x ipe v5.20 ? 2019/07/22 08:56:17 (permalink)
    0
    Thanks all. 
    Finally, this video helps me to solve the issue. 
    https://www.youtube.com/watch?v=pyH8IdpdT4I
     
    #10
    Jump to:
    © 2019 APG vNext Commercial Version 4.5