• AVR Freaks

Hot!UART Communication Troubles

Author
jack.fining
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/06/17 07:36:49
  • Location: 0
  • Status: offline
2019/07/09 11:27:00 (permalink)
0

UART Communication Troubles

Hi, I'm really new to microcontrollers and C in general, so please bear with me here. I'm just trying to set up a simple LED system to test the functionality of UART with the OS I'm working with. I've attached a .txt file with my code. Any recommendations would be appreciated. Below I'll list out the specs of what I'm working with:
 
PIC24FJ256GB210
xc16 compiler v1.25
MPLAB X IDE 3.15


Attachment(s)

Attachments are not available: Download requirements not met
#1

1 Reply Related Threads

    Aussie Susan
    Super Member
    • Total Posts : 3628
    • Reward points : 0
    • Joined: 2008/08/18 22:20:40
    • Location: Melbourne, Australia
    • Status: offline
    Re: UART Communication Troubles 2019/07/09 19:07:27 (permalink)
    0
    There is a whole lot missing from your program - I hope that is not all of it.
    This forum is intended for the IDE and not for questions about specific processors or the XC16 compiler.
    I suggest you ask this question in (one of) the XC16 or PIC24 forums but make sure that you show us ALL of your code (hopefully from a small but complete program that shows the issue you are having) - and please include the configuration settings.
    Susan
    #2
    Jump to:
    © 2019 APG vNext Commercial Version 4.5