• AVR Freaks

AnsweredAnyone tried SPI5 on a PIC32MZ2048EFH144

Author
adown
New Users
  • Total Posts : 37
  • Reward points : 0
  • Joined: 2017/10/19 16:09:17
  • Location: Calgary
  • Status: offline
2019/06/24 18:23:22 (permalink)
0

Anyone tried SPI5 on a PIC32MZ2048EFH144

Good evening, quick question.  I'm familiar with SPI communication, and the other SPI busses on my MCU function as expected.  However i cannot get any data in/out of SPI5.  It's interrupt never fires, and data i write to SPI5BUF never appears on the pin.  I have the most, absolutely basic initialization.  I'm only using harmony to configure my IO/clocks, and i've checked the generated code.
 
Can anyone confirm that SPI5 works in their application?
 
-A
#1
ric
Super Member
  • Total Posts : 22654
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: online
Re: Anyone tried SPI5 on a PIC32MZ2048EFH144 2019/06/24 19:21:25 (permalink) ☼ Best Answerby adown 2019/06/25 12:38:04
4.5 (2)
Those pins appear to be shared with the JTAG interface.
Has JTAG been disabled?
 

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#2
adown
New Users
  • Total Posts : 37
  • Reward points : 0
  • Joined: 2017/10/19 16:09:17
  • Location: Calgary
  • Status: offline
Re: Anyone tried SPI5 on a PIC32MZ2048EFH144 2019/06/25 12:38:59 (permalink)
0
Thanks Ric, i'm an idiot (the harmony configurator always gives me a false sense of security, i forget to check for non-remappable pin function conflicts).
 
-A
#3
Jump to:
© 2019 APG vNext Commercial Version 4.5