• AVR Freaks

Hot!Harmony v3 - No MCU's to select

Author
dmccric
Senior Member
  • Total Posts : 156
  • Reward points : 0
  • Joined: 2006/05/30 08:13:15
  • Location: Bradford, England
  • Status: offline
2019/06/18 08:24:22 (permalink)
0

Harmony v3 - No MCU's to select

I have installed the latest versions of MPLAB X v5.20 and Harmony v3 but when I create my project it will not allow me to finish creating the project as there is no list of processors to choose from.
 
I have rebooted, re-installed, etc. Has anyone had the same problem?
 
Regards
#1

7 Replies Related Threads

    Jim Nickerson
    User 452
    • Total Posts : 6326
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Jim Nickerson
    User 452
    • Total Posts : 6326
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: Harmony v3 - No MCU's to select 2019/06/18 08:33:58 (permalink)
    0
    I see you have version 3, maybe this is of more help https://github.com/Microc...Harmony.github.io/wiki
    #3
    dmccric
    Senior Member
    • Total Posts : 156
    • Reward points : 0
    • Joined: 2006/05/30 08:13:15
    • Location: Bradford, England
    • Status: offline
    Re: Harmony v3 - No MCU's to select 2019/06/18 14:24:00 (permalink)
    0
    I have looked at both of these tutorials and none have helped me. Still the same issue, I have installed this on both my laptops and both have the same issue. I cannot see any target devices to select.
    #4
    dmccric
    Senior Member
    • Total Posts : 156
    • Reward points : 0
    • Joined: 2006/05/30 08:13:15
    • Location: Bradford, England
    • Status: offline
    Re: Harmony v3 - No MCU's to select 2019/06/19 00:57:28 (permalink)
    0
    I have now managed to create a project by adding the target MCU in manually, PIC32MX795F512L.
    I then selected the Configurator from the tools menu and I now get another error.
    See attached image.
     
    Any ideas?
     
     

    Attached Image(s)

    #5
    Jim Nickerson
    User 452
    • Total Posts : 6326
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: Harmony v3 - No MCU's to select 2019/06/19 07:13:30 (permalink)
    0
    I have not used Harmony v3 for any Pic32Mx devices, only v2
    #6
    paulmtcuk
    Starting Member
    • Total Posts : 43
    • Reward points : 0
    • Joined: 2007/08/23 05:16:51
    • Location: 0
    • Status: offline
    Re: Harmony v3 - No MCU's to select 2019/06/19 08:47:09 (permalink)
    0
    I wouldn't add manually. 
     
    did you follow the steps in https://www.microchip.com/forums/m1101397.aspx ?
     
    When you create a new Harmony v3 project you must click on "Launch Framework Downloader" to download the latest framework from github. Did you do this?  You can redownload to refresh -- You must select at least some core packages from the catalog by checking the download tick box and click "Download" before "Next". After which the framework path must match that of the downloaded files and all supported PICs at the time of your download will be shown after "Next >" in to Project settings step. 
     
    post edited by paulmtcuk - 2019/06/19 08:49:19
    #7
    paulmtcuk
    Starting Member
    • Total Posts : 43
    • Reward points : 0
    • Joined: 2007/08/23 05:16:51
    • Location: 0
    • Status: offline
    Re: Harmony v3 - No MCU's to select 2019/06/19 08:51:20 (permalink)
    0
    (Couldn't edit)
     
    Did you follow https://github.com/Microchip-MPLAB-Harmony/mhc/wiki
     
    At which step did you get to?
    #8
    Jump to:
    © 2019 APG vNext Commercial Version 4.5