• AVR Freaks

Hot!Really slow parametric search

Author
realexander
Super Member
  • Total Posts : 187
  • Reward points : 0
  • Joined: 2006/04/08 09:50:42
  • Location: 0
  • Status: offline
2019/06/12 14:50:06 (permalink)
0

Really slow parametric search

Is it just me, or is the parametric search tool for microcontrollers horrendously slow to load? Like, it takes almost 2 minutes. It's been like this for months.
 
- Bob
 
#1

7 Replies Related Threads

    KTrenholm
    Super Member
    • Total Posts : 710
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: Really slow parametric search 2019/06/13 07:52:02 (permalink)
    0
    Runs just fine on my end using Firefox 67.0.2.
     
    If you're having issues, maybe downloading and using the spreadsheet version would be quicker?
    #2
    mbrowning
    USNA79
    • Total Posts : 1511
    • Reward points : 0
    • Joined: 2005/03/16 14:32:56
    • Location: Melbourne, FL
    • Status: offline
    Re: Really slow parametric search 2019/06/13 07:57:44 (permalink)
    0
    Today, 1 to 5 seconds for me (win10, i7, 16G RAM, SSD, Firefox).
     

    Go Navy! Beat Army!
    #3
    realexander
    Super Member
    • Total Posts : 187
    • Reward points : 0
    • Joined: 2006/04/08 09:50:42
    • Location: 0
    • Status: offline
    Re: Really slow parametric search 2019/06/13 09:27:30 (permalink)
    0
    What happens if you click the "Show All Specs" radio button?
     
    - Bob
     
    #4
    KTrenholm
    Super Member
    • Total Posts : 710
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: Really slow parametric search 2019/06/13 09:39:27 (permalink)
    0
    Selecting "Show All Specs" took a few seconds to load in, but no more that like 15-20 seconds here on my end.
     
    #5
    realexander
    Super Member
    • Total Posts : 187
    • Reward points : 0
    • Joined: 2006/04/08 09:50:42
    • Location: 0
    • Status: offline
    Re: Really slow parametric search 2019/06/13 09:52:48 (permalink)
    0
    And were all the specs displayed and you could start selecting them?
     
    What I'm seeing is the browser loads the page in maybe 10 seconds (which is bad, but not bad enough to complain about) and then a JavaScript (or some local AJAX-like thing) runs for a couple of minutes loading the data.
     
    I see this in Chrome, Firefox, and MS Edge.
    #6
    KTrenholm
    Super Member
    • Total Posts : 710
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: Really slow parametric search 2019/06/13 09:59:51 (permalink)
    0
    Yeah for me the slowest thing is the initial page load (like you said, around 10-15 seconds, which isn't great).
     
    Past that I can select a search item like package pin count and it sorts and loads in pretty quickly, within 3-5 seconds.
    Scrolling down you can tell it loads additional parts in as it scrolls, but again it only takes a couple seconds to do so.
     
    This is on a Win 7 rig sporting an aging i5-3550
    You're using Win10 presumably?
    #7
    realexander
    Super Member
    • Total Posts : 187
    • Reward points : 0
    • Joined: 2006/04/08 09:50:42
    • Location: 0
    • Status: offline
    Re: Really slow parametric search 2019/06/13 10:04:26 (permalink)
    0
    Yeah, Win10. I doubt that's the issue though.
    #8
    Jump to:
    © 2019 APG vNext Commercial Version 4.5