• AVR Freaks

RN4020 private Characteristics

New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2019/06/09 08:46:26
  • Location: 0
  • Status: offline
2019/06/12 07:46:29 (permalink)

RN4020 private Characteristics

I use a RN4020 BLE Module to communicate with the VALRT BT Button: https://vsnmobil.com/products/v-alrt/specs

Problem is, I need to send "80BEF5ACFF" within 30sec after connect to the specific private UDID "FFFFFFF5-00F7-4000-B000-000000000000" (see reference: https://github.com/HoyosI...V.ALRT-bluetooth-spec)

Problem is, I always get "ERR" back from RN4020.

Here is my Initialisation Code (which works):

sf,2 //Factory Reset
+ //echo on
sr,92000000 //configure as Master
r,1 //reboot
F //search devices
X //stop searching
E,0,001EC026C931 //connect to device with mac: 001EC026C931 which is my device
B //Bond

Get a "Connected" back and the Button quit it with a Beep.

Now I tried to Write


with and without "-" but allways get a error back. At github are samples for Android and iOS but its not clear for me what I have to send...

Think I forgot prestep, but I dont know which one.

When I send a "LC", i get this stuff back:






























As you can see, not the Service / Characteristic what Im looking for. Pretty same but not same. Tried the "FFFFFFA500F74000B000000000000000" one but still not working.

When I connect the button with the BLE Scanner Android App it works well, I can see the requested Characteristic and I can write to it.


0 Replies Related Threads

    Jump to:
    © 2020 APG vNext Commercial Version 4.5