• AVR Freaks

Hot!ICD 3 Debug mode error msg when single stepping: Stepping target failed

Author
Kirit1
Starting Member
  • Total Posts : 69
  • Reward points : 0
  • Joined: 2007/03/27 14:58:03
  • Location: CALIF
  • Status: offline
2019/05/22 19:02:04 (permalink)
0

ICD 3 Debug mode error msg when single stepping: Stepping target failed

Hello:
 
Using ICD 3, IDE V8.92, PIC18F65K22 based board, Windows 10 (64-bit), debugging fails when I halt the firmware and try to single step (or animate), I get the message "Stepping Target Failed".
In Debugger "run" mode, the board functions a OK."halt" works OK.
 
Likewise, in programming mode, I can program the board and then run in standalone mode a OK.
 
 
I tried a couple different production quality PIC18F65K22 based boards, but got the same issue.
 
I have replaced ICD 3 with  Pickit 3 in debug mode, and again, same problem as above.
 
Programming mode functions usinging Pickit 3 work a OK.
 
My Assembler based Firmware does have both Main and ISR. The firmware was developed a few years back using ICD 2, and I do not recall having this type of issue.
Under "Configure => power" tab, I did notice the system defaulted Target Vcc to 3.3V. In my case, the Vcc is 5V, so I adjusted accordingly, but the problem remained as before.
The cable from ICD 3 Pod to my board was about 9" long. I shortened it to 4", but, again, the problem remained as before.
 
There is no Error Message Number or online help regarding " Stepping Target Failed".
 
Any suggestions to resolve the issue will be much appreciated.
 
Thank You.
#1

3 Replies Related Threads

    du00000001
    Just Some Member
    • Total Posts : 2997
    • Reward points : 0
    • Joined: 2016/05/03 13:52:42
    • Location: Germany
    • Status: offline
    Re: ICD 3 Debug mode error msg when single stepping: Stepping target failed 2019/05/22 22:03:24 (permalink)
    0
    External watchdog or alike?
    Seems your recall is imperfect...

    PEBKAC / EBKAC / POBCAK / PICNIC (eventually see en.wikipedia.org)
    #2
    Kirit1
    Starting Member
    • Total Posts : 69
    • Reward points : 0
    • Joined: 2007/03/27 14:58:03
    • Location: CALIF
    • Status: offline
    Re: ICD 3 Debug mode error msg when single stepping: Stepping target failed 2019/05/23 12:27:18 (permalink)
    0
    Thank you for the feedback; however, .....
     
    The Watchdog Timer is disabled. Also, in the "RUN" mode, the firmware works fine; Only when "Step Into", "Step Over" or animation, does the "Stepping Target Failed" occurs.
     
    Could the problem be related to ICD, ICC signals bouncing around when trying to single step?
    #3
    Jim Nickerson
    User 452
    • Total Posts : 6184
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: ICD 3 Debug mode error msg when single stepping: Stepping target failed 2019/05/23 12:45:28 (permalink)
    0
    Do the config bits for pgc/pgd match the physical connections ?

    Attached Image(s)

    #4
    Jump to:
    © 2019 APG vNext Commercial Version 4.5