• AVR Freaks

Hot!Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out.)

Author
nyholku
Junior Member
  • Total Posts : 101
  • Reward points : 0
  • Joined: 2008/04/30 05:13:58
  • Location: 0
  • Status: offline
2019/05/20 03:40:08 (permalink)
0

Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out.)

We are trying to bring up a new board with ATtiny1616.
 
When I try to program the board I get 

Erasing...
PDI physical timed out. (25)
Programming did not complete.

 
I suspect that the chip is not in UDPI mode so I would like to get the Power Debugger to do a +12V pulse on the reset line to bring the chip into UDPI mode, but I cannot find this option.
 
Some forum posts say that Power Debugger has this capability, some say it can be found from Tools/Device menu.
 
Some forums posts claim that factory fresh 1616 should be in UDPI mode but I don't find this confirmed in the datasheet.
 
For references attached is how the chip is connected to the programmer.
 
 

Attachment(s)

Attachments are not available: Download requirements not met
#1

4 Replies Related Threads

    je_ruud
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2016/12/08 23:55:38
    • Location: 0
    • Status: offline
    Re: Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out 2019/05/21 03:32:22 (permalink)
    +1 (1)
    The 12V activation with PowerDebugger is targeted in the next MPLAB X release. For now you will have to use Studio.
     
    And yes, all tiny's with UPDI defaults to the pin configured as UPDI.
    #2
    nyholku
    Junior Member
    • Total Posts : 101
    • Reward points : 0
    • Joined: 2008/04/30 05:13:58
    • Location: 0
    • Status: offline
    Re: Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out 2019/05/21 22:54:13 (permalink)
    +2 (2)
    Answering my own question:
     
    I posted essentially the same question in avrfreaks forum and got an explanation from someone who looks like he is from Microchip.

    You can find the thread in here:

    https://www.avrfreaks.net/forum/trying-program-attiny1616-atmel-power-debugger-and-updi#comment-2698046

    In short +12V activation is not yet available for MPLAB X, only know option is to use Atmel Studio and Power Debugger. MPLAB X support is in the pipeline. 

    And yes, factory fresh ATtiny1616 is in UDPI mode and we solved our silly wiring mistake.
    #3
    je_ruud
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2016/12/08 23:55:38
    • Location: 0
    • Status: offline
    Re: Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out 2019/05/22 00:42:30 (permalink)
    +2 (2)
    I actually answered this thread before my reply in Freaks, but since I'm "new" in the Microchip forum my post was waiting for approval...
    #4
    nyholku
    Junior Member
    • Total Posts : 101
    • Reward points : 0
    • Joined: 2008/04/30 05:13:58
    • Location: 0
    • Status: offline
    Re: Enabling +12V pulse for UDPI on Power Debugger with ATtiny1616 (PDI physical timed out 2019/05/25 21:34:26 (permalink)
    0
    Thanks for the answers! :) 
    #5
    Jump to:
    © 2019 APG vNext Commercial Version 4.5