MPLABX v5.15/MCC not showing SCK1 and 2 pins for SPI1 and 2?

Author
rdtsc
Starting Member
  • Total Posts : 46
  • Reward points : 0
  • Joined: 2013/01/21 11:13:18
  • Location: 0
  • Status: offline
2019/04/16 07:31:27 (permalink)
0

MPLABX v5.15/MCC not showing SCK1 and 2 pins for SPI1 and 2?

I just created a new:
* dsPIC33EP256GP502 project from Linux OS
* MCC Plugin v3.75
* MCC Core v4.65 
* pic24-dspic33-pic32mm-1.75.1
Then added SPI1 and SPI2, and the SCK1 and SCK2 are not listed anywhere in the Pin Module nor Pin Manager.
 
This is *after* upgrading MCC core to 4.65; prior to this (unsure which core was being used, perhaps 4.56), I was seeing a SCK1 pin, but no SCK2 pin.
 
Any clues as to what to do now?  Try earlier versions of the plugins until a working configuration is found?  

Attachment(s)

Attachments are not available: Download requirements not met
#1

2 Replies Related Threads

    rdtsc
    Starting Member
    • Total Posts : 46
    • Reward points : 0
    • Joined: 2013/01/21 11:13:18
    • Location: 0
    • Status: offline
    Re: MPLABX v5.15/MCC not showing SCK1 and 2 pins for SPI1 and 2? 2019/04/17 06:44:36 (permalink)
    0
    Ok well to answer my own question:
     
    dsPIC33EP256GP502
    MPLABX v5.15
    SPI clock pins LAST WORKING with:
    MCC Plugin v3.75
    Core v4.15.9
    PIC24/dsPIC33/PIC32MM library v1.35
    Foundation Services v0.1.24
    SPI pins NOT working with (missing from, at least partially) all later versions.
    #2
    Aussie Susan
    Super Member
    • Total Posts : 3518
    • Reward points : 0
    • Joined: 2008/08/18 22:20:40
    • Location: Melbourne, Australia
    • Status: offline
    Re: MPLABX v5.15/MCC not showing SCK1 and 2 pins for SPI1 and 2? 2019/04/17 20:31:15 (permalink)
    0
    Submit a ticket with Microchip
    Susan
    #3
    Jump to:
    © 2019 APG vNext Commercial Version 4.5