• AVR Freaks

Hot!Cannot find system include files

Author
simon.brouwer
Junior Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2006/12/06 02:54:33
  • Location: 0
  • Status: offline
2019/03/25 06:27:41 (permalink)
0

Cannot find system include files

Hi,
 
I have a new PIC32MX Harmony project that builds without a problem; now I want to add my own .h and .c files.
 
The problem is that in these files, the #include directives for system files get flagged with an error.
 
For example, I added a new "xc32_newfile.c" in the same logical and physical folder as main.c, and simply copied the include directives from main.c into it. Then I get the error flags as in attached image.
 
In main.c, these same include directives don't present any problem!
I don't understand what is different between these files to cause this.
 
Any directions to a solution are very welcome!
Thanks in advance,
 
Simon

Attached Image(s)

#1

2 Replies Related Threads

    eclipse80
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2016/03/06 10:16:00
    • Location: 0
    • Status: offline
    Re: Cannot find system include files 2019/03/25 08:27:44 (permalink)
    0
    simon.brouwer
    The problem is that in these files, the #include directives for system files get flagged with an error.

     
    I usually restart MPLAB X when i get these errors and they go away.
    #2
    simon.brouwer
    Junior Member
    • Total Posts : 106
    • Reward points : 0
    • Joined: 2006/12/06 02:54:33
    • Location: 0
    • Status: offline
    Re: Cannot find system include files 2019/03/26 07:54:07 (permalink)
    0
    Well, at least the compiler could find those include files, that is the most important.
    And my impression is that, once the file has been used in compilation, the error flags disappear (at least some of the time...)
    #3
    Jump to:
    © 2019 APG vNext Commercial Version 4.5