• AVR Freaks

KSZ9477 to PIC32MZ

Author
morgan1361
New Member
  • Total Posts : 14
  • Reward points : 0
  • Joined: 2019/03/22 07:28:09
  • Location: 0
  • Status: offline
2019/03/22 08:31:58 (permalink)
0

KSZ9477 to PIC32MZ

Hello All,
 
I currently have a project to create a gigabit switch board using a PIC32MZ2048EFH100 and a KSZ9477S.  Now I have a bit of experience doing this with PIC32MX's and MPLab pre-harmony.  I plan to use this switch in un-managed mode, the MCU is there to be an Ethernet node for other reasons.  I am having trouble getting all this working with harmony.  I have used hardware configuration straps and the switch seems to be functioning but I cannot ping the MCU.   All of the examples show driver written for linux and there are about 50 files just for this switch.  This PHY is not directly supported by harmony so what changes need to be made in order for this to work.  Does it even matter if I do not plan to use any of the switches management features.  I guess I just need someone to help point me in the right direction as I feel I may be overthinking this.
 
Thanks in advance
post edited by morgan1361 - 2019/03/25 07:33:59
#1
morgan1361
New Member
  • Total Posts : 14
  • Reward points : 0
  • Joined: 2019/03/22 07:28:09
  • Location: 0
  • Status: offline
Re: KSZ9477 to PIC32MZ 2019/03/25 07:35:36 (permalink)
0
So after making a trial run at this, just using one of the included KSZ harmony drivers, the TCP/IP stack is not initializing.  I assume that is due to the improper driver.  Is there a tutorial for creating one for use with the harmony stack.  I am currently using harmony v2.06.
#2
Jump to:
© 2021 APG vNext Commercial Version 4.5