• AVR Freaks

Hot!interrupt usage V2 project not compiling

Author
C_dude
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2019/03/13 10:57:52
  • Location: 0
  • Status: offline
2019/03/20 21:30:13 (permalink)
0

interrupt usage V2 project not compiling

http://microchipdeveloper.com/32bit:mx-code-examples-interrupt-usage
 
I've been reading up on Pic32 for a bit, and following some of the tutorials I've found online. I've had some problems getting interrupts to work. Even the MicroChip provided tutorial (above link) doesn't compile without errors. I'm not sure what the source of the errors are, but I can't get it working.....
 
Any insights? 
#1

3 Replies Related Threads

    Larry.Standage
    Super Member
    • Total Posts : 878
    • Reward points : 0
    • Joined: 2011/12/30 09:50:47
    • Location: 0
    • Status: offline
    Re: interrupt usage V2 project not compiling 2019/03/22 08:35:57 (permalink)
    0
    What's your setup? I just tried to build the example and it did just fine. That's with MPLAB X 5.15 and XC32 2.15.
     
    Where did you extract the example? The website says to extract (on Windows) to your C: drive.
    #2
    C_dude
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2019/03/13 10:57:52
    • Location: 0
    • Status: offline
    Re: interrupt usage V2 project not compiling 2019/03/22 10:47:40 (permalink)
    0
    Win 7, same MPLAB and XC32 compiler edition as you. - Trying to compile for PIC32MX210F016B, DIP package.
     
     
    post edited by C_dude - 2019/03/22 11:06:52
    #3
    Larry.Standage
    Super Member
    • Total Posts : 878
    • Reward points : 0
    • Joined: 2011/12/30 09:50:47
    • Location: 0
    • Status: offline
    Re: interrupt usage V2 project not compiling 2019/03/22 13:57:35 (permalink)
    0
    Yeah, totally different part, so the code won't compile straight up.
     
    Since I don't know how you've hooked up the MX210, you'll have to pay attention to the following to get this to work:
    1. Remove any references to CHECON. This part does not have Flash prefetch.
    2. Remove any references to DDPCON.
    3. Change the clock frequency to 40 MHz. You'll have to do this in the #pragma statements and where SYS_CLK_FREQUENCY is defined. If you don't have an external crystal, change the FNOSC to FRCPLL so that it uses the internal FRC to drive the PLL.
    4. Change the LED definitions to whatever port and pin has your LED.
    5. Remove any #pragma config statements that don't compile. This part has different configuration settings.
    #4
    Jump to:
    © 2019 APG vNext Commercial Version 4.5