• AVR Freaks

Helpful ReplyHot!IPE Advanced Mode Entry

Author
edware
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/01/04 22:41:19
  • Location: 0
  • Status: offline
2019/02/23 23:12:23 (permalink)
0

IPE Advanced Mode Entry

Is there a way to configure IPE so that it starts in advanced mode without the need to enter a password?

Or put another way, can I set the password to <blank>?
 
Can I also set the option 'Power Target from tool' to default to YES?
 
Thanks!
post edited by edware - 2019/02/23 23:14:48
#1
vkalyan
New Member
  • Total Posts : 27
  • Reward points : 0
  • Joined: 2016/02/15 22:26:47
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/02/23 23:28:43 (permalink)
0
Check the attachment for advanced mode login.
 
For the "Power Target circuit from tool" setting you can create an environment. Check the attachment
post edited by vkalyan - 2019/02/23 23:38:59

Attached Image(s)

#2
edware
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/01/04 22:41:19
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/02/24 22:29:22 (permalink)
0
Awesome! Thanks for your fast response.
It works exactly as I hoped it would LoL: LoL
Is there a way to automatically load a default environment when starting up IPE ?
 
Cheers!
#3
vkalyan
New Member
  • Total Posts : 27
  • Reward points : 0
  • Joined: 2016/02/15 22:26:47
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/02/24 22:40:24 (permalink)
0
Is there a way to automatically load a default environment when starting up IPE ?

 
Yes. Just place the environment folder at your desired location. Copy that path and paste it in mplab_ipe.conf file which is situated at C:\Program Files (x86)\Microchip\MPLABX\v5.10\mplab_platform\etc\ with the command with the argument -J-Dload.environment
Example: -J-Dload.environment=D:\\pic18f\pic18f.pm3
#4
Sudheer Herle
Super Member
  • Total Posts : 413
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re: IPE Advanced Mode Entry 2019/02/25 00:15:17 (permalink)
0
Perfect!
#5
tech24x7
Starting Member
  • Total Posts : 61
  • Reward points : 0
  • Joined: 2013/10/14 21:38:52
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/02/25 23:07:05 (permalink)
0

Attached Image(s)

#6
keane
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/05/24 07:27:00
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 09:30:29 (permalink)
0
Is there a method similar to the "-J-Dload.environment=D:\\pic18f\pic18f.pm3" that will load in the correct device and hex file? The environment does not save this information for me. Tried the -P,-F method from the user guide to create a shortcut but it doesn't seem to work with IPE v5.05. Thanks.
#7
KTrenholm
Super Member
  • Total Posts : 710
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 09:57:36 (permalink) ☄ Helpfulby keane 2019/05/24 09:59:32
0
The environment should save the device, but it will only actually CHANGE the currently selected device if the selection has been "Applied" first (you have selected a device in the dropdown then clicked the "Apply" button).  Otherwise it will not recognize the selected part has changed.  I actually brought this up in a support case to mchip a while back but I don't think it was ever actually addressed despite being closed as "resolved".
 
This is of course, with the IPE GUI, not CLI.  In either case, the device should be included in the environment.  Hex file is, unfortunately, not included in the environment.
post edited by KTrenholm - 2019/05/24 10:06:52
#8
keane
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/05/24 07:27:00
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 10:02:59 (permalink)
0
Thank you, probably should have realized I was not applying it before saving the environment. 
#9
NorthGuy
Super Member
  • Total Posts : 5544
  • Reward points : 0
  • Joined: 2014/02/23 14:23:23
  • Location: Northern Canada
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 10:04:53 (permalink) ☄ Helpfulby edware 2019/06/24 16:22:05
5 (1)
If you want to automate everything, you can just create a bat file which calls PK3cmd . e x e (or other) with all the parameters followed by a "pause" command. Then, you create a shortcut to the bat file. Clicking on the shortcut will do all the programming. May not look nice, but requires only one click for complete programming.
#10
keane
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/05/24 07:27:00
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 10:11:13 (permalink)
0
Okay I'll explore that option. Using MPLAB X moving forward so will try IPECMD instead, unless there are benefits of the legacy one.
#11
Jerry Messina
Super Member
  • Total Posts : 404
  • Reward points : 0
  • Joined: 2003/11/07 12:35:12
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 10:21:55 (permalink)
0
Hex file is, unfortunately, not included in the environment

I don't know about for the pm3, but with the other tools the hex file is saved as part the environment, at least it is for me.
 
It doesn't actually save the hex file (or a link to it), but it processes it into a .bin file that it saves along with the .pen file in the same folder.
 
#12
keane
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/05/24 07:27:00
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 10:38:11 (permalink)
0
When I load a HEX file, then save the environment as either .pm3 or .pen, neither remembers which HEX file was selected when I import them again. Do you have to link the .bin file somehow? It doesn't seem to touch that file when I import. Thanks.
#13
Jerry Messina
Super Member
  • Total Posts : 404
  • Reward points : 0
  • Joined: 2003/11/07 12:35:12
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 12:17:41 (permalink) ☄ Helpfulby keane 2019/05/24 12:57:33
0
I've been using IPE V3.55 since that's what our production folks use... when I load the .pen file I get the proper device and hex data (from the .bin file) loaded automatically.
 
I just tried this with IPE 5.10 and it seems to work quite differently. If I view program memory after loading the environment it shows blank (all FF's).
 
What good is an environment if it doesn't load the settings and data?????
I have to believe I'm doing something wrong with V5.10, else my low option of MPLABX has just reached an all time low.
 
 My bad. Operator error... the test environment I loaded didn't have any data at the beginning so I thought it wasn't working. Seems to load the hex data just like v3.55 does.
 
post edited by Jerry Messina - 2019/05/24 12:27:07
#14
keane
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/05/24 07:27:00
  • Location: 0
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/24 13:00:29 (permalink)
0
Thank you for checking that Jerry. How can I verify the memory data loaded in from the IPE GUI (ie what tab and button opens it)? Can you only see it after you've connected to a tool (programmer)?
#15
Jerry Messina
Super Member
  • Total Posts : 404
  • Reward points : 0
  • Joined: 2003/11/07 12:35:12
  • Status: offline
Re: IPE Advanced Mode Entry 2019/05/25 03:59:19 (permalink) ☄ Helpfulby keane 2019/05/27 04:04:56
0
In IPE V5 you can see the memory contents using 'Window | Target Memory Views | Program Memory'
After I loaded a hex file and created an environment I then used 'View | Clear All Memory' and I got all FF's
Imported the environment and the hex data is there.
 
Works for me without any tool connected.
#16
Jump to:
© 2019 APG vNext Commercial Version 4.5