• AVR Freaks

Hot!EDBG does not shown on Ateml Studio

Author
yzhong
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2017/01/18 14:50:52
  • Location: 0
  • Status: offline
2019/02/22 12:50:01 (permalink)
0

EDBG does not shown on Ateml Studio

I am used ATSAME54-XPRO (SAM E54 xplained pro). But, I could not find EDBG (available tools) on Ateml Studio after connecting SAM E54 xplained. I checked device manager. it showed ( Ateml Corp. EDBG USB port (COM55) and EDBG Data Gateway). could you help me to configu EDBG on Ateml Studio
#1

1 Reply Related Threads

    vitius
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2019/10/31 00:32:44
    • Location: 0
    • Status: offline
    Re: EDBG does not shown on Ateml Studio 2019/11/01 00:33:28 (permalink)
    0
    I had the very same problem.
    I tried several ways to solve it.
    I also have an Atmel ICE, the strangest thing was that the ICE also disappeared when I connected the XPlain over USB. The root of the problem is that something kills the Debugger Backend Agent (which runs in the background when you start Atmel Studio) when the Xplain board is connected.
    So I started to play around with the EDBG Data Gateway driver, I removed it in the device manager. I tried to find a download for the latest version without any success so I let it as it is, without the driver installed.
    My idea was that I would use the ICE to program the board so I started Atmel Studio and SURPRISE!
    The board appeared in the Studio, EDBG is also available and works fine.
     
    I don't really understand, but it works _without_ the driver. See attached image.

    Attached Image(s)

    #2
    Jump to:
    © 2019 APG vNext Commercial Version 4.5