Hot!Harmony Configurator 3 - Fail to load

Author
PastrelloMarco
Starting Member
  • Total Posts : 50
  • Reward points : 0
  • Joined: 2013/08/30 12:26:20
  • Location: Venezia, Italy
  • Status: offline
2019/01/09 06:19:34 (permalink)
0

Harmony Configurator 3 - Fail to load

Hi all:
today I downloaded by the new plugin the new version of Harmony 3 configurator.  I installed all packet but when I try to Load the Harmony Configurator 3 from MPLABX 5_05, the IDE show the message in the attachment and the loading fail
 
I think the problem is the MCH path missing: Does Someone Know how to solved this problem?
Where I can Write it manually?
 
Thanks in advance

Attached Image(s)

#1

14 Replies Related Threads

    Jim Nickerson
    User 452
    • Total Posts : 5820
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 06:59:05 (permalink)
    0
    Do you have Harmony 3 ?

    Attached Image(s)

    #2
    JPortici
    Super Member
    • Total Posts : 561
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 07:04:03 (permalink)
    0
    Maybe 5.05 isn't supported? I have only tried at home, i have 5.10 installed there..
    I get it that things are still in beta, but it's annoying that i have to enter the correct paths manually every time..
    #3
    PastrelloMarco
    Starting Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2013/08/30 12:26:20
    • Location: Venezia, Italy
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 07:20:07 (permalink)
    0
    Thnaks for help me
    Yes, I installed  the plugin this morning. If plugin has a wrong version, I think I can't download the framework

    Attached Image(s)

    #4
    MarkD
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2003/11/07 12:43:55
    • Location: Toronto, Canada
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 12:13:43 (permalink)
    0
    PastrelloMarco
    Hi all:
    today I downloaded by the new plugin the new version of Harmony 3 configurator.  I installed all packet but when I try to Load the Harmony Configurator 3 from MPLABX 5_05, the IDE show the message in the attachment and the loading fail
     
    I think the problem is the MCH path missing: Does Someone Know how to solved this problem?
    Where I can Write it manually?
     
    Thanks in advance




     
    I had exactly that same error last night, and could not find a solution to it.  I get the feeling that Harmony is not in a good state, I never have any trouble installing other IDE's and components.    I decided to start again and use Harmony V2, and followed these instructions exactly:  
     
    http://microchipdeveloper.com/harmony:installation
     
    But the file mentioned in step 11 does not even exist!
     
    Navigate to the following directory:
    C:\microchip\harmony\vX_XX\doc
    (where X.XX represents the version number)
    Select the file:
    org-microchip-harmony_help.nbm
     
     
    This is all that is in the mentioned directory on my PC  (please see attached picture).
     
    Does anyone have an idea what's going wrong?
     
    Thanks,
     
    MarkD
     
     
     
     
     
     

    Attached Image(s)

    #5
    JPortici
    Super Member
    • Total Posts : 561
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 13:07:36 (permalink)
    0
    Are you using X 5.10? because i had no problem whatsoever downloading/installing. Didn't need to follow no instruction
    The plugin is VERY crude anyway (blocking code between operations, so it can appear stuck while it isn't)
    #6
    purdyd
    Senior Member
    • Total Posts : 116
    • Reward points : 0
    • Joined: 2004/03/22 21:02:01
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 13:13:28 (permalink)
    0
    it worked for me with MPLAD X IDE 5.10.  It seemed to work without any instructions.
     
    I think I would upgrade to 5.10 and try that. as JPortici said.
    #7
    MarkD
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2003/11/07 12:43:55
    • Location: Toronto, Canada
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/09 14:37:41 (permalink)
    0
    Thanks for the quick answers.   
    I should have mentioned that I am using MPLABX 5.10 and XC32 v2.15   (all the latest)
     
    I know I should start my own post regarding my problems but I'll make one last post here, and start a new post if needed.
     
    I've got Harmony Framework 2.06 running now and I'm following the instructions in the Harmony Configurator User's Guide V2.06.    On page 5, what you should see on the "Initial MHC Display" is mentioned.   Mine does not look like that, it does not have the SERVICES tab and Dashboard / Navigator.
     
    I've attache what the MHC  user's guide shows and also what my screen looks like.    Does anyone have an idea why mine is different?    I'n not sure if the documentation is incorrect or if I still have a bad install.
     
     
     
     
     
    post edited by MarkD - 2019/01/09 14:39:19

    Attached Image(s)

    #8
    PastrelloMarco
    Starting Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2013/08/30 12:26:20
    • Location: Venezia, Italy
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 07:03:36 (permalink)
    0
    hi all.
    I installed  MPLAB X 5_10 but i hace the same problem that 5_05.
    Java, Windows, Microchip IDE X and Harmony tools  are updated. What I can update yet?
     
    best regards

    Attached Image(s)

    #9
    JPortici
    Super Member
    • Total Posts : 561
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 07:09:33 (permalink)
    0
    MarkD
    I know I should start my own post regarding my problems but I'll make one last post here, and start a new post if needed.



    And yet you didn't. Please start another thread, because it adds confusion.
     
    @marco i actually live 40-something km from venice :)
    Anyway, can you give me more info? could be OS related... I did only try with windows 10 pro (1809)
    post edited by JPortici - 2019/01/10 07:11:38
    #10
    Jim Nickerson
    User 452
    • Total Posts : 5820
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 07:13:01 (permalink)
    0
    Be patient and wait for Harmony 3. https://www.microchip.com/forums/FindPost/1081916
    #11
    MarkD
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2003/11/07 12:43:55
    • Location: Toronto, Canada
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 11:43:26 (permalink)
    0
    Jack_M
    MarkD
    I know I should start my own post regarding my problems but I'll make one last post here, and start a new post if needed.



    And yet you didn't. Please start another thread, because it adds confusion.
     
    @marco i actually live 40-something km from venice :)
    Anyway, can you give me more info? could be OS related... I did only try with windows 10 pro (1809)




     
    I didn't start a new thread right away as I originally had exactly the same problem.   But now after using Framework 2 instead, I made some progress.   It didn't make sense to suddenly switch to a new thread for one last comment.
     
     
    #12
    JPortici
    Super Member
    • Total Posts : 561
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 13:39:30 (permalink)
    0
    Maybe not on facebook or the likes, but on a forum which is HEAVILY unmoderated it's up to us users to keep things going smoothly and follow the netiquette.
    Besides, you are hoping that people stumble on a thread with a completely unrelated title
    #13
    NKurzman
    A Guy on the Net
    • Total Posts : 17007
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/01/10 14:09:40 (permalink)
    5 (1)
    Just a note here, assuming it applies. Harmony ‘s MHC must match the version of Harmony you are using. MHC 2.05 will not work will 2.04. And just because 3.0 is available does not mean it will work with anything else but 3.0. MHC has never been backwards or forward compatible.
    #14
    m4l490n
    Junior Member
    • Total Posts : 105
    • Reward points : 0
    • Joined: 2010/06/15 22:21:39
    • Location: 0
    • Status: offline
    Re: Harmony Configurator 3 - Fail to load 2019/02/10 20:51:46 (permalink)
    0
    Is there any solution for this? I'm having the exact same problem.
     
    MCH 3.1.0.4
    Framework 3.1.0
    MPALBX 5.10
    #15
    Jump to:
    © 2019 APG vNext Commercial Version 4.5