Hot!MPLAB X v5.05: Cannot create, rename, or clone project configurations

Author
KTrenholm
Super Member
  • Total Posts : 556
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
2018/10/22 10:38:05 (permalink)
4.5 (2)

MPLAB X v5.05: Cannot create, rename, or clone project configurations

[EDIT] This seems to have been fixed in v5.10
 
So I'm running into an issue on MPLAB X v5.05.  I'm attempting to create a second project config (one for testing/debug, the other for release builds) and I can't seem to do so.
 
I go to Project Properties > Manage Configurations > Rename in order to rename the current "default" config to "Release". 
Clicking OK to save this change doesn't change the config name and when I return to the "Project Properties" window, I cannot navigate the "Categories" panel at all.  I can change things in the already opened window, such as Hardware Tool and Toolchain, and the OK, Cancel, and Apply buttons will close the Project Properties window, but OK and Apply do NOT save the change in config name.
 
This occurs both when the project is or is NOT the active project.  I have attempted Rebooting X and closing/reloading the project but neither does anything. 
 
Attempting to duplicate the current config is also broken in what seems like the same way. Same unresponsive behavior occurs in the Project Properties window and the new configuration does not appear on the list.  Trying to switch the active config to the newly created one in the "Manage Configurations" window also does not seem to do anything.
 
I'm running on Windows 7 x64 6.1.7601
I am also running the patch for deadlock on v5.05 (https://www.microchip.com/forums/FindPost/1068572)
 
Has anyone else seen this? 
Possibly related to: https://www.microchip.com/forums/m1071595.aspx
 
 
 
post edited by KTrenholm - 2018/11/12 14:23:27
#1

16 Replies Related Threads

    KTrenholm
    Super Member
    • Total Posts : 556
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/22 10:45:33 (permalink)
    0
    Just after posting I found that I can get the name change to stick if I make the name change, then back in project properties if I select a different toolchain and "Apply" it will suddenly show the new name.
     
    This works to get a rename though, but does not work on trying to duplicate/create a new config.
    #2
    davekw7x
    Entropy++
    • Total Posts : 1586
    • Reward points : 0
    • Joined: 2012/01/16 12:01:07
    • Location: Left Coast, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/22 16:42:40 (permalink)
    0
    KTrenholm
    This works to get a rename though, but does not work on trying to duplicate/create a new config.



    I found it to be hit-or-miss.
    At first I thought it only affected projects that MPLABX converted from version 4.20, but then I found that it (sometimes usually always) happens with fresh 5.05 projects.
    One user said that he manually edited nbprojects/configurations.xml to add the new configurations.  Not being that bold (and not having enough time from my other projects), I just went back to MPLABX version 5.00 and created all of the configurations, then went back to 5.05 to finish the job.
     
    It also crossed my mind that the problem is with the Linux-specific version.
     
    My setup:
    MPLABX version 5.05 running under 32-bit Centos 6.10 Linux has this problem. MPLABX version 5.00 does not.  (But I need 5.05 for other stuff.)
     
     
    Regards,

    Dave
    post edited by davekw7x - 2018/10/22 16:45:38

    Sometimes I just can't help myself...
    #3
    KTrenholm
    Super Member
    • Total Posts : 556
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/23 06:47:15 (permalink)
    0
    Good to know it's not just me at least.
    The project this is currently a problem on is a 5.05 project.
     
    I may go the xml editing route I guess.
     
    P.S. Does anyone know why mplab just keeps dumping this into my project.xml?
                <formatting>
                    <project-formatting-style>false</project-formatting-style>
                </formatting>
    MPLAB X just keeps sticking that in there, I've got like 15 of them in sequence by now.
    #4
    LaoMa
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2017/08/01 21:39:42
    • Location: 0
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/25 18:51:03 (permalink)
    0
    Hello,
    I have been having the same problem but it is not just for version 5.05, also 5.00 has the same issue!!!!!!!!
    Simply, I did not have to copy/rename project after I installed IDE 5.00 and 5.05 because I was working in the same project.
     
    Now, I need to have a similar project and I attempted to copy/rename a project continue to create the "original_project_name" files in "......\dist\default\production".
     
    The Build and the Make buttons have the tooltip which show still the original name of the project...
    After some tentatives (but I do not remember the exact sequence of the operations done), I was able to change those tooltips to show the new name project and after that I was able to upload the file in the target board.
     
    It is a real bug, how long does Microchip need to publish a new version or just a patch to close this?
     
    thanks for a quick reply....
    post edited by LaoMa - 2018/10/25 20:01:36
    #5
    Jim Nickerson
    User 452
    • Total Posts : 5578
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/26 06:32:07 (permalink)
    +1 (1)
    LaoMa
    Hello,
    I have been having the same problem but it is not just for version 5.05, also 5.00 has the same issue!!!!!!!!
    Simply, I did not have to copy/rename project after I installed IDE 5.00 and 5.05 because I was working in the same project.
     
    Now, I need to have a similar project and I attempted to copy/rename a project continue to create the "original_project_name" files in "......\dist\default\production".
     
    The Build and the Make buttons have the tooltip which show still the original name of the project...
    After some tentatives (but I do not remember the exact sequence of the operations done), I was able to change those tooltips to show the new name project and after that I was able to upload the file in the target board.
     
    It is a real bug, how long does Microchip need to publish a new version or just a patch to close this?
     
    thanks for a quick reply....


    Maybe it would help to open a support ticket https://support.microchip.com
    #6
    KTrenholm
    Super Member
    • Total Posts : 556
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/26 06:46:43 (permalink)
    +1 (1)
    LaoMa it sounds like your issue is related to copying entire projects, not copying configurations within projects.
    I've seen threads pop up here regarding issues copying projects for as long as I've been using MPLAB X around v2.50 so I wouldn't exactly count on it being fixed anytime in the immediate future.
     
    In any case, different issue from what myself and davekw7x (and this guy) are having.

    #7
    LaoMa
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2017/08/01 21:39:42
    • Location: 0
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/29 17:44:36 (permalink)
    0
    Thanks,
     
    to KTrenholm. you are right, but at the 1st reading I saw that it is exactly the same behavior I have found when copy/rename a project.
    to Jim.Nickerson . I have tried to open a ticket but for some reason I cannot go behind the 1st pass: I fill all fields, both mandatory and not, but when I press NEXT, the page after a while shows me ever the title field like there is an error .... I tried to change wording, characters etc, but nothing has worked. Then I post here....
     
    Bye and thanks again
    post edited by LaoMa - 2018/10/29 17:46:59
    #8
    Jim Nickerson
    User 452
    • Total Posts : 5578
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/10/30 07:43:10 (permalink)
    +1 (1)
    I wonder if you saw this page, registered for support and got an email response ?
    Attachments are not available: Download requirements not met
     

    Attachment(s)

    Attachments are not available: Download requirements not met
    #9
    Doug Richard
    Super Member
    • Total Posts : 254
    • Reward points : 0
    • Joined: 2003/11/07 12:42:00
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/06 07:02:27 (permalink)
    0
    Got the same issue here.  Any resolution?

    Doug Richard
    = != ==
    #10
    KTrenholm
    Super Member
    • Total Posts : 556
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/06 08:03:55 (permalink)
    +1 (1)
    No fix yet.  I've got a ticket open about the problem, will post back if I get anything back of any use.
    #11
    vjasinski
    Super Member
    • Total Posts : 140
    • Reward points : 0
    • Joined: 2013/04/30 11:48:06
    • Location: Michigan, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/09 12:49:36 (permalink)
    +2 (2)
    I had the same problem. Seems to be fixed in V5.10
    #12
    RISC
    Super Member
    • Total Posts : 5359
    • Reward points : 0
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/09 14:51:06 (permalink)
    0
    Hi,
    I reported this issue some time ago and I was told it will be fixed in MPLAB v5.10
    Regards
    #13
    KTrenholm
    Super Member
    • Total Posts : 556
    • Reward points : 0
    • Joined: 2012/08/08 14:04:23
    • Location: Connecticut, USA
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/12 10:00:17 (permalink)
    +1 (1)
    According to my microchip ticket, this should be fixed in 5.10, which is now live.
     
    I haven't really put it through all the paces but I'm able to change the names of my configs now, so far so good.
    #14
    RISC
    Super Member
    • Total Posts : 5359
    • Reward points : 0
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/12 13:54:45 (permalink)
    0
    Hi,
    I confirm that this is fixed in MPLAB X v5.10 ;=)
    Regards
     
    #15
    dan1138
    Super Member
    • Total Posts : 2897
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/12 15:31:57 (permalink)
    0
    Related but a little off topic.
     
    Has anyone noticed that the MPLABX documentation that new user depend on has become a bit dated:
    Attachments are not available: Download requirements not met

    Attachment(s)

    Attachments are not available: Download requirements not met
    #16
    qhb
    Superb Member
    • Total Posts : 7891
    • Reward points : 0
    • Joined: 2016/06/05 14:55:32
    • Location: One step ahead...
    • Status: offline
    Re: MPLAB X v5.05: Cannot create, rename, or clone project configurations 2018/11/12 15:36:36 (permalink)
    +2 (2)
    Does that mean the guide has been correct all along, and they're just trying to get the software to do what the manual says ever since? ;)
     
    #17
    Jump to:
    © 2018 APG vNext Commercial Version 4.5