• AVR Freaks

MPLABX 5.05 cannot find assembler

Author
K3PTO
Starting Member
  • Total Posts : 58
  • Reward points : 0
  • Joined: 2014/07/06 13:09:14
  • Location: Camdenton, mo
  • Status: offline
2018/10/13 12:32:17 (permalink)
0

MPLABX 5.05 cannot find assembler

I just attempted to re-install MPLABX 5.05 and it cannot find the assembler.  I attempted to force it using:
Tools - Options - Embedded - Build Tools and attempted to point it to the folder with the assembler.  It tells me that there is no tool chain there!
I have NOT installed it to the default folder.  However, I have successfully installed MPLABX to non-default folders successfully since MPLAB 3.  I did successfully install 5.05 to the same file path on another computer so I know it should work.
Both computers are running Windows 10 pro 64 bit.
Any help will be greatly appreciated.
 
post edited by K3PTO - 2018/10/15 07:53:24
#1

11 Replies Related Threads

    Danno
    Super Member
    • Total Posts : 273
    • Reward points : 0
    • Joined: 2005/09/07 10:12:10
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/15 12:23:27 (permalink)
    +1 (1)
    What part are you trying to get the assembler to work with?
     
    I just tried a project with MPLAB X v5.05, PIC16F18855 and selected mpasm v5.81.
     
    No issues for me.
     
    #2
    K3PTO
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2014/07/06 13:09:14
    • Location: Camdenton, mo
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/15 14:09:47 (permalink)
    0
    Hi Danno,
    I can't get that far!  My install will not find an assembler nor will it allow me to point to one.
     
     
    #3
    Danno
    Super Member
    • Total Posts : 273
    • Reward points : 0
    • Joined: 2005/09/07 10:12:10
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/15 16:12:49 (permalink)
    0
    Hmmm..  Yea seems something is broken.  Seems when MPLAB X is installed non-standard, it can't find the tool chains.
    What was the last version that did work?
    #4
    K3PTO
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2014/07/06 13:09:14
    • Location: Camdenton, mo
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/15 17:30:27 (permalink)
    0
    Hi Danno,
    Thank you for taking the time to respond.  I did successfully install 5.05 and had it running for a while.  However, due to circumstances I had to un-install it and then was when my attempt to re-install ran into this problem.
     
    #5
    Jim Nickerson
    User 452
    • Total Posts : 6376
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: MPLABX 5.05 cannot find assembler 2018/10/16 07:01:35 (permalink)
    +1 (1)
    Maybe the user dir/cache needs to be erased/deleted
    #6
    K3PTO
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2014/07/06 13:09:14
    • Location: Camdenton, mo
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/16 17:18:21 (permalink)
    0
    Hi Jim,
     
    That may be but how do I do that?
    #7
    qhb
    Superb Member
    • Total Posts : 9999
    • Reward points : 0
    • Joined: 2016/06/05 14:55:32
    • Location: One step ahead...
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/16 17:27:06 (permalink)
    +1 (1)
    The help/about screen tells you where they are.
    Just use Windows Explorer to delete all the files in those folders.
     

    Nearly there...
    #8
    K3PTO
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2014/07/06 13:09:14
    • Location: Camdenton, mo
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/17 12:24:16 (permalink)
    0
    Thank you qhb,
     
    That should do it!
    #9
    Danno
    Super Member
    • Total Posts : 273
    • Reward points : 0
    • Joined: 2005/09/07 10:12:10
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/23 13:42:27 (permalink)
    0
    Did JN's suggestion to clear the Cache work?  
    #10
    K3PTO
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2014/07/06 13:09:14
    • Location: Camdenton, mo
    • Status: offline
    Re: MPLABX 5.05 cannot find assembler 2018/10/23 14:50:36 (permalink)
    +1 (1)
    Sorry I did not respond sooner.  Yes, it did.
    #11
    Jim Nickerson
    User 452
    • Total Posts : 6376
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: online
    Re: MPLABX 5.05 cannot find assembler 2018/10/24 08:58:40 (permalink)
    0
    When you re installed the original cache dir was re used with the original problems...
    #12
    Jump to:
    © 2019 APG vNext Commercial Version 4.5