SDO runtime error

Author
xman236
New Member
  • Total Posts : 25
  • Reward points : 0
  • Joined: 2018/10/05 07:32:05
  • Location: 0
  • Status: offline
2018/10/11 12:23:57 (permalink)
0

SDO runtime error

Hi guys,
 
above is the wiring of my CANbus. D1 is where the sensor values are coming from the robot. D4 is the radio receiver for the remote controller of the robot. The problem that I have is, the CANbus 1 is directly connected to the CANbus so that the CANbus is always fed with the information from the remote controller. So I do not have any chance to control the robot via CANbus, since my message gets overwritten all the time with the value from the remote controller.
So I thought I disconnect the terminals 4 and 5 and attach the CAN_H and CAN_L from my Laptop to there.
 
However when I start the robot using the remote controller, I get this "SDO runtime error" as in the attached screenshot.
Does anyone have a clue what this error causes?

Attached Image(s)

#1

1 Reply Related Threads

    qhb
    Superb Member
    • Total Posts : 7159
    • Reward points : 0
    • Joined: 2016/06/05 14:55:32
    • Location: One step ahead...
    • Status: online
    Re: SDO runtime error 2018/10/11 12:26:40 (permalink)
    0
    This is a continuation of https://www.microchip.com/forums/m1070618.aspx
    (Useful to know the context of what is being asked)
     

    Worst forum problems are now fixed, but the damn firewall is still there.
    #2
    Jump to:
    © 2018 APG vNext Commercial Version 4.5