XC8 V2 - includes not found, unstable internet connection message, etc...

Author
rgable@morbros.com
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2018/10/10 08:26:53
  • Location: 0
  • Status: offline
2018/10/10 12:46:11 (permalink)
0

XC8 V2 - includes not found, unstable internet connection message, etc...

Manually installed XC8 v2.0. Told this operation was a success.
Open the IDE and the project.
Open project properties ... "Internet connection is not stable enough to download latest toolchain" message box.
Our IT guy tells me this is a source folks issue, not ours. Click on OK
Select XC8 (v2.00) ... Apply ...
Another "internet connection..." message box. Click on OK
Click on OK button, properties.
Another "internet connection..." message box. Click on OK
Now, these are not found.
    #include "stdbool.h"
    #include <xc.h>
If I revert back to v1.45, everything seems to be just fine.
What's up with v2.00?
 
 
#1

7 Replies Related Threads

    JPortici
    Super Member
    • Total Posts : 377
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/10 13:30:04 (permalink)
    0
    Hi, the includes not found is a common issue, it's because they added an include directive to a file that doesn't exist (and is never used)
    Hope it will be fixed in 2.05
     
    The connection not stable enough issue, i only had it with MPLABX 5.00, no issues in 5.05
    5.05 also solves the "cannot modify variables in the watch view during debug" issu
    #2
    du00000001
    Just Some Member
    • Total Posts : 2118
    • Reward points : 0
    • Joined: 2016/05/03 13:52:42
    • Location: Germany
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/10 13:48:19 (permalink)
    +1 (1)
    "Internet connection nor stable enough" is usually an issue on the user's side, although from time to time Microchip might be the source.
    Observe repeatedly (once per day or so): if the issue persists, it's on your side - whatever your IT "guru" is telling you.

    PEBKAC / EBKAC / POBCAK / PICNIC (eventually see en.wikipedia.org)
    #3
    mad_c
    Super Member
    • Total Posts : 1107
    • Reward points : 0
    • Joined: 2010/12/12 17:48:27
    • Location: Brisbane, Australia
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/10 14:23:25 (permalink)
    +1 (1)
    rgable@morbros.com
    Now, these are not found.
        #include "stdbool.h"
        #include <xc.h>
    If I revert back to v1.45, everything seems to be just fine.
    What's up with v2.00?

    There has been reports of code generated by MCC including files that it shouldn't have, but there should be no problems with XC8 2.00 including the files that you mentioned. Can you provide any more details?
     
    Jeff
    #4
    JPortici
    Super Member
    • Total Posts : 377
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/10 22:37:08 (permalink)
    +1 (1)
    du00000001
    "Internet connection nor stable enough" is usually an issue on the user's side, although from time to time Microchip might be the source.
    Observe repeatedly (once per day or so): if the issue persists, it's on your side - whatever your IT "guru" is telling you.




    Although to me (and apparently many other users from what i gathered on the forum) the issue appeared the moment i installed X 5.00, wouldn't be there if i opened another version of X and went away with X 5.05
     
    mad_c
    rgable@morbros.com
    Now, these are not found.
        #include "stdbool.h"
        #include <xc.h>
    If I revert back to v1.45, everything seems to be just fine.
    What's up with v2.00?

    There has been reports of code generated by MCC including files that it shouldn't have, but there should be no problems with XC8 2.00 including the files that you mentioned. Can you provide any more details?
     
    Jeff




    i bet his problem is this https://www.microchip.com/forums/m1058957.aspx
    post edited by JPortici - 2018/10/10 22:38:32
    #5
    rgable@morbros.com
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/10/10 08:26:53
    • Location: 0
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/11 04:45:40 (permalink)
    0
    From our IT guy...
    "
    If you guys have support on the product I’d recommend creating a ticket.
     
    It seems when your machine connects to download a XML file from Mchip it is getting a status code of 301.
     
    2018:10:10-09:41:36 dbq-fw01 httpproxy[25881]: id="0001" severity="info" sys="SecureWeb" sub="http" name="http access" action="pass" method="GET" srcip="192.168.1.129" dstip="172.224.189.96" user="" group="" ad_domain="" statuscode="301" cached="0" profile="REF_DefaultHTTPProfile (Default Web Filter Profile)" filteraction="REF_DefaultHTTPCFFAction (Default content filter action)" size="178" request="0xc3d30000" url="http://www.microchip.com/rss/Recent-MPLABXSoftware.xml" referer="" error="" authtime="0" dnstime="1" cattime="414" avscantime="0" fullreqtime="4360957" device="0" auth="0" ua="Java/1.8.0_144" exceptions="av,sandbox,fileextension" category="175" reputation="trusted" categoryname="Software/Hardware" content-type="text/html"
     
    If that’s the case it looks to be on the server-side having issues: https://airbrake.io/blog/http-errors/301-moved-permanently
     
     
    If you go the page serving the XML it does list the URL’s for the updates if you needed to download them manually: https://www.microchip.com/rss/Recent-MPLABXSoftware.xml
    "
    #6
    rgable@morbros.com
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/10/10 08:26:53
    • Location: 0
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/11 04:49:22 (permalink)
    0
    "There has been reports of code generated by MCC including files that it shouldn't have, but there should be no problems with XC8 2.00 including the files that you mentioned. Can you provide any more details?"
     
    The code compiled and worked fine using the older version.  Select XC8 v2.00 and now my includes cannot be found.
    I don't know what more detail I can give.  Yes, this was the magic code generator generated code, but how should that affect whether the basic #includes are found.  I guess I am lost on that one.
     
    #7
    mad_c
    Super Member
    • Total Posts : 1107
    • Reward points : 0
    • Joined: 2010/12/12 17:48:27
    • Location: Brisbane, Australia
    • Status: offline
    Re: XC8 V2 - includes not found, unstable internet connection message, etc... 2018/10/11 14:01:33 (permalink)
    +1 (1)
    rgable@morbros.com 
    The code compiled and worked fine using the older version.  Select XC8 v2.00 and now my includes cannot be found.
    I don't know what more detail I can give.  Yes, this was the magic code generator generated code, but how should that affect whether the basic #includes are found.  I guess I am lost on that one.

    If you create a new project with an empty main and include the <xc.h> header, does that still fail? If so, can you show the build command and errors?
     
    If you are building MCC code, you would want to make sure that it is building for C90, as that is what the generated code has been tested against. It is possible that the IDE has selected C99 when the project was migrated. That should not stop <xc.h> being found, but could produce a number of other errors that might cascade into a mess.
     
    I am away for a couple weeks but someone else might be able to help based on your comments.
     
    Jeff.
    #8
    Jump to:
    © 2018 APG vNext Commercial Version 4.5