• AVR Freaks

AnsweredHot!Forum; can't post

Page: 12 > Showing page 1 of 2
Author
GreenGiant
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2018/09/25 06:10:02
  • Location: 0
  • Status: offline
2018/10/08 04:03:20 (permalink)
0

Forum; can't post

Hi I am trying to post a request for help in the forum for PIC18 but I keep getting an error message.  Can anyone help?  I can't seem to find a way to submit a support ticket, only view open ones (of which there aren't any).
Regards
 
Access Denied
You don't have permission to access "http://www.microchip.com/forums/post.aspx?" on this server.
Reference #18.76a3c017.1538996464.116cc17
#1
qhb
Superb Member
  • Total Posts : 9998
  • Reward points : 0
  • Joined: 2016/06/05 14:55:32
  • Location: One step ahead...
  • Status: offline
Re: Forum; can't post 2018/10/08 04:56:16 (permalink) ☼ Best Answerby GreenGiant 2018/10/08 05:49:51
0
Your post probably contains some text triggering the stupid firewall.
Make sure you use code tags around code, and avoid any mention of Apple product names, or function names containing "char" immediately by a "(".
 

Nearly there...
#2
GreenGiant
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2018/09/25 06:10:02
  • Location: 0
  • Status: offline
Re: Forum; can't post 2018/10/08 05:59:27 (permalink)
0
Awesome, many thanks.  Didn't think of that.  It didn't like the image file URLs to prnt.sc
#3
Jim Nickerson
User 452
  • Total Posts : 6021
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: online
DaleSchultz
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2019/01/08 19:31:45
  • Location: Maine, USA
  • Status: offline
Re: Forum; can't post 2019/01/09 15:52:50 (permalink)
0
in my case I setup my user profile first and I had a URL in my signature...
 
#5
xdev
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2019/03/04 06:11:05
  • Status: offline
Re: Forum; can't post 2019/03/06 06:59:59 (permalink)
0
Problem still exists...
#6
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 07:08:37 (permalink)
5 (1)
I found this works for me:
Highlight the text between {code} and {/code} then select font family Courier New.
post edited by Gort2015 - 2019/03/06 07:12:11

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#7
xdev
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2019/03/04 06:11:05
  • Status: offline
Re: Forum; can't post 2019/03/06 07:29:02 (permalink)
0
There was no code on my post...(?)
#8
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 08:02:53 (permalink)
0
Change the whole text to Courier New.

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#9
xdev
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2019/03/04 06:11:05
  • Status: offline
Re: Forum; can't post 2019/03/06 08:03:55 (permalink)
0
ok thx, will try it!
#10
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 08:20:45 (permalink)
0
It works for me on code but I wait with antisipasion to see if it works for you.

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#11
KTrenholm
Super Member
  • Total Posts : 709
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: Forum; can't post 2019/03/06 08:45:49 (permalink)
0
Gort2015
Change the whole text to Courier New.




If this works this is the most amazing workaround.  How did you discover that?
#12
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 08:53:03 (permalink)
0
I discovered it by accident, I was posting some code, the forum software refused it.
I wanted it lined up so that it looked neat and tidy, I changed the font to Courier New and it just worked.
 
I was then going to change the text to remove any, "char" forum bugs but I didn't have to.
post edited by Gort2015 - 2019/03/06 08:54:43

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#13
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 09:09:48 (permalink)
0
This is strange, I'll link to the post that worked for me.

The original code was in assembly but it contained text such as char.
 
https://www.microchip.com/forums/m1088742.aspx#1089009
Post #5 and Post #6
 
It was split in two to edit the line causing the forum bug.

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#14
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 09:12:25 (permalink)
0
I will now try it again:
;----------------------------------------------------
;----------------------------------------------------
;----------------------------------------------------
.equ arg_Text,      w0
.equ txt,           w0  ;psuedym
.equ txtlen,        w1
.equ maxalpha_l,    w2
.equ minalpha_l,    w3
.equ maxdec,        w4
.equ mindec,        w5
.equ maxalpha_h,    w6
.equ minalpha_h,    w7
.equ TXT,           w8  ;global
.equ _PC,           w9  ;global
.equ tmp,          w10
.equ SP,           w15
;rtn txt,           w0
;rtn txtlen,        w1
;rtn valid,          Z

symbol_valid:
    push    w10
    mov     #'0',mindec
    mov     #'9',maxdec
    mov     #'A',minalpha_h
    mov     #'Z',maxalpha_h
    mov     #'a',minalpha_l
    mov     #'z',maxalpha_l
    setm    txtlen
    bclr    WS2412B_Flag,#WSFLAG_TMP    ;err flag
    bra     $+4
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
looptxtlensp:
    ;ready for next entry
    dec2    SP,SP       ;clear flim stack
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
looptxtlen:
    ;get char, ascii 'A' - 'Z', '0' - '9' or '_'
    inc     txtlen,txtlen
    ze      [txt++],tmp
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ;underscore ok
    cp      tmp,#'_'
    bra     z,looptxtlen
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ;decimal and alpha was first?
    push    tmp
    flim    maxdec,tmp
    bra     nz,tryupper
    btss    WS2412B_Flag,#WSFLAG_TMP    ;alpha flag?
    bra     err_syntaxsp
    bra     looptxtlensp
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
tryupper:
    ;uppercase?
    mov     [SP-2],tmp
    flim    maxalpha_h,tmp
    bra     nz,trylower
    bset    WS2412B_Flag,#WSFLAG_TMP    ;alpha flag
    bra     looptxtlensp
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
trylower:
    ;lowercase?
    flim    maxalpha_l,[--SP]
    bra     nz,$+6
    bset    WS2412B_Flag,#WSFLAG_TMP    ;alpha flag
    bra     looptxtlen
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ;found symbol, at least one alpha?
    btss    WS2412B_Flag,#WSFLAG_TMP    ;alpha flag
    bra     err_syntax
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ;back 1
    dec     txt,txt
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ;success, w0 = txt, w1 = txtlen
    pop     w10
    bset    SR,#Z
    return
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
err_syntaxsp:
    dec2    SP,SP   ;clear tmp
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
err_syntax:
    dec2    SP,SP   ;clr flag
    ;~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
err_syntaxspclr:
    pop     w10
    bclr    SR,#Z
    return
;----------------------------------------------------
;----------------------------------------------------
;----------------------------------------------------

 

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#15
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 09:14:56 (permalink)
0
Just tried it again and it worked.
That code will not get excepted by the forum software.
Again, changing the font to Courier New and it works.
 
post edited by Gort2015 - 2019/03/06 09:22:43

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#16
Gort2015
Klaatu Barada Nikto
  • Total Posts : 3122
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: Forum; can't post 2019/03/06 09:20:49 (permalink)
0
I was thinking that the blue highlighted (not by me) would be the ones that cause the forum software to not except.

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#17
xdev
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2019/03/04 06:11:05
  • Status: offline
Re: Forum; can't post 2019/03/20 03:36:16 (permalink)
0
Highlight as code and define "Courier New" for font does not work!!!!!!

Problem: Access Denied
You don't have permission to access "http://www.microchip.com/forums/post.aspx?" on this server.
Reference #18.76a3c017.1538996464.116cc17

Solution: Avoid links!!
#18
xdev
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2019/03/04 06:11:05
  • Status: offline
Re: Forum; can't post 2019/03/20 03:39:37 (permalink)
0
When i remove links, it seems to work... WTF is that crap?!?

 

Problem: Access Denied
You don't have permission to access "http://www.microchip.com/forums/post.aspx?" on this server.
Reference #18.76a3c017.1538996464.116cc17

Solution: Avoid links!!
#19
qhb
Superb Member
  • Total Posts : 9998
  • Reward points : 0
  • Joined: 2016/06/05 14:55:32
  • Location: One step ahead...
  • Status: offline
Re: Forum; can't post 2019/03/20 05:56:18 (permalink)
5 (1)
It's a broken firewall installed on the web server, which has no knowledge of the forum operation.
See: How to avoid errors when editing posts
and
Expressions which trigger the firewall

Nearly there...
#20
Page: 12 > Showing page 1 of 2
Jump to:
© 2019 APG vNext Commercial Version 4.5