• AVR Freaks

AnsweredHot!dsPIC33CK Fcy Frequency

Page: < 1234 Showing page 4 of 4
Author
Howard Long
Super Member
  • Total Posts : 673
  • Reward points : 0
  • Joined: 2005/04/04 08:50:32
  • Status: offline
Re: dsPIC33CK Fcy Frequency 2019/05/02 06:56:43 (permalink)
0
NorthGuy
I always specify all config bits explicitly because I simply generate them with MPLAB X and then paste the generated text. So, I always had these bits cleared. This would explain why I could debug at 100 MHz while others couldn't.

 
That is my standard modus operandi too, although if I am trying to create a more readable example, I strip out what I consider to be unnecessary or irrelevant config bits as an aid to demonstrate the problem.
 
 
#61
bhave
Starting Member
  • Total Posts : 27
  • Reward points : 0
  • Joined: 2018/03/15 05:33:32
  • Location: 0
  • Status: offline
Re: dsPIC33CK Fcy Frequency 2019/05/02 10:51:59 (permalink)
0
Well, I think that solves it.  I can successfully run and debug the dsPIC33CK256MP506 at 100 MIPS when I add:
 
 
#pragma config ALTI2C1 = OFF

 
to the code from my previous posts.
#62
bboyanov
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2007/08/01 01:07:19
  • Location: 0
  • Status: offline
Re: dsPIC33CK Fcy Frequency 2019/05/02 23:30:08 (permalink)
0
Thanks spdmtl,
#pragma config ALTI2C1 = OFF allowed to run dsPIC33CK128MP205 even at 110MIPS  in FRCPLL and XTPLL modes.
I hope Microchip will explain, one day, function of the mysterious reserved bits FDEVOP<9:8>.
Regards,
bboyanov
post edited by bboyanov - 2019/05/02 23:44:21
#63
Page: < 1234 Showing page 4 of 4
Jump to:
© 2019 APG vNext Commercial Version 4.5