• AVR Freaks

Hot!Pickit 4 stopped working

Author
wireb
Starting Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2011/04/07 08:46:26
  • Location: 0
  • Status: offline
2018/08/13 19:39:58 (permalink)
5 (2)

Pickit 4 stopped working

Been having issues with Mplabx 5.0 crashing during programming on my PC. The latest crash seems to have messed up my Pickit 4. Now when I connect it to my PC it does not enumerate nor do any of the LEDs come on. If I swap it out for my Pickit 3 (and a micro usb cable) my PC sees it just fine and I can program my device. I have tried a different USB cable with no luck. 
 
I am wondering if somehow I interrupted a firmware update that left it in a bad state. Is there any way to bootstrap the Pickit 4 or reload it from a Pickit 3?
 
Thanks,
#1

9 Replies Related Threads

    Ken_Pergola
    Super Member
    • Total Posts : 2255
    • Reward points : 0
    • Joined: 2003/11/07 12:48:48
    • Status: offline
    Re: Pickit 4 stopped working 2018/08/13 21:08:31 (permalink)
    4.5 (2)
    wireb
    "...Is there any way to bootstrap the Pickit 4?..."
     



    Hello Peter,
     
    I'm sorry that you ran into this trouble with your MPLAB PICkit 4 tool.
    Would you be willing to try a few things that should take less than 5 minutes?
     
    1) Could you download the MPLAB PICkit 4 User's Guide?
    http://ww1.microchip.com/downloads/en/DeviceDoc/PICkit4%20In-Circuit%20DebuggerUG-DS50002751B.pdf
     
    2) On page 37, could you try the 3 steps near the bottom of the page to force the unit into Bootloader mode?
     
    3) If #2 does not pan out could you try the step in section 4.4.3 "How to Use the Hardware Tool Emergency Boot Firmware Recovery Utility" on page 38?
     
    Let us know if either of these steps get you back on track.
     
    I hope this helps.
     
    Best regards,
     
    Ken
    #2
    wireb
    Starting Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2011/04/07 08:46:26
    • Location: 0
    • Status: offline
    Re: Pickit 4 stopped working 2018/08/14 19:36:24 (permalink)
    5 (1)
    The emergency firmware boot firmware recovery fixed the issue. 
    Thanks for all the help! 
    #3
    Ken_Pergola
    Super Member
    • Total Posts : 2255
    • Reward points : 0
    • Joined: 2003/11/07 12:48:48
    • Status: offline
    Re: Pickit 4 stopped working 2018/08/14 20:23:06 (permalink)
    5 (1)
    wireb
    The emergency firmware boot firmware recovery fixed the issue...



    Hello Peter,
     
    Great! You are very welcome. Thanks for your willingness to try these steps and I'm super glad you are up and running again.
     
    Best regards,
     
    Ken
     
    P.S. I am not sure how you got into this state. If it happens again I would be interested in hearing what specific steps led up to this issue. Did the LED strip flash color magenta during suggestion #1 above (if you tried that suggestion first)?
    #4
    wireb
    Starting Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2011/04/07 08:46:26
    • Location: 0
    • Status: offline
    Re: Pickit 4 stopped working 2018/08/14 20:49:00 (permalink)
    5 (1)
    When I killed it MPLABx had just hung during a program cycle and I tried unplugging the PicKit to see if that would revive the program. (it did not. Had to kill Java to get it to close down). 
     
    After that point I had no led's at all when I plugged it back in. 
     
    Will let you know if I hit it again.
    #5
    Ken_Pergola
    Super Member
    • Total Posts : 2255
    • Reward points : 0
    • Joined: 2003/11/07 12:48:48
    • Status: offline
    Re: Pickit 4 stopped working 2018/08/14 20:54:51 (permalink)
    5 (1)
    Thank you Peter for your time and answers -- appreciated! I'll let you go (it's just the geek in me wondering how the tool got into this bad state). Have a great rest of the night (or day). 
    #6
    evren
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2021/02/27 04:55:18
    • Location: 0
    • Status: offline
    Re: Pickit 4 stopped working 2021/03/07 10:41:13 (permalink)
    0
    Hello there.
    Pickit stuck in 4 purple lights.
    resimag.com/i/59e1067dd707

    pk4 files.jar How to upload file.?
    Pickit 4 MPLAB X IPE recognizes.
     

    I've tried.

    Perform the following steps to force the debugger into bootload mode:
    1. Disconnect the Micro-B USB cable from the debugger.
    2. Press down on the MPLAB PICkit 4 logo and hold while plugging in the Micro-B
    USB cable. The light strip flashes purple. Continue pressing the logo until the
    light strip stops flashing and changes to steady on purple. You are now in bootloader
    mode.
    3. Try to reestablish communication with the MPLAB X IDE or MPLAB IPE. When
    successful, the firmware update is downloaded. When complete, the LED is
    steady on blue and the debugger is ready for operation.

    Please I would be glad if you could help.
    #7
    RISC
    Super Member
    • Total Posts : 6056
    • Reward points : 0
    • Status: offline
    Re: Pickit 4 stopped working 2021/03/08 16:52:49 (permalink)
    0
    Hi,
    Maybe this could be helpful :
    https://microchipdeveloper.com/snap:troubleshooting
    Regards
     

    For support make sure to check first here : http://microchipdeveloper.com
    There are hundreds of PIC, AVR, SAM...which one do YOU use ?
    #8
    evren
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2021/02/27 04:55:18
    • Location: 0
    • Status: offline
    Re: Pickit 4 stopped working 2021/03/08 19:45:13 (permalink)
    0
    PİCkit 4 was not lit when the first problem occurred.
    Hardware Tool Emergency Boot Firmware Recovery
    It has been done successfully.
    the light came on and remained purple.
    For the light to turn blue, the pk4 files.jar file must be loaded.
    how can I do it.
    #9
    evren
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2021/02/27 04:55:18
    • Location: 0
    • Status: offline
    Re: Pickit 4 stopped working 2021/03/08 20:08:48 (permalink)
    0
    Thanks to anyone who can help.

    MPLAB X IDE, MPLAB X IPE
    communication is being established.
    Recognizes PICkit 4.
    PICkit 4 lights are purple.
    The PICkit 4 lights should turn blue.

    pk4 files.jar How to upload file.?
    #10
    Jump to:
    © 2021 APG vNext Commercial Version 4.5