Helpful ReplyHot!MPLABX v5.00 freezes

Page: 12 > Showing page 1 of 2
Author
aeromorph
Starting Member
  • Total Posts : 63
  • Reward points : 0
  • Joined: 2014/05/08 04:50:19
  • Location: 0
  • Status: offline
2018/08/13 02:21:37 (permalink)
5 (1)

MPLABX v5.00 freezes

Hello, 
 
I opened a project created on the previous version and got the message that the project would be converted to mplabx 5. Accepted and worked on the project. Afterwards, compiled, saved and turn off the pc. Now, everytime I open MPLABX, it's freezed. I can't open it, I can't get it to work no matter what. 
 
I tried uninstaling and installing again, the projct still opened in it and freezes. It's rendered useless right now. 
 
Any clues on thie bug? 
 
Thanks. 
#1
Jim Nickerson
User 452
  • Total Posts : 5567
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/13 05:57:44 (permalink)
0
aeromorph
Hello, 
 
I opened a project created on the previous version and got the message that the project would be converted to mplabx 5. Accepted and worked on the project. Afterwards, compiled, saved and turn off the pc. Now, everytime I open MPLABX, it's freezed. I can't open it, I can't get it to work no matter what. 
 
I tried uninstaling and installing again, the projct still opened in it and freezes. It's rendered useless right now. 
 
Any clues on thie bug? 
 
Thanks. 


As you have already re installed.
I would first try deleting the Cache Directory, and powering down the PC ( including removing the power cord ).
If this does not help  delete Cache and User Directory and repeat the power cycle.
#2
KTrenholm
Super Member
  • Total Posts : 556
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/13 06:34:02 (permalink)
0
FWIW I've got what I think is the same problem with v5.00 (and 4.20 for that matter).  Hangs while loading projects on startup.
 
Deleting Cache/User directories temporarily fixes the problem and lets me get into the IDE, but of course every time you do that you're losing any custom IDE settings.  It also just comes back next boot.
 
Definitely try clearing the cache out though, let us know if it changes anything for you.
Should be able to find the cache at AppData\Local\mplab_ide
#3
ag70
Junior Member
  • Total Posts : 50
  • Reward points : 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/13 08:49:39 (permalink)
0
Only good solution for Mplab X v5.00 is uninstall process.
Return to any working version.

my config today: Dell Optiflex i7 4-core, win7 prof x64, 12GB RAM, SSD, Mplab X 4.10 (or 4.20 but only if necessary) + ICD4, PIC18F27K42, assembly only
#4
KTrenholm
Super Member
  • Total Posts : 556
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/13 09:01:31 (permalink)
+1 (1)
ag70
Only good solution for Mplab X v5.00 is uninstall process.
Return to any working version.




Basically this.
I'm back on 4.15 because it's the last one that I can actually use without hanging.
#5
Jim Nickerson
User 452
  • Total Posts : 5567
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/13 09:02:18 (permalink)
0
aeromorph,
Does the same thing happen with a newly created project after deleting cache and userdir ?
#6
northeastman
Senior Member
  • Total Posts : 124
  • Reward points : 0
  • Joined: 2009/11/07 05:49:38
  • Location: North East England
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/15 07:26:26 (permalink)
0
Hi,
2nd time I have tried to upgrade to V5.0 in the last 6 months!
Works a couple of times but then locks up and freezes on Project loading.
 
Tried deleting the Cache, and restarting the PC (ASUS X550C with 8Gb and I7- 2.8GHz cpu) Windows 10 up to date.
Also changed proxy setting to No Proxy (as in the upgrade notes), that don't work either.
 
Only way to stop MPLABX V5.00 is shut it down using the Task Manager.
Notice that there is sometimes residual mplabx.exe left in the process list.
 
Unable to work with V5.00 Any sign of a Fix?
 
Will revert back to V4.15 and then wait for next release with the fix.
Any help is appreciated on this subject, but we just don't have the time to experiment with an IDE that doesn't work!

Regards
Northeastman
#7
northeastman
Senior Member
  • Total Posts : 124
  • Reward points : 0
  • Joined: 2009/11/07 05:49:38
  • Location: North East England
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/15 07:39:17 (permalink)
+1 (1)
Hi...again
Just tried this.
Shut down V5.00 using 
Went to the folder holding the project in Windows explorer, and changed the name of the Folder where it is stored.
 
Run MPLBX V5.00 loads now but obviously with no project
Change the name of the project folder back again using Windows Explorer
Load the project OK
 
Appears to work for now.
Don't have the time to uninstall and reload V4.20 until next week so must press on.
Hope this helps others?

Regards
Northeastman
#8
aeromorph
Starting Member
  • Total Posts : 63
  • Reward points : 0
  • Joined: 2014/05/08 04:50:19
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/16 00:41:24 (permalink)
0
Hello all, 
Thanks everyone for the input. I managed to get it to work only deleting the content of "nbprojects" of the project I got stuck open. It seems there's something to do with the warning, on the first time you open a pre-v5.0 project, saying that the project will be converted to v5.0. I guess the bug in this conversion. 
 
Until Microchip resolves it, I believe this might be the workaround. 
 
#9
KTrenholm
Super Member
  • Total Posts : 556
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/16 06:09:32 (permalink)
0
Could absolutely be an issue with parsing the contents of nbproject but I don't know if it's an issue with the v5.00 conversion (at least for me), as I get the same freezing behavior on v4.20 as I do on v5.00.
#10
ag70
Junior Member
  • Total Posts : 50
  • Reward points : 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/16 07:49:00 (permalink)
0
Use 4.10 if you can (Pickit4 not supported yet). It's last (relatively) good version od Mplab X.

my config today: Dell Optiflex i7 4-core, win7 prof x64, 12GB RAM, SSD, Mplab X 4.10 (or 4.20 but only if necessary) + ICD4, PIC18F27K42, assembly only
#11
tdarlic
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2015/06/15 01:55:35
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/24 14:32:02 (permalink)
+1 (1)
I just updated today and the same thing happend to me. I updated to version 5.05 and the thing froze on each start. I have a bootloader project loading main firmware. I tried different things until i renamed the project folder, restarted the MPLABX and then renamed back project folder and reload all projects. Loads fine now on restart. Lets hope it will stay like this. It compiles now and programs PIC32MX without problems. 
#12
katela
Super Member
  • Total Posts : 1011
  • Reward points : 0
  • Joined: 2013/06/11 05:25:18
  • Location: South Africa
  • Status: offline
Re: MPLABX v5.00 freezes 2018/08/24 16:19:57 (permalink)
0
Seems like there are always issues with new MPLAB X updates.

Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
YouTube Tutorials: https://www.youtube.com/user/StudentCompanionSA
#13
mawadre
Starting Member
  • Total Posts : 20
  • Reward points : 0
  • Joined: 2014/12/03 02:48:20
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/12 01:21:23 (permalink)
0
I updated from 4.01 to 5.05 recently because 4.01 startet to freeze on startup since one of my team mates started to save the project using a newer MPLAB X version. Since I cannot easy switch GIT branches anymore (End MPLAB X, switch branch, restart MPLAB X -> MPLAB X is frozen). Now I every time have to delete the local settings completly. So I lose my keyboard shortcuts and lots of other changes and optimizations every time.
 
So now MPLAB X is again as unusable for professionals as Eclipse CDT was in the past. One of my coworkers already switched to Eclipse as his main IDE and uses MPLAB X only debugging and for creating the make file on a change...
#14
Jim Nickerson
User 452
  • Total Posts : 5567
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/16 08:32:49 (permalink)
0
This morning my MpLab X 5.05 "hung" on start up.
I started ProcMon and javaw was stuck on setting watch for file changes on "c:"
After waiting a while I killed the process and it started after a bit.
It sets watch for changes on quite a few directories.
#15
NTElectronics UK
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2011/10/07 05:12:12
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/16 23:25:29 (permalink)
0
Hi,
We raised a ticket with MS regarding V5.00 freezing. They wanted us to activate the Log but we failed to make them understand that when MPLABX freezes you are unable to activate the log - as everything is frozen, mouse keyboard etc. During the ticket V5.05 was released.
 
Any way below is an installation solution that works for us but it uses V5.05 NOT V5.00.
 
This last weekend we have installed V5.05 on the same machine as V4.15.
Our Process was as follows.
1. Download V5.05 onto a local drive
2. Open MPLABX V4.15 close all projects and then close V4.15
3. Install V5.05 and install in C:\Microchip\MPLABX\v5.05 we have never used the default location "C:\Program Files (x86)" as it contains ()'s that affect our users.
4. Select No Proxy on the install (we only run on local machines).
5. After installation accept V5.05 to copy the V4.15 settings - remember we removed the project in V4.15 so now V5.05 loads with no project.
6. Load a small project (ours was PIC16F1829 based), originally generated with MPLABX V4.15  and XC8 V4.15 and let V5.05 convert the project. This is not a critical project for use and is used as a test case.
7. Run the compiler XC8 V2.00 this produced a lot of RED errors
"(902) no chip name specified; use "PICC --CHIPINFO" to see available chip names"?? 
8. Change the project settings from C99 to C90 in Compiler and Linker settings produces the same errors, so reverted the project back to XC8 V4.15. Compiles without issues for the PIC16F1829.
Note: Don't understand these errors and the manual is not helpful for error 902, but for us it appears to be a combination of MPLABX V5.05 and XC8 V2.00.  The project was originally compiled with XC8 V2.00 in MPLABX V4.15 without any such issues.
9. So far MPLABX V5.05 appears to be working OK, so we will proceed, with caution, until confidence in this version is established by all our users.
 
Hope this helps others.
P.S. The test laptop is Windows 10 (up to date), and is Intel Core I7 with 8GB of memory. We run ICD3 for project debugs.
 
 
#16
azstudent
Moderator
  • Total Posts : 128
  • Reward points : 0
  • Joined: 2009/12/01 14:47:45
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/18 21:06:56 (permalink) ☄ Helpfulby mawadre 2018/09/20 00:33:02
+5 (5)

Unfortunately we were unable to duplicate the freeze issue during "Opening Projects" stage.
However we believe the issue is real and have fixed some areas.
Please try the fix using the instructions given below if you are interested and let us know if it is still an issue.
This is scheduled to be part of 5.10 release if things go well with this patch.

Instructions to apply the patch.

1. Close all instances of MPLAB X.
2. It is advisable to take a backup of your projects just to make sure you don't lose work.
3. Download the appropriate patch for the version you have installed. (hang_issue_*_v1.zip)
5.00 --> https://microchip.box.com...y9fputcq55jn97z9im2eqe
5.05 --> https://microchip.box.com...yuqsoxpi513xebyocc7yrx
4. Navigate to the installation folder and find mplab_ide/modules folder. i.e. C:\Program Files (x86)\Microchip\MPLABX\*\mplab_platform\mplab_ide\modules folder and unzip the downloaded zip file.
5. You should see a folder structure as ..................mplab_ide/modules/patches/com-microchip-mplab-nbide-embedded-makeproject/hang_issue_patch.jar


After following the above steps, you can test whether this patch fixes the issue you were facing.

Thank you for your help in testing the fix.
#17
mawadre
Starting Member
  • Total Posts : 20
  • Reward points : 0
  • Joined: 2014/12/03 02:48:20
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/19 07:29:08 (permalink)
+1 (1)
If I understood you right it was just enough to extract the ZIP file into the MPLAB installations modules folder. Just that - and then start MPLAB X right after? In that case it did help right now. Before extracting the ZIP MPLAB X hangs on opening my project, after extraction it did not hang any more. What did you guys change?
 
Thanks a lot!
#18
azstudent
Moderator
  • Total Posts : 128
  • Reward points : 0
  • Joined: 2009/12/01 14:47:45
  • Location: 0
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/19 09:24:24 (permalink)
0
Yes, extracting the zip in the specified folder is enough.
We suspected a deadlock between parsing the file and opening the project and that is what we fixed. Hopefully that is it. If you think this fixed the hang issue, please mark my previous comment as helpful so that others can also take advantage of that.
Thank you for testing the fix.
#19
Jim Nickerson
User 452
  • Total Posts : 5567
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: offline
Re: MPLABX v5.00 freezes 2018/09/19 09:37:01 (permalink)
0
The patch helped my startup hang while setting watch for changes deadlock.
#20
Page: 12 > Showing page 1 of 2
Jump to:
© 2018 APG vNext Commercial Version 4.5