Hot!Connectivity problem USB - External Memory Programmer ---- Solved ----

Author
RAFROY
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2018/08/01 03:28:14
  • Location: 0
  • Status: offline
2018/08/02 22:44:13 (permalink)
0

Connectivity problem USB - External Memory Programmer ---- Solved ----

Morning Microchip Forum!!
I'm a beginer and I hope we can help us... Well, I have a little problem, when I try to connect the External Memory programmer software to the PIC24FJ256DA210.
I installed the last driver (Vers. 1.0.0.7) wich is in the current MLA library v2017-03-06 for Windows. The PC detect and install the driver correctly, but when I run the programmer software and check the USB option in the settings, doesn't detect the device.
I tried with three diferent PC's under Windows 10 and 7 OS with the same result.
Also I tried with two PIC's with the same result.
 
I hope that somewere there are the solution,
 
Bye friends!
 
P.D. Sorry if isn't the correct forum.
post edited by RAFROY - 2018/09/21 01:58:35
#1

5 Replies Related Threads

    Wollli
    Senior Member
    • Total Posts : 62
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: Connectivity problem USB - External Memory Programmer 2018/08/03 05:25:06 (permalink)
    0
    I also have such Problems on different PC's.
    I'm using the Memory Programmer for an older Project of the PIC32MX795L with Graphics.
    On some Windows 7 Machines the Programmer does not find the Microcontroller.
     
    The driver seems to be installed correct, and after cable connection it appears in the PC driver list.
     
    But the application does not find the hardware. The same hardware can be found on another PC
    running win10/64 with a VMWare Win 7/64. There the application memory Programmer works always.
     
    I do not know what happens there in the drivers/application

    Wolfgang.Schroeder2@gmx.de
    #2
    Wollli
    Senior Member
    • Total Posts : 62
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: Connectivity problem USB - External Memory Programmer 2018/08/03 05:52:00 (permalink)
    3 (1)
    By using the memory programmer from the latest MLA (V2016_11_07) the problems were solved.
    The driver is still the same, also the microcontroller software!
     
    This runs on Windows 7 and Windows 10 !
     
    BR
      Wolli

    Wolfgang.Schroeder2@gmx.de
    #3
    RAFROY
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/08/01 03:28:14
    • Location: 0
    • Status: offline
    Re: Connectivity problem USB - External Memory Programmer 2018/08/06 00:08:35 (permalink)
    0
    Dear Wolli,
     
    Thank you so much for your quick reply. I tried it by the latest MLA (V2016_11_07) but doesn't work under Windows 7 (32bit) and Windows 10 (32bit), also I disabled the antivirus McAfee and I tried to three PIC's.
    Is possible that there are a Windows upgrade problem? Is better works in Windows 64bit?
     
    Newly, thank you Wolli, I will keep trying.
    #4
    Wollli
    Senior Member
    • Total Posts : 62
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: Connectivity problem USB - External Memory Programmer 2018/08/07 08:21:40 (permalink)
    0
    Hello Rafroy,
     
    I'm using only 64bit machines since Windows 7 and Windows 10 , so I cannot tell if it runs
    on 32 bit. I think it should, because it runs as java Application, but I never tested it.
     
    Best regards
       Wolli

    Wolfgang.Schroeder2@gmx.de
    #5
    RAFROY
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/08/01 03:28:14
    • Location: 0
    • Status: offline
    Re: Connectivity problem USB - External Memory Programmer 2018/09/21 01:57:23 (permalink)
    0
    Dear Wolli,
     
    Thank you so much for your reply... Finally I solved the problem. After to install the Windows 7 64bit and the installer driver MLA (V2016_11_07) works well....
    I tried it until with 5 PC's and Windows 7/10 of 32bits and didn't work. After to upgrade two PC's with Windows 7 64bits I had not problems, now work's well...
     
    Thank you so much newly.
     
    Best regards,
    #6
    Jump to:
    © 2019 APG vNext Commercial Version 4.5