Hot!MPLAB IPE 5.0 not launching on Win 10

Page: 12 > Showing page 1 of 2
Author
bptsj
Starting Member
  • Total Posts : 20
  • Reward points : 0
  • Joined: 2013/08/17 14:46:34
  • Location: 0
  • Status: offline
2018/08/01 07:23:18 (permalink)
5 (3)

MPLAB IPE 5.0 not launching on Win 10

I installed MPLAB IDE 5.0 and MPLAB IPE 5.0 on my windows 10 system as administrator and when I launch MPLAB IPE the I get a splash screen that is mostly empty. Every option I try says to select device but I have no user interface to select the device.  I've attached a screen shot of my opening window. I installed the same on my home laptop (Win 10) and it works fine. The MPLAB IDE seems to work okay.
 
When MPLAB IDE install asked if persistent folders should be deleted I selected yes.
 
Thanks,
Brian
 
 

Attached Image(s)

#1

31 Replies Related Threads

    Jim Nickerson
    User 452
    • Total Posts : 5458
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 07:33:57 (permalink)
    5 (1)
    It works on my Windows 10
    You seem to be in Advanced mode
    You might try clicking on the Restore Window Group Icon

    Attached Image(s)

    #2
    bptsj
    Starting Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2013/08/17 14:46:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 09:12:33 (permalink)
    5 (1)
    selecting the window icon stops the display of the options tool bar but now I notice in the lower right hand corner where it says:
    Tool:NA Device:NA and Environment:NA there is a small notification icon. When clicked the popup notification says there is a Java Null pointer exception (see attached).
     
    This works on my home laptop which is also windows 10.
     
    Brian
     

    Attached Image(s)

    #3
    DarioG
    Allmächtig.
    • Total Posts : 54081
    • Reward points : 0
    • Joined: 2006/02/25 08:58:22
    • Location: Oesterreich
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 09:15:58 (permalink)
    0
    non l'avete ancora capito che i software son fatti col CULO, da un po' di anni a oggi?

    GENOVA :D :D ! GODO
    #4
    Jim Nickerson
    User 452
    • Total Posts : 5458
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 09:49:15 (permalink)
    3.5 (2)
    I think maybe there was a problem installing, anti virus..
    Is this a corporate PC at work on a domain ?
    #5
    bptsj
    Starting Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2013/08/17 14:46:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 09:53:42 (permalink)
    0
    Argh! Yes it is a corporate network with lots of security and I need to login as administrator to install software. I'll see if I can disable anti-virus software before I re-install.
     
    Brian
    #6
    Jim Nickerson
    User 452
    • Total Posts : 5458
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 09:59:04 (permalink)
    0
    Are you installing on a local drive ?
    There are many corporate firewall/domain policies that may interfere with software installation.
    I might remove the ethernet cable during installation if temporarily disabling the virus/firewall does not help.
    #7
    DarioG
    Allmächtig.
    • Total Posts : 54081
    • Reward points : 0
    • Joined: 2006/02/25 08:58:22
    • Location: Oesterreich
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 10:30:00 (permalink)
    0
    corporate are evil. in 1 year, there will be nothing left...

    GENOVA :D :D ! GODO
    #8
    bptsj
    Starting Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2013/08/17 14:46:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 12:56:54 (permalink)
    5 (1)
    I tried installing while disconnected from the network, safe mode, and this didn't help. MPLAB IPV 5.0 still has a java error.
    What I did next was uninstall 5.0 and re-installed 4.15. Version 4.15 MPLAB IPV does load and programs using my picKit3.
    For now I can use this as a work around.
     
    I then installed v5.0 so I had both packages installed simultaneously. MPLAB IPE 5.0 has a java null pointer error and V4.15 continues to work. BTW, the "isolated" java version under each install is the same jre1.8.0_144.
     
    Brian
    #9
    CarpeCimex
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2012/04/05 18:24:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 15:48:53 (permalink)
    4.33 (3)
    I just installed IDE/IPE v5.0 and I have this in spades.  IDE seems to start up fine, but I get a complete blank for IPE:

    I just installed the latest Java, rebooted afterwards, and have installed, removed, and re-installed the IDE.  This is all on my local laptop, and my account is Administrator.  I'm not sure what to try next.
    post edited by CarpeCimex - 2018/08/01 15:50:17

    Attached Image(s)

    #10
    bptsj
    Starting Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2013/08/17 14:46:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 16:16:15 (permalink)
    4 (2)
    If you click on the tiny left most icon in the tray to the left of TOOLS:NA you will probably get an error notification of a Java null pointer exception error, at least I did. I also noted the "isolated" java install for both 4.51 and 5.0 is the same version of Java.
     
    Brian
    #11
    CarpeCimex
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2012/04/05 18:24:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 16:22:41 (permalink)
    0
    @bptsj: Yes, I did most of the time.  Once though, the tiny icon (which maybe looks like a red LED) was not there and clicking did not give me the Java runtime error.
    #12
    qɥb
    Monolothic Member
    • Total Posts : 3329
    • Reward points : 0
    • Joined: 2017/09/09 05:07:30
    • Location: Jupiter
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 16:37:23 (permalink)
    5 (1)
    How do you click on an icon that isn't there? ;)
     
    "As I was going up the stair
    I met a man who wasn't there!
    He wasn't there again today,
    Oh how I wish he'd go away!"


    This forum is mis-configured so it only works correctly if you access it via https protocol.
    The Microchip website links to it using http protocol. Will they ever catch on?
    PicForum "it just works"
    #13
    JPortici
    Super Member
    • Total Posts : 433
    • Reward points : 0
    • Joined: 2012/11/17 06:27:45
    • Location: Grappaland
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/01 22:48:55 (permalink)
    3 (1)
    which version of windows 10 are you running?
    I don't know if it was fixed but i had so many issues with software, programmers and old games when i installed the 2017 falls creators update (1709) that i rolled back immediately and blocked updates. I'm still on 1703
    #14
    CarpeCimex
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2012/04/05 18:24:34
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/08/02 09:09:45 (permalink)
    0
    @JPortici -- I have recent Win 10 Pro updates, version 1803, OS build 17134.137.  Everything else is running fine.  I'm not going to roll back Windows to fix Microchip's problem.
    #15
    tech24x7
    Starting Member
    • Total Posts : 42
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/09/02 22:59:48 (permalink)
    0
    It seems someother JRE version < 1.8 has been installed in your computer? Also try deleting and restart again
    %userprofile%\AppData\Roaming\mplab_ide\dev\verX.X
    #16
    nverwer
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2018/10/03 00:09:30
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/10/03 13:36:04 (permalink)
    5 (1)
    CarpeCimex
    I just installed IDE/IPE v5.0 and I have this in spades.  IDE seems to start up fine, but I get a complete blank for IPE:

    I had the same, including the NullPointerException. Sometimes, this exception does not show as the small orange dot, but it is in the log file (look in ..\AppData\Roaming\mplab_ide\dev\verX.X).
     
    When I installed the IDE/IPE on another PC, it just worked, but it did ask me to allow the program to go through the firewall (standard Windows 10 firewall).
    I have a different firewall (Avast) on the first computer, and it did not ask me to allow the program through. So to anyone experiencing this problem: Check if your firewall is blocking the IDE/IPE.
     
    Of course showing a blocked connection (sometimes) as a NullPointerException is not very elegant, and Microchip might want to improve this.
    #17
    dsMartyn
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2012/11/03 01:56:06
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/10/04 08:40:51 (permalink)
    0
    I have EXACT same issue on MacOS Mojave!
     
    no firewall/ antivirus just a stupid java error in the log file, i've tried 3 different versions of Java (using the config file to point to the jDK home) 
    #18
    dsMartyn
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2012/11/03 01:56:06
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/10/04 08:48:25 (permalink)
    0
    going into Admin mode i get an error icon, it looks like it's failing to load the device FXML info
     
    This is taken from the message log: 
     
    javafx.fxml.LoadException:
     
    /Applications/microchip/mplabx/v5.05/mplab_platform/mplab_ipe/modules/com-microchip-mplab-ipe.jar!/com/microchip/mplab/ipe/ui/device/DeviceFx.fxml
     
    IPE 5.05
    OS x Mojave 10.14
     

    at javafx.fxml.FXMLLoader.constructLoadException(FXMLLoader.java:2601)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2579)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2441)
    at javafx.fxml.FXMLLoader.load(FXMLLoader.java:2409)
    at com.microchip.mplab.ipe.ui.device.DeviceControlTopComponent.createScene(DeviceControlTopComponent.java:170)
    at com.microchip.mplab.ipe.ui.device.DeviceControlTopComponent.lambda$init$42(DeviceControlTopComponent.java:137)
    at com.sun.javafx.application.PlatformImpl.lambda$null$172(PlatformImpl.java:295)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$173(PlatformImpl.java:294)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
    Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(ArrayList.java:657)
    at java.util.ArrayList.remove(ArrayList.java:496)
    at com.sun.javafx.collections.ObservableListWrapper.doRemove(ObservableListWrapper.java:116)
    at javafx.collections.ModifiableObservableListBase.remove(ModifiableObservableListBase.java:179)
    at com.microchip.mplab.ipe.ui.device.DeviceFxController.initialize(DeviceFxController.java:309)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2548)
    ... 8 more
    Diagnostic information
    Input arguments:
    -Djdk.home=/Library/Java/JavaVirtualMachines/jdk1.8.0_171.jdk/Contents/Home
    -Dnetbeans.default_userdir_root=/Users/martyn/Library/Application Support/mplab_ipe
    -Dnetbeans.dirs=/Applications/microchip/mplabx/v5.05/mplab_platform/mplab_ipe:/Applications/microchip/mplabx/v5.05/mplab_platform/ide:/Applications/microchip/mplabx/v5.05/mplab_platform/mdbcore:/Applications/microchip/mplabx/v5.05/mplab_platform/mplablibs:/Applications/microchip/mplabx/v5.05/mplab_platform/nb:
    -Dnetbeans.home=/Applications/microchip/mplabx/v5.05/mplab_platform/platform
    -Dcom.apple.mrj.application.apple.menu.about.name=MPLAB X IPE
    -Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade
    -Djava.io.tmpdir=/tmp/mplab_ipe
    -Dstatistics.connect=false
    -Dcrownking.stream.verbosity=very-quiet
    -Xss2m
    -Xms256m
    -Xmx512m
    -Dapple.awt.graphics.UseQuartz=true
    -XX:+UseConcMarkSweepGC
    -XX:+CMSClassUnloadingEnabled
    -Dapt.limit.expanded.params=1000
    -Dplugin.manager.check.interval=EVERY_STARTUP
    -Dsun.java2d.noddraw=true
    -Dorg.netbeans.modules.extbrowser.UseDesktopBrowse=true
    -Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade
    -XX:+HeapDumpOnOutOfMemoryError
    -XX:HeapDumpPath=/Users/martyn/Library/Application Support/mplab_ipe/dev_ipe/v5.05/var/log/heapdump.hprof
    Compiler: HotSpot 64-Bit Tiered Compilers
    Heap memory usage: initial 256.0MB maximum 494.9MB
    Non heap memory usage: initial 2.4MB maximum -1b
    Garbage collector: ParNew (Collections=2 Total time spent=0s)
    Garbage collector: ConcurrentMarkSweep (Collections=1 Total time spent=0s)
    Classes: loaded=6945 total loaded=6945 unloaded 0
    INFO [org.netbeans.core.ui.warmup.DiagnosticTask]: Total memory 8,589,934,592
    INFO [null]: Total physical memory 8,589,934,592
    WARNING [org.openide.filesystems.Ordering]: Not all children in Menu/File/ marked with the position attribute: [Export, Import], but some are: [Separator3.instance]
    WARNING [org.openide.filesystems.Ordering]: Not all children in Menu/Help/ marked with the position attribute: [Readme Docs], but some are: [master-help.xml, Tool Help Contents, shortcuts.xml, Separator1.instance]
    SEVERE [global]
    java.lang.NullPointerException
    at com.microchip.mplab.ipe.login.LoginFXMLDocController.handleButtonAction(LoginFXMLDocController.java:121)
    Caused: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at sun.reflect.misc.Trampoline.invoke(MethodUtil.java:71)
    at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at sun.reflect.misc.MethodUtil.invoke(MethodUtil.java:275)
    at javafx.fxml.FXMLLoader$MethodHandler.invoke(FXMLLoader.java:1769)
    Caused: java.lang.RuntimeException
    at javafx.fxml.FXMLLoader$MethodHandler.invoke(FXMLLoader.java:1774)
    at javafx.fxml.FXMLLoader$ControllerMethodEventHandler.handle(FXMLLoader.java:1657)
    at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(CompositeEventHandler.java:86)
    at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:238)
    at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:191)
    at com.sun.javafx.event.CompositeEventDispatcher.dispatchBubblingEvent(CompositeEventDispatcher.java:59)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:58)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.EventUtil.fireEventImpl(EventUtil.java:74)
    at com.sun.javafx.event.EventUtil.fireEvent(EventUtil.java:49)
    at javafx.event.Event.fireEvent(Event.java:198)
    at javafx.scene.Node.fireEvent(Node.java:8413)
    at javafx.scene.control.Button.fire(Button.java:185)
    at com.sun.javafx.scene.control.skin.ButtonSkin.lambda$new$280(ButtonSkin.java:102)
    at com.sun.javafx.scene.KeyboardShortcutsHandler.processAccelerators(KeyboardShortcutsHandler.java:347)
    at com.sun.javafx.scene.KeyboardShortcutsHandler.dispatchBubblingEvent(KeyboardShortcutsHandler.java:163)
    at com.sun.javafx.event.CompositeEventDispatcher.dispatchBubblingEvent(CompositeEventDispatcher.java:59)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:58)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.EventUtil.fireEventImpl(EventUtil.java:74)
    at com.sun.javafx.event.EventUtil.fireEvent(EventUtil.java:49)
    at javafx.event.Event.fireEvent(Event.java:198)
    at javafx.scene.Node.fireEvent(Node.java:8413)
    at com.sun.javafx.scene.control.behavior.TextInputControlBehavior.forwardToParent(TextInputControlBehavior.java:432)
    at com.sun.javafx.scene.control.behavior.TextFieldBehavior.fire(TextFieldBehavior.java:183)
    at com.sun.javafx.scene.control.behavior.TextInputControlBehavior.callAction(TextInputControlBehavior.java:178)
    at com.sun.javafx.scene.control.behavior.BehaviorBase.callActionForEvent(BehaviorBase.java:218)
    at com.sun.javafx.scene.control.behavior.TextInputControlBehavior.callActionForEvent(TextInputControlBehavior.java:127)
    at com.sun.javafx.scene.control.behavior.BehaviorBase.lambda$new$74(BehaviorBase.java:135)
    at com.sun.javafx.event.CompositeEventHandler$NormalEventHandlerRecord.handleBubblingEvent(CompositeEventHandler.java:218)
    at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(CompositeEventHandler.java:80)
    at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:238)
    at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:191)
    at com.sun.javafx.event.CompositeEventDispatcher.dispatchBubblingEvent(CompositeEventDispatcher.java:59)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:58)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:56)
    at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
    at com.sun.javafx.event.EventUtil.fireEventImpl(EventUtil.java:74)
    at com.sun.javafx.event.EventUtil.fireEvent(EventUtil.java:54)
    at javafx.event.Event.fireEvent(Event.java:198)
    at javafx.scene.Scene$KeyHandler.process(Scene.java:3964)
    at javafx.scene.Scene$KeyHandler.access$1800(Scene.java:3910)
    at javafx.scene.Scene.impl_processKeyEvent(Scene.java:2040)
    at javafx.scene.Scene$ScenePeerListener.keyEvent(Scene.java:2501)
    at com.sun.javafx.tk.quantum.GlassViewEventHandler$KeyEventNotification.run(GlassViewEventHandler.java:217)
    at com.sun.javafx.tk.quantum.GlassViewEventHandler$KeyEventNotification.run(GlassViewEventHandler.java:149)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.tk.quantum.GlassViewEventHandler.lambda$handleKeyEvent$352(GlassViewEventHandler.java:248)
    at com.sun.javafx.tk.quantum.QuantumToolkit.runWithoutRenderLock(QuantumToolkit.java:389)
    at com.sun.javafx.tk.quantum.GlassViewEventHandler.handleKeyEvent(GlassViewEventHandler.java:247)
    at com.sun.glass.ui.View.handleKeyEvent(View.java:546)
    [catch] at com.sun.glass.ui.View.notifyKey(View.java:966)
    INFO [org.netbeans.modules.autoupdate.pluginimporter.Installer]: importing from null

    #19
    dsMartyn
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2012/11/03 01:56:06
    • Location: 0
    • Status: offline
    Re: MPLAB IPE 5.0 not launching on Win 10 2018/10/04 08:56:24 (permalink)
    0
    i just opened up the device xml and noticed it had x,y and width & height values so i changed my resolution and now it loads!
     
    so set your resolution lower and walah!
     
     
    #20
    Page: 12 > Showing page 1 of 2
    Jump to:
    © 2018 APG vNext Commercial Version 4.5