• AVR Freaks

Helpful ReplyHot!Issues installing 1.35 on Mac

Author
jtzeng
Super Member
  • Total Posts : 444
  • Reward points : 0
  • Joined: 2003/11/07 12:42:20
  • Status: offline
2018/07/31 23:11:30 (permalink)
0

Issues installing 1.35 on Mac

I have tried a number of time to install this version.
The IDE 4.20 see's it is there but cannot understand what to do with it.
See image.

Attached Image(s)


John Zigrang
JTZ Engineering, Inc.
#1
Aussie Susan
Super Member
  • Total Posts : 3559
  • Reward points : 0
  • Joined: 2008/08/18 22:20:40
  • Location: Melbourne, Australia
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/01 19:36:53 (permalink)
0
Have you tried a compile to see if it works?
I'm not really sure what problem you are having or the question you are asking.
Susan
#2
qɥb
Monolothic Member
  • Total Posts : 3332
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/01 20:02:27 (permalink)
0
Aussie Susan
...
I'm not really sure what problem you are having or the question you are asking.



I think it's the lack of a green or yellow bullet to the left of XC16 v1.35 they are commenting about.
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#3
jtzeng
Super Member
  • Total Posts : 444
  • Reward points : 0
  • Joined: 2003/11/07 12:42:20
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/01 21:43:45 (permalink)
0
The compiler cannot be called from the IDE on the mac.
It works fine from a PC.
There is something in the install on the Mac that is causing the IDE to not recognize this as a callable compiler.
I just installed 1.34 and it worked just fine.
The IDE and XC team need to get together to see what might be causing this.
 
With the IDE not showing any bullets on the XC16 1.35 should be a big indication.

John Zigrang
JTZ Engineering, Inc.
#4
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/02 11:32:40 (permalink)
0
I'm having the exact same issue.  Not only is the "green dot" missing (what exactly the green dot signifies I don't know), but so is the compiler version number!  If I attempt to select v1.35 in a project, I immediately get an error complaining about not being able to generate makefiles, and all build attempts fail.  I uninstalled and reinstalled, no change.  Reverting to v1.34 and everything works fine.  I submitted a support ticket yesterday.  Their response so far is that they cannot duplicate the problem.  I will post any updates here.
#5
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/06 10:52:15 (permalink)
0
Update: Installing XC16 v1.35 on a newer (2012) Mac running a newer OS (High Sierra 10.13.6) works fine.  More info to come as it becomes available.
#6
jtzeng
Super Member
  • Total Posts : 444
  • Reward points : 0
  • Joined: 2003/11/07 12:42:20
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/08/06 21:26:16 (permalink)
0
Found that the Mac OS was the issue.  This should not happen in this type of OS.
That aside I first updated to MPLAB C 5.00 and found latter that sprinf no longer works.
See this for more detail.
http://www.microchip.com/forums/m1063363.aspx?tree=true
 

John Zigrang
JTZ Engineering, Inc.
#7
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/04 13:26:53 (permalink)
0
Updating the OS just hides the problem, it doesn't solve it.  Something changed between XC16 v1.34 and v1.35.  In addition, current versions of the MPLAB X IDE and XC8 and XC32 compilers continue to work fine on 10.11.x.  And it's moot for me anyway, as updating beyond 10.11.x is not possible on my machine, and I'm certainly not willing to replace the hardware just to solve this one nuisance problem.
 
Microchip Support is so far unable to reproduce the problem on their end.  They are telling me that the problem exists on only a handful of machines with 10.11.x, and I think they're losing interest in getting to the bottom of it.  If anyone else out there is currently experiencing the problem, please chime in and provide input to help them solve it.  
 
In the meantime, I've suggested they attack it from a different angle, namely determining why the IDE thinks (and notifies me) that "an update to v1.35 is available", when in fact it's already installed.
 
#8
jtzeng
Super Member
  • Total Posts : 444
  • Reward points : 0
  • Joined: 2003/11/07 12:42:20
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/04 13:34:43 (permalink)
0
I gave up and closed my case as it was going nowhere.

John Zigrang
JTZ Engineering, Inc.
#9
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/04 13:39:25 (permalink)
0
I probably would have done likewise if I had the option of updating my OS.  But since I don't, I'm trying to be persistent with (and helpful to) them instead.  grin: grin
#10
prmcgill
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2010/10/29 09:54:48
  • Location: 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/17 15:45:48 (permalink)
+1 (1)
I'm having the exact same problem with the same symptoms on MacOS 10.11.6. I wasted time uninstalling and reinstalling before I found this forum thread. I just renewed my HPA on this compiler but will be unable to use the current release until/unless the problem is fixed.
#11
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/27 12:34:18 (permalink)
0
I appreciate knowing that.  I just submitted a bunch of IDE logs to Microchip Support.  I will also inform them that another user is experiencing this issue.  Thanks!
#12
Jim Nickerson
User 452
  • Total Posts : 5940
  • Reward points : 0
  • Joined: 2003/11/07 12:35:10
  • Location: San Diego, CA
  • Status: offline
Re: Issues installing 1.35 on Mac 2018/10/28 09:07:56 (permalink)
0
Doogie
 Microchip Support is so far unable to reproduce the problem on their end.  



It is extremely difficult to fix a problem that can not be reproduced.
I have installed detailed logging in my software, to no avail.
I have gone so far as installing remote control of a PC to try to resolve a problem I was unable to reproduce in my lab.
 
#13
Doogie
Super Member
  • Total Posts : 131
  • Reward points : 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2019/01/08 13:39:50 (permalink) ☄ Helpfulby Cyclomatic_Complexity 2019/01/25 01:55:37
+1 (1)
XC16 v1.36 has just been released, and it installs and compiles correctly (for me at least) on Mac OS X 10.11.6. grin: grin
#14
follower
Junior Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/11/27 03:31:14
  • Location: 0
  • Status: offline
Re: Issues installing 1.35 on Mac 2019/01/30 01:13:14 (permalink)
0
To anyone else looking for the XC16 v1.36 release--it has been "removed"/pulled due to a bug.
 
There is a post about it being removed in the forum thread "Do XC16 1.36 executables have a virus/trojan?".
 
As it is actually still possible to download the buggy release (via a direct URL) I can confirm that XC16 v1.36 appeared to run successfully on Mac OS X 10.9 when I tried it (before I discovered the release had been pulled :) ).
 
There doesn't appear to be any comment in the release notes about the fix though.
#15
Jump to:
© 2019 APG vNext Commercial Version 4.5