• AVR Freaks

Helpful ReplyHot!can´t connect to PicKit 4

Page: 12 > Showing page 1 of 2
Author
lonesomerider
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2018/06/19 12:19:38
  • Location: 0
  • Status: offline
2018/06/20 02:19:09 (permalink)
0

can´t connect to PicKit 4

Hi everyone,
First i'm new to this forum so please be patient.
I tried to get my new pickit 4 working:
I installed mplab x 4.20 in my win10 PC.
I connected the pickit with the PC via one of my usb cable and the target. 
The pickit didn't show up in mplab IDE and ipe as i expected from my experience with ICD 3.
The Led in the pickit was pink-ish with some flickering. 
Then i disconnected the target and reconnected the pickit with my PC. The Led was now blue but still Not showing Up in mplab IDE and ipe. 
After that i tried the original usb cable with the pickit. Since then the Led isn't lighting any more. 
I'm a little desperate now and don't know what to do next. Can anybody help?
#1
DevMod1
Administrator
  • Total Posts : 485
  • Reward points : 0
  • Joined: 2009/02/10 09:34:30
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2018/06/20 09:34:52 (permalink) ☄ Helpfulby lonesomerider 2018/06/20 12:32:02
0
Are you using the USB cable that came with the PICKit 4?  When you say the LED is not on anymore, are you staying when you connect there is no LED light at all???
 
Try the "Emergency Tool Recovery" in MPLAB X.  It could be that the reset button got pushed inadvertently.
 
 
 

_____________________________

Please read the forum posting guidelines. Do not double post, please help keep these forums professional and comments respectful.
Please notify the moderators of problems/spam/trolls.
#2
lonesomerider
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2018/06/19 12:19:38
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2018/06/20 11:28:51 (permalink)
0
Hi,
thanks for you help! What i did now:
"Emergency Tool Recovery" with the original usb cable, worked!
After that the pickit was connected to mplab x. So i tried to download my software. I got that output:
 
Connecting to MPLAB PICkit 4...

Currently loaded versions:
Boot version...................01.00.00

Now Downloading new Firmware for target device: PIC24FJ64GA002
Updating firmware application...

PICkit 4 timeout out during the firmware download process.
Connection Failed.
Transmission on endpoint 2 failed
 
So I reconnected the pickit three times until the LED was blue (i think this is ok? the 2 times before it was pink-ish again with blue flickers)
Now it is like yesterday, LED is blue and pickit isn´t recognized by mplab.
#3
DevMod1
Administrator
  • Total Posts : 485
  • Reward points : 0
  • Joined: 2009/02/10 09:34:30
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2018/06/22 09:03:40 (permalink)
0
We will try and reproduce this issue and provide a fix.

_____________________________

Please read the forum posting guidelines. Do not double post, please help keep these forums professional and comments respectful.
Please notify the moderators of problems/spam/trolls.
#4
stemberk
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2018/06/22 22:45:07
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2018/06/25 22:20:01 (permalink)
0
Hi,
I had the same problem when I used "Power target circuit from PICkit 4" option. PICkit 4 is working correctly  if I disable this option and use an external voltage for device powering. This is just workaround working for me and there is definitely bug in PICkit 4.
#5
adq
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/01/30 12:01:34
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2019/02/08 13:41:44 (permalink)
5 (1)
I know this is a few months old, but I feel I may be able to save somebody some time here.  I noticed on a few reviews where people said the PicKit 4 was great but the USB cable didn't work out of the box.  My PicKit 4 went to blue light but wouldn't install on Windows 10, Ubuntu 18.2, Windows 7, or MacOS Mojave.  Weird.  I went through all the troubleshooting and got to the part where you place the device in recovery mode.  Now I have a bricked Pickit with no light.  I tried another USB cable.  Still no luck.  After Microchip sent me a replacement, I had the same issues UNTIL I used the brand new USB cable.  I was also able to recover the original PicKit 4 with that same new cable.  All is well and I'll be sending them the old Pickit and especially the USB cable back.   Don't discount cables.
#6
asvoria
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2018/11/02 05:11:20
  • Location: 0
  • Status: offline
Re: can´t connect to PicKit 4 2019/07/27 04:55:33 (permalink)
0
I think I am having the same issue, but my blinking light color is purple. I did try to change the USB cable, but it doesn't solve my problem. A bit frustrated now because Microchip tickets filed but they didn't reply me anything.
#7
Ken_Pergola
Super Member
  • Total Posts : 2198
  • Reward points : 0
  • Joined: 2003/11/07 12:48:48
  • Status: offline
Re: can´t connect to PicKit 4 2019/07/27 15:01:17 (permalink)
5 (1)
asvoria
...but my blinking light color is purple...



Hello Asvoria,
 
1) Does the purple light stop flashing and then change to stead-state purple?
 
It sounds like the 'force Bootloader mode' is being triggered -- but the purple flashing should stop after a few seconds.
 
2) Are you inadvertently pressing the hidden pushbutton under the MPLAB PICkit 4 logo when you are plugging in the USB cable into the MPLAB PICkit 4 too?:
 
 
From the User's Guide:
 
Perform the following steps to force the debugger into bootload mode:
1. Disconnect the Micro-B USB cable from the debugger.
2. Press down on the MPLAB PICkit 4 logo and hold while plugging in the Micro-B
USB cable. The light strip flashes purple. Continue pressing the logo until the
light strip stops flashing and changes to steady on purple. You are now in boot
loader
mode.
3. Try to reestablish communication with the MPLAB X IDE or MPLAB IPE. When
successful, the firmware update is downloaded. When complete, the LED is
steady on blue and the debugger is ready for operation.
 
 
Best regards,
 
Ken
 
#8
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/27 07:52:23 (permalink)
0
Hello,
I don't know if someone else encounter this problem but I just have the same with my first picKit4, just out of the box.
Impossible to update the firmware:
 
Connecting to MPLAB PICkit 4...
Currently loaded versions:
Boot version...................01.00.00
Now Downloading new Firmware for target device: PIC16F1614
Updating firmware application...
PICkit 4 timeout out during the firmware download process.
Connection Failed.
Transmission on endpoint 2 failed
 
Invoke the Bootloader Mode works fine, same for Emergency Boot Firmware Recovery Utility but it doesn't help, when I try to connect, it fail downloading the firmware.
 
Please give me back my old ICD3 which was working fines from years.....
 
#9
NKurzman
A Guy on the Net
  • Total Posts : 18266
  • Reward points : 0
  • Joined: 2008/01/16 19:33:48
  • Location: 0
  • Status: online
Re: can´t connect to PicKit 4 2020/01/27 08:06:11 (permalink)
0
What version of MPLabX?
What OS?
USB direct, or Through a hub? USB2 or 3?
Your ICD3 should still work.
#10
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/27 08:43:55 (permalink)
5 (3)
I just solve it.
If other have the problem, this is how you can fix this:
-just go to the coffe room and spent half an hour speaking with other collegues about the most crazy film you have ever seen.
-go back and plug your PicKit4, it will light blue and now will works...
 
 
#11
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/27 09:16:33 (permalink)
0
Just in order to check if it works correctly a second time:
-I programm correctly a board (Pick kit4 is lighting orange or yellow, not easy to define)
-I close MPLABX IDE v5.30
-i unplug Pickit4 from the computer.
-I plug again the pickit => i light purple=> not good => impossible to connect to MPLABX (even windows did't recognise it).
- i invoke bootloder mode => now pickit is dicover by windows and MPLABX but it fails to download firmawre
 
I use MPLABX v5.30, windows10, direct connection to USB, it seems USB are 3.0.
 
#12
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/28 01:28:42 (permalink)
0
Just an update about the problem,
When I face the problem, if I let the pickit4 unplugged for more than 10 minutes, then it will recover itself.
Also using an USB isolator USB-ISO OLIMEX between PC and PICKIT it always run correctly. I suspect this can be related to the voltage on my USB port.
Any ideas?
#13
ric
Super Member
  • Total Posts : 25592
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/28 02:26:33 (permalink)
0
Is there any improvement if you add a separate ground connection between your PC and your target board?
(i.e. so the PK4 ICSP connection is not the only ground connection from PC to target)
 

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#14
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/28 03:51:22 (permalink)
0
Hello,
Not sure it will help. Actually I have problem without been connected to the target board.
Just connecting the pickit4 to PC give problem, it light purple and is not recognised by windows so in that case I have to unconnect and wait or connect it throught the OLIMEX.
This morning I also discover that sometimes it also recover by itself when I let it connected to the PC and wait more than 10 minutes but this is not always the case.
#15
crosland
Super Member
  • Total Posts : 1779
  • Reward points : 0
  • Joined: 2005/05/10 10:55:05
  • Location: Warks, UK
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/28 12:31:08 (permalink)
0
Raise a support ticket and get a replacement.
 
The purple light means its waiting for a firmware download.
 
I had a similar issue but it mysteriously resolved itself before I actually returned it to Microchip.
#16
crosland
Super Member
  • Total Posts : 1779
  • Reward points : 0
  • Joined: 2005/05/10 10:55:05
  • Location: Warks, UK
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/29 02:54:06 (permalink)
0
Well, a day later and mine is b******d again, by simply moving it on my desk.
 
The original response from Microchip was to reset the PICKit 4 by pressing the Emergency button located in the small hole beside the USB socket. The unit should reset and show in the Device manager as AT91 in the Ports section. If this shows then the emergency recovery tool (in MPLAB X) will be able to reset the unit.
 
Firmware download fails now. I have asked for a replacement.
#17
er_eco
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/30 02:50:57 (permalink)
0
crosland
 
 The purple light means its waiting for a firmware download.
 



I was not sure about the purple light signification.
Is it normal that when you plug the pickit4 it always light purple before it switch to blue? Is it somethig you also had?
#18
crosland
Super Member
  • Total Posts : 1779
  • Reward points : 0
  • Joined: 2005/05/10 10:55:05
  • Location: Warks, UK
  • Status: offline
Re: can´t connect to PicKit 4 2020/01/30 03:51:55 (permalink)
0
The information about the purple light came form Microchip.
 
If you go through the hardware reset and emergency recovery procedure then I think th light is purple until you first use it with MPLAB X and it downloads new firmware for whatever device you are programming. After that it should always be blue.
 
 
#19
Witek
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Joined: 2013/02/14 06:56:33
  • Location: Western Australia
  • Status: offline
Re: can´t connect to PicKit 4 2020/02/10 00:10:02 (permalink)
0
Yep, it was the cable. I was able to "Emergency boot" the pickit4, update the firmware, and other things most of the time. Until, I wanted to set the kit into programmer to go mode. That would report: Fatal error: UNKNOWN_POWER_ERROR, no matter what i tried. Then I came accross this post and sceptically tried differnt cables. Only one worked out of different 4 I had.
 
 
#20
Page: 12 > Showing page 1 of 2
Jump to:
© 2020 APG vNext Commercial Version 4.5