Hot!ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock

Author
krizy
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2011/08/24 03:48:27
  • Location: 0
  • Status: offline
2018/05/23 05:16:03 (permalink)
0

ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock

Hi,
I noticed that i can't see any of the ICD's (3 & 4 versions) in IPE V4.15 when i plug it into my HP thunderbolt dock or any other USB hubs further down the chain but does work if i plug it direct in to the laptop or any hubs directly plugged into the laptop.
 
The device driver does load ok in device manager (Microchip WinUSB Device) when using the thunderbolt dock but the tool option is blank. I have updated the Dock with the latest HP firmware and still no success. 
 
Does anybody have any ideas?
 
Thanks,
 
Chris
#1

7 Replies Related Threads

    RISC
    Super Member
    • Total Posts : 5271
    • Reward points : 0
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/05/23 06:04:40 (permalink)
    0
    Hi,
    In the recommendations for pluging tools it is always recommended to plug directly into the PC to avoid any driver issues. External dock / USB hubs have sometimes issues.
     
    What kind of dock station do you have :
    * a HP special connector based connection between your laptop and the dock
    * a USB external dock  (this may be an issue)
    I have a Lenovo laptop with "special connector" below that plugs into the dock and I can use without any issue the docking station.
    It is indeed strange that you see the driver in device manager (it means it has been enumerated)
    Can you try USBdeview freeware to see more details ?
    If you cannot make progress I suggest you enter a ticket to Microchip support 
    Regards
     
    #2
    krizy
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2011/08/24 03:48:27
    • Location: 0
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/05/23 07:32:42 (permalink)
    0
    Its just a HP thunderbolt 3Dock that uses a special connector. Every other USB device I've plugged in works.
     
    Anyway I ran USBDeview and I can't see nothing obvious except for a red dot next it so I've raised a ticket with support.
     
    Thanks.
    #3
    MShouk
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2012/05/19 00:52:26
    • Location: Chandler, Arizona
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/06/06 13:28:39 (permalink)
    0
    Thank you for reporting this issue. We will try to reproduce the problem on our side.
    #4
    tmbarton
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2012/02/16 09:28:00
    • Location: 0
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/06/12 03:53:48 (permalink)
    0
    I have the same problem with an ICD3 using a Dell Thunderbird dock.  Strangely it works fine on an earlier IDE/IPE V3.45, but not on 4.20.  If I plug directly into the laptop it works fine on both 3.45 and 4.20.
     
    Trevor
    #5
    prj
    Super Member
    • Total Posts : 197
    • Reward points : 0
    • Joined: 2009/12/01 14:35:45
    • Location: 0
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/06/13 08:37:50 (permalink)
    0
    tmbarton: I am presuming you were running some flavor of Windows. Were there any Windows updates between using X 3.45 and 4.20?
    #6
    qɥb
    Monolothic Member
    • Total Posts : 3329
    • Reward points : 0
    • Joined: 2017/09/09 05:07:30
    • Location: Jupiter
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/06/13 16:08:51 (permalink)
    5 (1)
    May be irrelevant, but what flavor of USB ports are on the laptop, and on the dock?
    i.e. are they USB2, or USB3?
     

    This forum is mis-configured so it only works correctly if you access it via https protocol.
    The Microchip website links to it using http protocol. Will they ever catch on?
    PicForum "it just works"
    #7
    tmbarton
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2012/02/16 09:28:00
    • Location: 0
    • Status: offline
    Re: ICD 4 not recognised in IPE V4.15 when using a HP thunderbolt dock 2018/06/18 09:48:47 (permalink)
    0
    Yes, it's Windows (10, fully patched), and no there are no updates involved, literally if I run V3.45 the ICD3 works perfectly and if I then run 4.15 it fails to be seen when it's connected to the dock.  The Dell Dock is a Thunderbolt/USB C thing which has USB2 and USB3 ports on it, one of which goes to a USB2 hub and to the ICD3.  This is the configuration that always fails with 4.15 and always works with 3.45.
     
    The laptop itself has USB3 ports and works with both versions if I connect the ICD3 directly.
     
    Trevor
    #8
    Jump to:
    © 2018 APG vNext Commercial Version 4.5