AnsweredHot!Debugging programming & debug times, need help

Author
justinmreina
Starting Member
  • Total Posts : 66
  • Reward points : 0
  • Joined: 2009/06/06 22:37:00
  • Location: 0
  • Status: offline
2018/03/09 14:01:52 (permalink)
0

Debugging programming & debug times, need help

Between computers at work we are observing strong differences in program & debug times with the ICD3, how do you recommend we work towards resolution? See below for setup -
 
Work Dev Setup
  • Computer A - Dell Latitude E7470
  • Computer B - Dell Latitude E7470 (same spec)
  • MCU - PIC24F
  • Debugger - ICD3
 
Issues Observed
  • Programming: ~30s(CompA), ~10s(CompB)
  • Debug: ~40s(CompA), ~10s(CompB)
Thoughts? How can we resolve this? I am the user of CompA and yikes this is painful. See below for my prev measurements on CompA -
post edited by justinmreina - 2018/03/09 14:21:00
#1
KTrenholm
Super Member
  • Total Posts : 558
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/09 14:25:06 (permalink) ☼ Best Answerby justinmreina 2018/03/16 09:59:20
5 (1)
Is the hang up on CompA when it's connecting to the ICD?  Or is it the amount of time it is actually programming the chip?
 
If it's taking extra time to connect to the ICD3, turning the "maintain connection to tool" option on may eliminate/reduce the connection time.
Tools>Options>Embedded>Maintain Active Connection to Hardware Tool
post edited by KTrenholm - 2018/03/09 14:26:30
#2
qɥb
Monolothic Member
  • Total Posts : 3332
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/09 16:05:32 (permalink) ☄ Helpfulby justinmreina 2018/03/16 09:59:31
0
KTrenholm
...
If it's taking extra time to connect to the ICD3, turning the "maintain connection to tool" option on may eliminate/reduce the connection time.
Tools>Options>Embedded>Maintain Active Connection to Hardware Tool

+1
I suspect this has been done on the one that is running faster.
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#3
justinmreina
Starting Member
  • Total Posts : 66
  • Reward points : 0
  • Joined: 2009/06/06 22:37:00
  • Location: 0
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/13 17:05:03 (permalink)
0
This is still occurring and needs resolution now, does anyone have any recommended next steps?
#4
qɥb
Monolothic Member
  • Total Posts : 3332
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/13 17:50:44 (permalink)
0
You haven't told us if you've tried what has already been suggested yet.
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#5
NKurzman
A Guy on the Net
  • Total Posts : 16668
  • Reward points : 0
  • Joined: 2008/01/16 19:33:48
  • Location: 0
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/13 19:09:17 (permalink)
0
Programming with compile? or without?  the Anti -Virus scanning the build directories can slow it down.
The PCs have the same RAM and number of Cores?
#6
justinmreina
Starting Member
  • Total Posts : 66
  • Reward points : 0
  • Joined: 2009/06/06 22:37:00
  • Location: 0
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/16 10:04:14 (permalink)
0
My apologies for the delay and incomplete response. I was able to try KTrenholm's advice this selection was not enabled.
 
When applied CompA decreases from 40/30 to 30/20! This is still a bit slow, thoughts for improvement? CompB is remote and will take time to go out to test, I can use another devPC in the office if useful.
#7
KTrenholm
Super Member
  • Total Posts : 558
  • Reward points : 0
  • Joined: 2012/08/08 14:04:23
  • Location: Connecticut, USA
  • Status: offline
Re: Debugging programming & debug times, need help 2018/03/16 10:57:39 (permalink)
0
It's been asked a few times in the thread, what's taking up that time?  The make/compile or the actual connection and programming of the PIC?
 
If it's the make that's taking up the time, and the machines you are using have multiple cores, you can try enabling parallel make to devote more CPU cores to the process (if it isn't already enabled).
Options>Embedded>Project Options>Use parallel make
 
#8
Jump to:
© 2018 APG vNext Commercial Version 4.5