• AVR Freaks

AnsweredNano 2d enabled causes program to halt.

Author
bordlab
Starting Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2018/01/29 06:45:53
  • Location: 0
  • Status: offline
2018/02/07 07:18:06 (permalink)
0

Nano 2d enabled causes program to halt.

Background: MPLAB X IDE v4.05, XC32 v1.44B, Harmony v2.05.01, PIC32MZ2064DAG169, PIC32MZ2064DAG169 development board with display.
 
I have a simple program that only displays some images.  With the Graphics stack enabled with defaults it runs great.  When I set the Graphics Processor to Nano 2d the program halts on start up.  The display blinks and I get "Target Halted" in the output window.  Is there any other setup needed for Nano 2d?
 
Thanks
Andy
#1
bblessing
Super Member
  • Total Posts : 729
  • Reward points : 0
  • Joined: 2008/12/04 06:44:21
  • Location: Cincinnati, OH
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/07 07:50:21 (permalink)
0
What do you have your heap set to? Also, are these large images? Where are they stored (DDR for example) and how are they stored (PNG, raw, etc)?
#2
bordlab
Starting Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2018/01/29 06:45:53
  • Location: 0
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/07 07:56:00 (permalink)
0
My heap is set to 205382 using the heap configuration tool.
The images are raw using the internal flash about 200k.
 
The images work great without nano 2d selected using software graphics.  Why would the hardware graphics be more restrictive?  Just trying to figure this all out.  Thank you for your quick reply!
#3
bblessing
Super Member
  • Total Posts : 729
  • Reward points : 0
  • Joined: 2008/12/04 06:44:21
  • Location: Cincinnati, OH
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/07 08:27:06 (permalink)
0
I was just trying to outline all of the things that gave me problems along the way, though I have custom hardware.

Perhaps the DDR clock is too fast? The GPU got weird on me above 150 MHz. What is your screen orientation?
#4
bordlab
Starting Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2018/01/29 06:45:53
  • Location: 0
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/07 08:34:50 (permalink)
0
My orientation is 0. 
Where do I see the GPU and DDR clock? 
 
All I see is Pixel Clock Settings. 
    Master Clock (MHZ) = 100
    Pixel Clock Prescaler = 4.
 
Update:
I found the DDR clock under the clock Diagram tab.  I changed it to 150Mhz (DIV_1, MUL_25, DIV_4, DIV_1)
 
The program still halts after a flash of the screen.  If I turn off Nano 2d it work perfectly.
 
Any other suggestions?  Thank you for all your help!!!!
post edited by bordlab - 2018/02/08 06:53:50
#5
bordlab
Starting Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2018/01/29 06:45:53
  • Location: 0
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/08 07:20:32 (permalink) ☼ Best Answerby MikeinAZ 2018/02/08 13:26:35
5 (1)
 
Update Solved:
Turns out the Heap Configuration Calculate through the Graphics Composer did not calculate enough Heap space for the Nano 2d.  I increased my heap space and now everything works.  I would still like to know why it calculated enough heap for software rendering but needed more for hardware rendering.
#6
MHGC
Super Member
  • Total Posts : 231
  • Reward points : 0
  • Status: offline
Re: Nano 2d enabled causes program to halt. 2018/02/09 09:08:14 (permalink) ☄ Helpfulby bordlab 2018/02/09 09:09:30
0
Hi,
 
Thank you for making aware of the deficiencies with the Heap Estimator.  We will be looking to correct this in the future.
#7
Jump to:
© 2019 APG vNext Commercial Version 4.5