2015/02/06 08:18:57
woody244
Greetings,
 
Very excited about an eclipse environment for PIC32.  I am running a MAC with Yosemite and was unable to successfully install Arriba in any fashion.  I tried the posted instructions using the plugin anc connect with Juno, Keppler and Luna.  Luna is preferred as this it the latest and what I use at work.  I also tried the full install.  My plan is to purchase the license if i can evaluate this with the simulator and it works well.  So far no good.  My current setup is trying to setup with Juno as this is what the post indicated had been verified.  I set the vm variable to point to my Java 1.6.  According to my Eclipse configuration it was loaded and is revision.
 
java.ext.dirs=/Library/Java/Extensions:/System/Library/Java/Extensions:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/lib/ext
java.home=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
 
java.version=1.6.0_65
2015/02/06 08:43:38
woody244
Forgot to add, I get the following error when connect tries to run
 
ArribaConnect
AC> AC> 
config> Loading /var/folders/58/ln8qfctn5k97xdx_5d0yh1s00000gn/T/arribaconnect3016163289963153273.cfg.2015-02-06 07:24:37.105 java[1189:53801] [Java CocoaComponent compatibility mode]: Enabled
2015-02-06 07:24:37.106 java[1189:53801] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000
dyld: lazy symbol binding failed: Symbol not found: _CGContextSetAllowsAcceleration
  Referenced from: /Applications/eclipse/jre.macos/Libraries/libawt.jnilib
  Expected in: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
 
dyld: Symbol not found: _CGContextSetAllowsAcceleration
  Referenced from: /Applications/eclipse/jre.macos/Libraries/libawt.jnilib
  Expected in: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
 
Arriba Connect:  loading /var/folders/58/ln8qfctn5k97xdx_5d0yh1s00000gn/T/arribaconnect3016163289963153273.cfg
 
I also get numerous
 
java.lang.NullPointerException errors that show up in the make targets window.
 
I am going to try reinstalling Java tonight but if that does not work I have no ideas on how to proceed.
 
Thanks,
Woody
2015/02/06 19:42:13
woody244
Here are updates on what I have found so far.  I have removed all other Java except the latest Java 6.  This should be clean and every reference to the error above says that should fix it.  No luck.  Can't use Luna because it requires Java 7.  Keppler and Juno are happy with Java 6.  Problems is identical with Arriba installer or plugins and I have tried clean installs after the Java cleanup.   Will attempt to contact Arriba directly to see if maybe they have seen similar and I am wasting my time.  Given how old any posts except this one I am beginning to think this is not a very long lived product.
 
 
2015/02/06 19:52:37
DavidBLit
Too bad.  It had the potential of being so much better (from any reasonable perspective) than the Netbeans-based garbage.
2015/02/06 20:16:34
woody244
Agree, I was considering a J-Link and using GDB with a standard Eclipse but I have a realIce so I have to lose it.  But then getting gdb for mips on a MAC is tough.  Although the one that comes with these tools might work.  I would really like to dump MPLABX.  Been using Microchip on designs for the past 20 years and was really disappointed they went with Netbeans.
 
Got an email into Viosoft.  See if they reply.
 
I tried on Windows too but only with Luna so maybe would have had better luck with Juno or Keppler.  I used their full install and it worked better but their GDB did not run from within the IDE.  Ran ok from the command line.
 
 
2015/02/18 12:43:43
viosoft
Hi Woody, your Java VM version is slightly different from the one we use.  Apparently, other Eclipse Juno users have reported similar issue so this is not a problem specific to Arriba: http://stackoverflow.com/questions/26450420/osx-10-10-and-eclipse-luna-own-app-crashes-when-started-from-inside-eclipse
 
I would recommend that you use build -466 of the Java VM as indicated in the link above, and see what happens.  
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account