• Welcome
  • Behaviour of MCP73831 when no battery is attached?
2012/08/12 10:27:09
jonaslorander
Hello,
 
I have a circuit with a PIC18 whit USB that uses a MCP73831 for battery charging.
The +5V from USB goes in to the MCP73831 with a 4,7uF ceramic capacitor on the input and one
on the output, and then the battery. The PROG resistor is 2k, which would give 500 mA (the
battery is 3000 mAh). After the battery I have a MCP1802 LDO with +3,3V output.
 
Here is my problem; 
If I have no battery connected the PIC18 some of the time will not start up, most of the time it
starts up, but my computer says it can not recognize the device (it should be a simple CDC which
echos back the data sent to it (the examples in the Microchip libraries)).
 
When the battery attached the computer recognizes the device properly, every time. I have a
100 nF capacitor on the MCLR-pin of the PIC which helps somewhat. 
 
If I bypass the MCP73831 (with no battery attached off course) and the +5V from the USB goes
directly to the LDO the PIC starts up properly and the computer recognizes the device every
time, no exceptions.
 
So, I guess my question is, how will the MCP73831 work when there is no battery attached?
Or is there something else that is wrong with my connection?
I have made a similar circuitry earlier with the MCP73831 but a different PIC (without USB) and that
PIC did not start either without the battery.
 
And if you wounder why I do not want to have the battery attached it is because I need the battery
elsewhere at the moment, and, during development it would be nice not to have the battery.
 
Thanks in advance! If I was unclear about anything please tell me so I can make it clearer :)
 
Regards,
Jonas
2012/08/13 01:54:03
DarioG
I can think of slow VCC rise time, so you could consider BOR and such...
2012/08/13 04:00:25
jonaslorander
Thanks for your reply Dario.
 
If I press the reset button on my board, bringing the MCLR to GND, I get the same behaviour, if it was a slow rise of Vdd, I don't think I would get the same behaviour when pressing the reset button, since the Vdd probably would be stable after a few seconds.
 
I will measure with an oscilloscope and see how the voltage rises when I connect the USB-cable.
 
The PIC is a PIC18F27J53.
 
Regards,
Jonas
2012/08/13 04:15:10
Ian.M
The series combination of charge controller and LDO may be unstable. Try adding a large electrolytic in place of the battery.
2012/08/13 06:47:48
jonaslorander
Thanks Ian, that helped. 
 
I tried with 1000 µF, 100 µF and 10 µF instead of the battery, and all of them worked.
 
It got me thinking, so I added another 4,7 µF ceramic capacitor, closer to the MCP73831 (right on the pins actually) and that seems to work too. So I guess it was some instability between the battery charger and the LDO. I will add this extra ceramic in the next rev of the board :)
 
Thanks again!
2012/08/13 09:59:22
Ian.M
Good.   Layout and decoupling can be critical as you have just found.
2013/09/05 04:33:12
maximosipov
I have a similar problem - LDO and some micros are connected to VBAT and without a battery:
 - voltage goes up to 4.2, remains stable for ~1ms
 - gradually drops down to ~2V (my micro resets)
 - goes to 4.2 again and cycle repeats
Adding another 4.7uF to VBAT didn't help in this case. What could be a solution for this problem?
 
Kind regards,
Max
2013/09/05 05:53:26
tom maier
Your LDO might be going into thermal overload or current overload.
 
You need to measure you total current and see if your are exceeding the LDO specs.
 
2013/09/05 06:59:43
maximosipov
I will. However it is unlikely - I'm using the LM3671-3.3 and LM3671-1.8 and spec says it has 600mA load current. The device works well if powered from the battery or if battery is connected.
2013/12/05 05:42:00
hitesh_azoi
Hey Maximosipov,
 
i am facing the same issue and i did  it all the remedy , which are suggested in above thread. i want to ask you, how did you find the solution of this issue or you you still facing this issue.
please let me know.
 
thanks in advance.
 
BR
Hitesh Barot
12
© 2019 APG vNext Commercial Version 4.5

Use My Existing Forum Account