2007/12/05 15:09:11
DevMod
We have put up a web page to help people analyze problems with MPLAB ICD 2.  If you have additional information on a problem that you've solved, please add to this thread, and we'll add that info to the web page if it can be of help to others.
 
www.microchip.com/icd2help
2007/12/05 16:47:31
phil7890
 
Subject:  ICD2 and Clearing Various Protection Bits.
http://forum.microchip.com/tm.aspx?m=278003&mpage=1&key=&#278075

Problem/description in posts #1 & 3.
Proposed solution in post #4.
Confirmation in post #5.
Thanks.
2007/12/05 19:14:04
DevMod
Thanks.  We'll add to the document.
2007/12/05 20:49:24
xiaofan
How about this? MPLAB ICD2 doesn't have the hardware capability of controlling the Vdd/Vpp timing since it was was created before any of these internal RC/internal osc PICs were developed. 
http://forum.microchip.com/tm.aspx?m=277310

ICDWarn0033: MPLAB ICD2 does not support programming this device if both the internal oscillator and internal MCLR are selected.  You may continue programming, but you are encouraged to cancel, reconfigure your device, and try again.

My suggestion is to use PICkit 2 instead for this kind of PICs.
2008/01/12 18:36:21
rdoerr
I was having problems running ICD2 in debugging mode with my PIC18F4680 board. If I switched from debugging to programming mode, it would work fine, but in debugging mode it would complain that it couldn't enter debugging mode. After reading everything listed on this thread and trying the suggestions, nothing would work. I finally started trying debug mode after commenting out different config option. I found the one config option that was causing my setup to not enter Debug Mode was the CONFIG PWRT=ON option. It works great with this commented out and fails if I add it back in. ll these test were done using 8.0 IDE. Has this been identified as a bug in the IDE?

Thanks

Ray Doerr
2008/01/28 10:19:30
PhilV
I believe this is a common problem Ray.
I too have found that a lot of devices will not enter debug with the power-on timer enabled. As a matter of course now I have one config file for debug, and one for release, (although with 8.01 IDE I am now moving to a single config file and checking for __DEBUG).
 
Phil
2008/03/26 23:20:09
blar
i have a problem with MPLAB ICD2, when connected to dsPIC this message appear "ICDWarn0020: Invalid target device id (expected=0x400, read=0x0)" but the device is working properly cos the day before it was working. Any idea what's the problem?
2008/03/31 01:43:24
donmorr
Hi Blar,
I had the exact same problem last week. Had been using the ICD 2 with my Explorer 16 board and all was working fine until I started getting the 'Invalid Target ID' warning.

To solve the problem I had to
1. disconnect the ICD2
2. run the uninstall driver tool
(located here: C:\Program Files\Microchip\MPLAB IDE\Utilities\MPUsbClean but follow the instructions here: http://www.interrupt.co.kr/data/mchp/Uninstalling_USB_Drivers_51417c.pdf),
3. restart the computer
4. reinstall MPLAB
5. restart the computer
6. connect the ICD2 and let it automatically install the drivers


Hope this helps!
Don.


2008/04/12 08:08:09
amob
I have the same problem. Using ICD2 with dsPIC30F2012 all working fine. 3 days ago impossible to start ("Invalid Target ID .. ")
I réinstall driver tool and MPLAB 8.02, with your method (on WINDOWS 98) the problem persist.
I try to install on an other PC ( Windows XP), I have the same problem.
If I use a 18Fxx it's OK
 
On MPLAB ICD2 Setting I have :
Target Vdd 0 V
Target Vpp 12.62 V
ICD2 Vpp  12.78 V
 
Target is correctly powerd (5V)
If I set "reset", I MCLR=1.56V with R-pull up 10k and 3.68V with R pull-up 1K
 
If I start with 18Fxx, set the reset I obtain 5V on MCLR. If I change the target for dsPIC30F2012 (or dsPIF30F3013) without stop, MCLR remain at 5V
HELP ME please !
 
Excuse my bad english !
 
2008/04/14 03:53:42
donmorr
Again I had the same problem. I think I caused it last week by plugging out the ICD2 while MPLAB was running. I've spent 3.5 hrs this morning trying to fix it! I tried re-installing the drivers and MPLAB 8.2 but it didn't fix it.
So I unstalled all versions of MPLAB that were installed on my computer. Uninstalled the drivers and re-installed MPLAB version 8.0, opened MPLAB 8.0 and allowed it to download the Operating System firmware to the ICD. This seemed to have fixed the problem.

Maybe its the process of changing the operating system on the ICD that fixes the issue??? I'm not 100% sure but it seems to have worked for me this time :-)

Don
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account