2020/11/17 03:34:42
oliverb
I'm using 5.10 currently and officially it doesn't appear to support the version of MCC I'm using (3.95) though it has worked so far. Not sure which XC16 as I'm not on the right computer to check right now.
 
Trying to switch to a newer MPLAB gave me what looked like a junk folder, something like ".generated files" which means adding yet another line to .gitignore or having to manually exclude more stuff from commits.
 
More importantly a dsPIC project failed to compile, though using the exact same project, same XC16, it compiled under 5.10. There's an odd issue with configuration settings, not sure whether it is worth investigating, if so then I'll post it, but I don't see why MPLAB should even affect compiler operation.
 
Is there a known issue with WDT prescaler settings? It does look as if MCC offers all 32 settings and MPLAB memory view only recognises 20-24 settings?
 
What I don't like about 5.10+MCC is if I select register view I have to wait for maybe half a minute for the register view to become available. This doesn't seem to happen with newer MPLAB, didn't happen with 5.35 or 5.45.
 
2020/11/17 07:43:17
JPortici
but I don't see why MPLAB should even affect compiler operation

it's mplab that's generating the command line that invokes the compiler. If some options are set then the code could not compiler (e.g.: small memory model, but more than 4k of ram used)
 
i would update.
however, if you are working with dsPIC33C cores in dual partition mode stay with 5.35, as 5.40 introduced bugs in the debugger that weren't solved in 5.45
 
i use 5.45 on everything, minus those dsPIC33CK projects in dual partition mode. For that i still have 5.35 lying around.
 
Also, keep XC16 updated if you use those cores.
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account