2020/10/26 09:41:41
dmccric
I am writing an Android App for the RN4871 module now my iOS version is working and I am getting a command error when setting new connection parameters.
 
When setting up my device I set the connection parameters to Apple Defaults (Command "ST") as set in the Datasheet but setting the them instantly using command "T" always gives an error.
 
"ST,0010,0024,0001,0064\r\n"                 // App default command
 
I receive the following from the my Android phone:  %CONN_PARAM,0006,0000,01F4% for the Interval, Latency & the Timeout parameters but setting these using the command T always fails.
 
"T,0006,0000,01F4\r\n"
"T,0006,0C8E,0000,01F4\r\n"
 
I have tried a few variations of the command below but nothing. Only error responses. The firmware revision for the module is v1.30.
 
Has anyone successfully set these parameters using an Android phone or Tablet?
 
 
2020/10/28 07:54:56
dmccric
I have resolved the issue but it was one of timing, when I received the command  CONN_PARAM,0006,0000,01F4% I immediately send the command to update the changes right away. This always failed.
 
However, I put a non-blocking, increased delay between receiving and sending the command and it worked fine. I send and receive many commands but this is the first time I have had to put a delay for it to be successful.
 
Regards
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account