2020/10/11 23:56:55
oliverb
So I started on a programming exercise for it, programmed it with the exercise, and now I'd like to put the original firmware back.
Problem is that when I've downloaded the file, found the hexfile and programmed it I get nothing at all. I remember the demo lighting the multicolour LED among other things.
 
I can't seem to compile the demo from source either, though I think I may just need the older MPLAB+XC16+MCC version used to create it?
 
Update: "Have you tried Build Clean?" So I got it to build, tried programming and I got an ID mismatch. On closer examination the source is for a dsPIC33CH128MP508 but my board clearly says dsPIC33CH512MP508. Not quite as simple as changing the PIC model in MPLAB though, I tried and couldn't get the master to compile.
 
OK so on further examination uart1.c contains the line: #include <p33CH128MP508.h> so I've changed it to #include <p33CH512MP508.h>
 
It works now.
 
Also note that the generated makefiles for the master project contain the absolute not relative path to the slave project so if there's a problem with "slave.h not found" or similar after a path or project name change you might need to delete the makefiles to force MPLAB to regenerate them.
 
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account