2020/08/29 19:48:02
stolzie78
Hi All, 
 
Well I tried to update the firmware on the PM3 as prompted by Microchip, which is now the worst idea that I have had. Updating the firmware has now bricked my PM3 and it is no longer usable. 
 
The PM3 is constantly coming up with a BIOS 13 error, it is no longer recoginsable on the USB and will not connect via USB. I have connected with an older serial cable which allows me to connect and it attempts to update the BIOS and firmware, however fails when it tries to download the database and it will reset during this procedure. 
 
I am wondering if anyone has had any experience with rectifiying the error. I have contacted microchip support about this issue and was told to install the drivers again for usb and update the firmware. 
 
All versions of the PM3 come up with 00.00.00.00 and it attempts to load the OS again and again, but to no avail. 
 
Any help would be appreciated.
 
Thanks
Jason

Attached Image(s)

2020/09/04 00:09:28
SujahA
There is a statement in PM3 readme related to ROHs and NON-ROHS devices. Can you check if your devices is roHS. I have faced issue in non-Rohs devices while upgrading firmware.
Also what was your old IDE version and what is the latest version you are upgrading to?
 
------------------------------------------------- From Readme-------------------------------------
·        Non-roHS MPLAB PM3s (Assy# 10-00359) are not suitable for programming devices with larger memories, for example PIC32MZ0512EFE064 and other similar devices. Upgrading to a roHS MPLAB PM3 is recommended. Programming PIC32MX devices on non-roHS MPLAB PM3s are not supported.
2020/09/04 02:11:27
stolzie78
Hi SujahA,
 
Thank you for your reply. The PM3 that I am using is a non-RoHS unit. I was using the latest IPE when it asked for the update and it has bricked the unit.
 
I have been installing older IDE's and trying to reprogram the BIOS and such, but unfortunately it is still coming up with Error13 on the screen. Tried different versions of the firmware loaded from different IDE's too. 
 
Also heard that holding down the enter and esc button on boot works, but not in this case. The unit can identify with the serial port, and appears to go through the motions of programming the device, but will reset during certain upload functions.
 
Would be interested to know if the firmware could be uploaded from the SD card or whether it is just serial now.
 
Thanks
Jason
 
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account