• WiFi
  • ATWINC1500 OTA Update help
2020/07/25 12:45:35
larrycook99
I am attempting to update the firmware on an ATWINC1500 from 19.4.4 to 19.5.4. I have tried following the examples and the documentation but when I attempt to perform the update I get a u8OtaUpdateStatus value of 7 returned, which in the enum is labelled OTA_STATUS_IMAGE_VERIFY_FAILED. I also get the same error if a try to update an ATWINC1500 that has 19.5.4 firmware on it. (I made that attempt by mistake.)
 
Does anyone know what that means? Does it mean that the image I am trying to use is bad? If so, where can I get a valid firmware image to download.
 
The one I am using the m2m_aio_3a0.bin file that I dug out of the ASF directory tree. (The release notes in the same tree are for 19.5.4.) I also have another bin file that I got from MLA v2018_11_26 by running setup_19.5.2_rc7.exe (I assume that this means that that firmware was really 19.5.2 and not 19.5.4.) At any rate both failed the same way and I am at a loss as how to overcome the error because I have no idea what is wrong.
2020/07/25 16:12:03
larrycook99
Looking at the TCP packets, it is trying to download the bin file but for some reason stops relatively early. The bin file is 400KB but it looks like only about 20 or so TCP frames of 1500 bytes are passed before the failure.
 
I am using HFS.exe as the documentation describes and it starts but just never finishes. I see the HTTP GET issued from my device and a number of TCP packets but not enough of them.
 
Is there a setting that I missed? Anyone have any idea why it might be failing?
 
The chip is a ATWINC1500-MR210PB, so according to the datasheet it should have the 4MB of flash that the documentation says it needs to do the OTA update. 
2020/07/25 17:29:17
jtemples
I did this a couple of years ago with the same chip and same .bin file with no issues.  I think I just put the .bin on my web server and ran the example in the 2018 MLA.  This was on an Explorer 16/32 with a PIC24E.
2020/07/25 19:03:35
larrycook99
So, you used the MLA 2018 code? I assume then that after connecting and getting an IP address, you called m2m_ota_start_update() to perform the HTTP Get and then m2m_ota_switch_firmware() when you received OTA_STATUS_SUCCESS in the OtaUpdateCb() callback function to switch to the new firmware. 
 
It seems simple and straight forward. Do you recall having to do anything else?
2020/07/25 20:01:19
jtemples
No, I didn't write any code.  I  believe all I did was enable the OTA_UPDATE app in demo_config.h in the winc1500 MLA project and ran it.
2020/07/25 20:28:40
davea
jtemples
I think I just put the .bin on my web server

had to do the same..
 
2020/07/26 09:37:47
larrycook99
Where did you get the bin file? Any chance you still have it? 
2020/07/26 10:07:40
jtemples
It's still sitting on my web site:  http://www.xargs.com/m2m_aio_3a0.bin
 
But I'm guessing it's the same one you already have.
2020/07/26 10:29:39
larrycook99
I have 2 copies of files with that name that I have gotten from Microchip. One is identical to yours. I got it from the MLA 2018 distribution. The other is not the same. It came from my ASF installation. Neither will download. They both cause an error as I described above.
2020/07/26 10:57:19
jtemples
The MLA firmware update project doesn't work?
12
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account