• MPLAB X IPE
  • I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib
2019/11/18 21:15:41
newboy
Hi,
 
I can't open IPE, it shows error when opening:
 
Warning - could not install some modules:
com.jcraft.jzlib - org.netbeans.InvalidException: Netigso: C:\Program Files (x86)\Microchip\MPLABX\v5.15\mplab_platform\ide\modules\com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib
com.jcraft.jsch - org.netbeans.InvalidException: Netigso: C:\Program Files (x86)\Microchip\MPLABX\v5.15\mplab_platform\ide\modules\com-jcraft-jsch.jar: Not found bundle:com.jcraft.jsch     
 
What's the problem?
 

Attached Image(s)

2019/11/19 23:51:58
tech24x7
Hi,
Can you clear the cache directory below and try again?
C:\Users\xxxx\AppData\Roaming\mplab_ipe\dev\
2020/02/10 20:40:33
tech24x7
Please try below steps,
  1. If you have admin rights to that machine, After clearing the cache can you try running IPE using Run As Administrator mode
  2. If step 1 doesn’t help please try the below steps,
    • Uninstall IPE
    •  Just Delete everything from cache directory
    • C:\Users\xyzuser\AppData\Local\mplab_ipe\Cache\dev\v5.30
    • C:\Users\ xyzuser \AppData\Roaming\mplab_ipe\dev\v5.30
  • After deleting just restart your machine.
  • Reinstall IPE
2020/02/10 20:58:42
ric
Note, this topic is from Nov last year, and the OP was using v5.15
They have not logged in since Nov-21, so I think they've given up.
 
2020/10/19 15:12:03
SOTI_Dev
I just ran into the same issue.  I had copied just the bare essential files from Program Files (x86)\Microchip\... to get the IPE GUI to run w/o needing to install the MPLAB v5.30 environment.  The goal was to get a production team to unpack a zip file and run the binary for the IPE without needing to use an installer.  I tested my bare-bones version from a random path on my drive, it worked fine.  I zipped up the folder tree and deleted the temporary folder.  Next time I tried to run the IPE from it's install location, I got the errors about not being able to find com.jcraft.jsch.jar and com.jcraft.jlib.jar despite the files still existing in the MPLAB default install location.  Re-installing didn't help, deleting the Roaming cache location didn't help but deleting the Local cache location fixed the problem.  That's an odd design choice to have the cached library locations override the default install locations if the software doesn't then fall back to check the default location when the cached location doesn't exist. 
 
Hope this helps someone else.
2020/10/20 01:26:55
tech24x7
Did you try open IPE GUI with admin rights?  Hope that solves the issue.
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account