• MPLAB X IPE
  • Problem with MPLAB IPE 5.10 on Ubuntu 18.10
2019/04/10 12:07:33
Aerrios
Hello,
I am having hard time with MPLAB X IPE v5.10 on Ubuntu 18.10. (I also tried with v5.15).
The program starts but not properly.
I am getting this error:

I have installed openjfx, using java openjdk version "1.8.0_191". (A also tried with java 1.11.)
 
Thank you for your help.
 

Attached Image(s)

2019/04/11 09:08:45
Sudheer Herle
IPE should use the jre 1.8 that is part of mplabx installation. Did you change anything there? Even if not, can you try using jre1.8
2019/04/11 11:59:24
Aerrios
I haven't changed anything.
This is what I use:

$ java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-2ubuntu0.18.10.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

And I found out, that the problem propably isn't in javafx, because this error appears in MPLAB X IDE and it works just fine. MPLAB X IPE doesn't fully load and when I try to switch to advanced mode or open any window, it freezes. 
2019/04/12 10:14:51
tech24x7
Hi Aerrios,
Can you open About Box from IPE help and paste the snapshot here.  That will tell which JRE it uses.
 
1) You can clear the cache directory and try restart IPE again, Cache location is available in about box
 
2019/04/12 12:08:39
Aerrios
tech24x7
Hi Aerrios,
Can you open About Box from IPE help and paste the snapshot here.  That will tell which JRE it uses.
 
1) You can clear the cache directory and try restart IPE again, Cache location is available in about box
 


Hello,
this is my About box:


Product Version: MPLAB X IPE 20180817-8f9031c3adc0
Java: 1.8.0_181; Java HotSpot(TM) 64-Bit Server VM 25.181-b13
Runtime: Java(TM) SE Runtime Environment 1.8.0_181-b13
System: Linux version 4.18.0-17-generic running on amd64; UTF-8; cs_CZ (mplab_ipe)
User directory: /home/samuel/.mplab_ipe/dev/v5.10
Cache directory: /home/samuel/.cache/mplab_ipe/dev/v5.10/var

I tried clearing '/home/samuel/.cache/mplab_ipe/dev/v5.10/var' (cache) directory, but without success :/
2019/10/02 08:29:48
gahlon
I also have the same problem with MPLAB X IPE not fully displaying the contents of the "Operate" tab in a fresh install of Debian 10.  My screen looks identical to the OP.
 
Has this issue been resolved yet?
 
Thanks.
2019/10/29 02:13:27
tech24x7
This issue is not seen in latest MPLAB X v5.25
2020/09/25 03:45:13
eg67150
I just installed the version 5.40 ( only IPE and 8bit tools ) and the problem seems still be present. Seems to be installation related , because i had it once in the past and reinstalling with IDE also cleard the problem. Also have "java.lang.IllegalStateException: Toolkit not initialized" exception in the tools bar.
Anybody found a solution to that problem ?
 
EDIT 2020-09-29 11:00 CET  : I'm not working under Ubuntu but Windows 10 if that helps. I had 3 older versions installed on the PC (including a version 3.40 or something like that and 5.10), that i deinstalled before installing the v5.40. I tried reinstalling v5.10 that i had before and that one is working, but this didnt change anything to the version 5.40 ( whcih was expected as each version comes with its own java runtime).
 
2020/09/27 23:33:59
tech24x7
Workaround: 
You can install Serial Devices Packs from MPLAB X IDE pack manager under tools menu.


Hope the next MPLAB X release will have this fix.
 
 
2020/09/29 02:35:54
eg67150
Thx Tech24x7,
that workaround seems to have fixed my buggy IPE. Meanwhile that goes against my wish to install only the IPE since the Packs seem only to be accessible from IDE....:/ But at least i can choose the device and programmers now within the IPE. Havn't tested the programming though but i'd guess that this should work now.
 
For information, i already had that problem in the past, and noticed it only happened every time i tried to install the IPE alone, without the IDE, for example on a laptop only used to program devices but not edit code.
I guess the IPE installation "only" misses installation points that are completed with the the IDE installation.
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account