2018/04/06 08:16:43
ptibruno
Hi Gents,
I've just received some BM62 bluetooth module, I've mouted them on my PCB design.
According to the steps described on the DevKit manual I've done the following steps :
- Generate the .txt file with the DSP parameters using DSPTool_IS206x_012_DualModeSPK1.1_v1.06.exe
- Generate the .txt file with UITool_IS206x_012_DualModeSPK1.1_v1.03.exe with IC package=BM62
- Merge the files using MPET.exe using the default bin file IS206X_012_DUALMODESPK1.1_E1.0.0.2_0FCD.bin
-> then I generate an Ipf file to write on BM62 EEPROM
 
Using EEPROM_Tool_V4851.exe  I've got MPSE Name : IS2064S_012_SPK02_V2.1_BETA
I'm trying to write on the EEPROM but i've got the following error : ''Device's IC version doesn't match file's IC Version: IS206X_012_DUALMODESPK1.1_E1.0""
 
When I'm doing the same steps with the DevKit it is working fine, the EEPROM tool is giving me MPSE name = IS206X_012_DUALLMODESPK1.1_E1.0
 
both module are BM62 so I'm not really understanding the meaning of the MPSE Name
 
Can anyone help with this error?
 
Thanks for your help
Regards
Bruno
 
 
 
 
 
 
 
2018/07/24 22:57:18
ryanafleming
For those who like me took a while yo get the solution. I have been working with the BM64 and had the same issue, but managed to fix it.
 
First this response is actually from the switches on the eval board being set still in programming mode rather than eeprom load mode. That is SW9 modes:
Running app: 1 off, 2 on.
Programming: 1 off, 2 off.
Programming eeprom: 1 on, 2 off.
 
Whenever you change switch states you have to power cycle the chip too, else it won't take effect.
2018/10/25 04:54:01
floppen
Hi
 
Similar problem but with BM64.
I get an error that version is wrong when i try to program EEPROM, I found that if i have pin 39 "P3_6" low i get this error and if i have it high programming the EEPROM works just fine.
2018/10/29 21:13:12
Rbaragona
Hey Bruno,
Any success with this issue?  I'm running into the same thing now, and I'm not sure how to fix it.  I've tried re-flashing the BM62s but that doesn't seem to help either.
2018/10/29 21:27:21
Rbaragona
Ah, it was as Ryan described, I just had to fully click the switch for the EAN.
 
2018/11/15 18:15:40
gcooper434
1st question: Bruno, did your problem get resolved?
2nd question: I don't understand how the switch being in the wrong position would cause Bruno's problem: if the switch was not in the right position (and the the power then turned off/on after the switch is set to the right position) then I don't see how the USB connection would be made, and there wouldn't be ANY response.
 
I'm having the very same problem Bruno reported, and I DO have the switch in the right position. Did I miss something here? I have the switch in what I think is the right position, and I have the red and blue LEDs on continuously. I can connect, and I get the same error Bruno reported. With the switch in any other position, I cannot connect, and get NO response.
 
2018/11/15 18:51:41
Rbaragona
Hi gcooper434,
I agree with your assumption, and that was my initial problem too.  I anticipated either no response or the response with the correct version.  In my particular case, it wasn't the EEPROM programming switch that was in the incorrect position, it was the the BTM_CONFIG_EAN pin.  Once I confirmed all 3 switches/pins (BTM_Config, P2_0, and P2_4) were in the correct position I was able to read the correct MPSE name and program the EEPROM.
2018/11/16 07:18:31
gcooper434
Rbaragona,

I have SW12's individual switches set as follows:
- 1: ON
- 2: OFF
- 3: OFF

When I attach the USB cable to the PC, the RED and BLUE LEDs are both on (and not blinking.) The GREEN LED is off.

When I connect (Port 28) I can click on the Module/Identify control and get the response of "IS2064S_012_SPK02_V2.1_BETA". This is different from the name shown in Illustration in FIGURE 3-30 of BM62 EVB User’s Guide (page 48).

Is there something I'm missing?

Gerald
2018/11/16 08:26:42
Rbaragona
Hi Gerald,
It sounds like your doing things correctly.  Maybe try flipping the switches back and forth, or when the USB is plugged in hit SW1, RST_N, to reset the module.
 
Maybe even try other incorrect switch positions.  I'm sorry I can't be more helpful!
 
Rob
2019/01/14 00:39:02
AleksOM
Hi All!
I have similar problem.
I used BM64 BT module with my PCB design.
I made the first version of the device more than 6 month ago.All was good.
Now I recieved more modules. All modules are v1.1. I take first module of 11, EAN->hight via 10 Ohm, P2_0->GND via 4.7 kOhm and update ROM to v2.1. But when I upload my EEPROM,which generated for BM64v2.1(EAN low,P2_0 low), I have problem:'Device's IC version doesn't match file's IC Version: IS206X_012_DUALMODESPK2.1_E1.0_BETA"
I solder my old BM64 - all working.
Herewith all modules with the same ROM version.
All new BM64 similar problem.
Then i generated new EEPROM to v1.1,but it didn't work either!
When I'm write generated EEPROM to DevKit all working fine(I updated the version to v2.1).
Can anyone help me?
12
© 2021 APG vNext Commercial Version 4.5

Use My Existing Forum Account