
 
 Getting Started with the MCC AVR® and PIC16/18 IEC60730

Class B Diagnostic Libraries

Introduction
The MPLAB® Code Configurator AVR® and PIC16/18 IEC60730 Class B Diagnostic Libraries are suites of diagnostic
tests in compliance with the IEC 60730 Class B functional safety standard. These libraries are distributed as MPLAB
X MCC modules, which allow quick and easy configuration using graphical interfaces. MCC generates code for
MPLAB X and the MPLAB XC8 compiler projects, based on the selections and configuration.

This document contains instructions on how to install the libraries, add diagnostic tests, and run the examples.
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1. Installing the Library
To use the libraries, install the MPLAB Code Configurator plug-in tool in the MPLAB X IDE. This section describes
how to install MCC and the IEC60730 Class B Diagnostic Libraries.

1. To install the MPLAB Code Configurator Plugin (see Figure 1-1):
1.1. In the MPLAB X IDE, select Plugins from the Tools menu.
1.2. Select the Available Plugins tab.
1.3. Look for the MPLAB Code Configurator, and click Install.

Figure 1-1. Installing MCC

2. To install the IEC60730 Class B Diagnostic Libraries:
2.1. Download the AVR and PIC16/18 IEC60730 Class B Diagnostic Libraries and release notes from the 

MCC website under Current Download → Application Libraries → AVR IEC60730 Class B Diagnostic
Library and PIC16/18 IEC60730 Class B Diagnostic Library (see Figure 1-2).

2.2. In the MPLAB X IDE, select Options from the Tools menu.
2.3. In the Plugins → MPLAB® Code Configurator 4.x tab, click Install Library.
2.4. Provide the path to the downloaded avr-iec60730-class-b-diagnostic-library-

x.y.z.mc3lib or pic16-pic18-iec60730-class-b-diagnostic-library-x.y.z.mc3lib
file.

Figure 1-2. Downloading from the MCC Website
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3. To load the IEC60730 Class B Diagnostic Libraries from the MCC Versions Window (see Figure 1-3):
3.1. Open MPLAB Code Configurator v4 from the Tools → Embedded menu.
3.2. Expand the Versions tab under Software → AVR IEC60730 Class B Diagnostic Library or Software

→ PIC16/18 IEC60730 Class B Diagnostic Library (the green mark indicates the loaded version).
3.3. Right click on the desired version of the library (see the Note below) and select Mark for Load.
3.4. Click the Load Selected Libraries button to load the library.

Figure 1-3. Loading from the MCC Versions Window

Note:  The help icon beside the library version leads to the release notes.
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2. Adding Diagnostic Tests
This section describes how to add diagnostic tests using MCC and the IEC60730 Class B Diagnostic Libraries in
MPLAB X projects.

1. Create a new project in the MPLAB X IDE for any supported device specified in the library release notes (e.g.,
ATtiny3217). To view the release notes, refer to step 2.1 in 1.  Installing the Library or the Note above.

2. Open MCC by clicking Tools → Embedded → MPLAB® Code Configurator v4, or click the  icon.
3. In the Device Resources panel under the Libraries → Functional Safety Libraries drop-down, select IEC60730

Class B Diagnostic Library.
4. Enable the desired modules to be added from the Diagnostic Modules tab selection (e.g., CPU). This step

will open the specific module tab, which contains the available diagnostic tests (see Figure 2-1).
Figure 2-1. Enabling the CPU Tests

5. Switch to the CPU tab, and the available diagnostic tests are enabled by default (see Figure 2-2).
Figure 2-2. Available CPU Tests

6. Some diagnostic tests have configurable parameters for modifying the tests as needed. In Figure 2-3, the
Flash test has the option to test the entire Flash memory or just 32 words as set by the Flash Length
parameter.
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Figure 2-3. Configuring the Flash Test

7. Once all preferred tests are enabled and configured, click the Generate button to add these test codes, along
with supporting API documentation, into the IDE project (see Figure 2-4 and Figure 2-5).
Figure 2-4. Generation of Test Files
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Figure 2-5. Project Files

 
Adding Diagnostic Tests

© 2021 Microchip Technology Inc.  User Guide DS50003109A-page 7



3. Library API Documentation
Each diagnostic test comes with the API documentation. Upon generating code from MCC for a diagnostic test, the
associated API documentation is generated and can be accessed from mcc_generated_files/
documentation/iec60730-test-name.chm (see Figure 3-1).

Figure 3-1. Navigating to the Test API Documentation

To view the API documentation, right click on the .chm file and select Open in System. These documents contain
detailed descriptions for each test, and test code contents (see Figure 3-2), which help users understand the usage
of the generated APIs.
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Figure 3-2. CPU Program Counter Test API Documentation
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4. Running the Examples
Examples are available for each diagnostic test. Users can generate these examples if the options are enabled in the
user interface.

1. In the MCC window, navigate to the IEC60730 Class B Diagnostic Library module and enable a diagnostic test
(e.g., CPU Program Counter).

2. Switch to the CPU tab, and enable the Generate Example box of the Program Counter test (see Figure 4-1).
Figure 4-1. Enabling the Program Counter Test Example

3. For displaying the test example output, select a USART under Peripherals in the Device Resources panel.
4. Enable Printf support for AVR devices, or Redirect STDIO to USART for PIC® devices. Configure the other

options to match the preferred serial terminal settings (see Figure 4-2).
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Figure 4-2. Configuring the USART in ATtiny3217

5. Click the Generate button.
6. Include the header mcc_generated_files/diag_common/examples/diag_common_example.h in

main.c. This header contains all the generated example functions.
7. Call the example function DIAG_CPU_ProgramCounter_Example() in main() (see Figure 4-3).

Figure 4-3. Adding the Test Example to main.c

8. Connect a board with the selected device to the PC (e.g., an ATtiny3217 Curiosity Nano).
9. Build and program the board.
10. Open and configure a serial terminal to view the example output (see Figure 4-4).
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Figure 4-4. Program Counter Test Output in the Serial Terminal
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5. Revision History
Doc. Rev. Date Comments

A 01/2021 Initial document release.
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner and under normal

conditions.
• There are dishonest and possibly illegal methods being used in attempts to breach the code protection features

of the Microchip devices. We believe that these methods require using the Microchip products in a manner
outside the operating specifications contained in Microchip’s Data Sheets. Attempts to breach these code
protection features, most likely, cannot be accomplished without violating Microchip’s intellectual property rights.

• Microchip is willing to work with any customer who is concerned about the integrity of its code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code

protection does not mean that we are guaranteeing the product is “unbreakable.” Code protection is constantly
evolving. We at Microchip are committed to continuously improving the code protection features of our products.
Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act.
If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue
for relief under that Act.
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Legal Notice

Information contained in this publication is provided for the sole purpose of designing with and using Microchip
products. Information regarding device applications and the like is provided only for your convenience and may be
superseded by updates. It is your responsibility to ensure that your application meets with your specifications.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL OR
CONSEQUENTIAL LOSS, DAMAGE, COST OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or
expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual
property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox,
KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST,
MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer,
QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon,
TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology Incorporated
in the U.S.A. and other countries.

AgileSwitch, APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed
Control, HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC
Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra,
TimeProvider, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut, Augmented Switching,
BlueSky, BodyCom, CodeGuard, CryptoAuthentication, CryptoAutomotive, CryptoCompanion, CryptoController,
dsPICDEM, dsPICDEM.net, Dynamic Average Matching, DAM, ECAN, Espresso T1S, EtherGREEN, IdealBridge, In-
Circuit Serial Programming, ICSP, INICnet, Intelligent Paralleling, Inter-Chip Connectivity, JitterBlocker, maxCrypto,
maxView, memBrain, Mindi, MiWi, MPASM, MPF, MPLAB Certified logo, MPLIB, MPLINK, MultiTRAK, NetDetach,
Omniscient Code Generation, PICDEM, PICDEM.net, PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE,
Ripple Blocker, RTAX, RTG4, SAM-ICE, Serial Quad I/O, simpleMAP, SimpliPHY, SmartBuffer, SMART-I.S., storClad,
SQI, SuperSwitcher, SuperSwitcher II, Switchtec, SynchroPHY, Total Endurance, TSHARC, USBCheck, VariSense,
VectorBlox, VeriPHY, ViewSpan, WiperLock, XpressConnect, and ZENA are trademarks of Microchip Technology
Incorporated in the U.S.A. and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of
Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip
Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
© 2021, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

ISBN: 978-1-5224-7470-8
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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