
 MPLAB IPE User's Guide
 MPLAB IPE (Integrated Programming Environment)

User's Guide

Notice to Customers

Important: 
All documentation becomes dated, and this manual is no exception. Microchip tools and documentation
are constantly evolving to meet customer needs, so some actual dialogs and/or tool descriptions may differ
from those in this document. Please refer to our website (www.microchip.com) to obtain the latest
documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each page, in front
of the page number. The numbering convention for the DS number is “DSXXXXXA”, where “XXXXX” is the
document number and “A” is the revision level of the document.

For the most up-to-date information on development tools, see the MPLAB® X IDE online help. Select the
Help menu, and then Topics to open a list of available online help files.
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1. Introduction
This chapter contains general information that will be useful to know before using the MPLAB® Integrated
Programming Environment (IPE) installed. This document is compatible with the version of the IPE installed with
MPLAB X IDE v5.40 or greater.

1.1 Conventions Used in This Guide
This manual uses the following documentation conventions:

Table 1-1. Documentation Conventions

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or dialog “Save project before build”

Underlined, italic text with right
angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, where N is
the total number of digits, R is the
radix and n is a digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START
Filenames autoexec.bat
File paths c:\mcc18\h
Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-
Bit values 0, 1
Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be any valid
filename

Square brackets [ ] Optional arguments mcc18 [options] file
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0|1}
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...........continued
Description Represents Examples

Ellipses... Replaces repeated text var_name [, var_name...]
Represents code supplied by user void main (void)

{ ...
}

1.2 Recommended Reading
This user's guide describes how to use Microchip MPLAB IPE. Other useful documents are listed below. The
following Microchip documents are available and recommended as supplemental reference resources.

Multi-Tool Design Advisory (DS51764)

Please read this first! This document contains important information about operational issues that should be
considered when using the MPLAB IPE with your target design.

MPLAB X IDE Online Help

This is an essential document to be used with any Microchip hardware tool.

This is an extensive help file for the MPLAB X IDE. It includes an overview of embedded systems, installation
requirements, tutorials, details on creating new projects, setting build properties, debugging code, setting
configuration bits, setting breakpoints, programming a device, etc. This help file is generally more up-to-date than the
printable PDF of the user’s guide (DS50002027) available as a free download at https://www.microchip.com/mplabx/.

Release Notes for MPLAB IPE

For the latest information on using the MPLAB IPE, read the notes under “Release Notes and Support
Documentation” on the MPLAB X IDE Start Page. The release notes contain updated information and known issues
that may not be included in this guide.

MPLAB IPE Online Help File

A comprehensive help file for the MPLAB IPE is included with MPLAB X IDE. This help file may be more up-to-date
than the printed documentation.

Processor Extension Pak and Header Specification (DS50001292)

This booklet describes how to install and use headers. Headers are used to better debug selected devices, without
the loss of pins or resources. See also the PEP and Header online Help file.

Transition Socket Specification (DS51194)

Consult this document for information on transition sockets available for use with headers.

SQTP File Format Specification (DS50002539)

This document shows how a Serial Quick Turn Programming (SQTPSM) file is produced and used by MPLAB® IPE
Integrated Programming Environment. Engineers can use this information to generate their own SQTP file.

 MPLAB IPE User's Guide
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2. MPLAB IPE Overview

2.1 IPE Defined
The MPLAB® Integrated Programming Environment (IPE) is a software application that provides a simple interface to
quickly access key programmer features. The IPE provides a production user interface for use on the manufacturing
floor.

The MPLAB IPE uses the MPLAB X IDE v4.20 or greater framework, Microchip Debugger (MDB) database,
hardware tool interfaces and respective drivers to provide programming capabilities for all Microchip programmers.

The MPLAB IPE is compatible with any of these platforms:

• Microsoft Windows® 7 or later
• Linux®

• macOS™

2.2 Software Installation Requirements
The MPLAB IPE application must be installed on your PC. It is available during the MPLAB X IDE installation process
if the check box is selected (see the setup figure below). You do not need to install the MPLAB X IDE in order to use
the IPE application. However, you may want to refer to the online help for the MPLAB X IDE for additional
information. Also select the check boxes for the device support you want installed.

 MPLAB IPE User's Guide
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Figure 2-1. Select Applications Dialog

Once you’ve installed the software, the IPE application can be accessed through the MPLAB IPE icon on your
desktop or startup menu.

2.3 Programming Tools Supported
The following programming tools work with the IPE:

• MPLAB ICD 3 In-Circuit Debugger – recommended for production programming
• MPLAB ICD 4 In-Circuit Debugger – recommended for production programming
• MPLAB PICkit™ 3 Debugger/Programmer – for development programming only
• MPLAB PICkit™ 4 In-Circuit Debugger – recommended for production programming
• MPLAB Snap In-Circuit Debugger – for development programming only
• MPLAB PM3 Programmer – recommended for production programming
• MPLAB REAL ICE™ Emulator – recommended for production programming
• Licensed PKOB Starter Kits – recommended for development programming only

2.4 IPE Modes
The IPE application operates in two modes:

• Production Mode – in which you can perform production programming operations. By default, the IPE is in
Production Mode when it is launched. The Production Mode capabilities are set from the Advanced Mode menu
discussed in 3.4.6  Production of this document.
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• Advanced Mode – a feature-rich GUI interface in which you can view and change the settings for programming
operations, and set up a production user interface for use on the manufacturing floor. To enable Advanced
Mode, see 3.2  Setting Up the Programmer.

 MPLAB IPE User's Guide
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3. General Setup
Getting started with the MPLAB® IPE is discussed in this chapter.

3.1 Launching the MPLAB IPE Application
After installing the software, double-click the MPLAB IPE application icon located on the desktop. The MPLAB IPE
main window opens.

Figure 3-1. MPLAB IPE Main Window

Multiple Instances of IPE

If you need to have multiple instances of the IPE available, refer to the MPLAB X IDE help. Open MPLAB X IDE, go
to Help>Tool Help Contents>MPLAB X IDE Help and navigate to the “Before You Begin” section, then “Launch
Multiple Instances of the IDE.” The instructions also apply to the IPE.

3.2 Setting Up the Programmer
For programming devices, you can use any of the supported tools (see 2.3  Programming Tools Supported). Refer to
the online help of the selected tool (for example, MPLAB ICD 4, PICkit 4, etc.) for information on programming a
device.

1. Using the Family drop-down menu, select the family of the device you wish to program, then use the Device
drop-down menu to select the device. Or, use the Device drop-down menu directly to select the device.
Note:  Selecting the Recently Used option from the Family menu lists the latest 10 devices used in the Device
menu.

 MPLAB IPE User's Guide
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Figure 3-2. Recently Used

2. Click Apply to configure the IPE to the current device (for example, Target Memory Views, checksum).
3. Connect the development tool to the PC and attach the appropriate target board, device and power. Refer to

the tool’s online help for additional instructions and information on connecting to target boards, etc.
4. Use the Tool drop-down menu to select the tool you want to use. If more than one development tool is

connected to the PC, select the one you wish to use.
Figure 3-3. Select Tool

5. Click the Connect button (next to the Tool name) to establish a connection between the IPE and the tool.
6. When the tool is connected, any messages or errors related to this tool will be displayed in the Output window

(refer to the following figure).

 MPLAB IPE User's Guide
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Figure 3-4. Output Window

7. After the tool is successfully connected, proceed to the next chapter to program the device with the IPE.

3.3 Advanced Mode Login

3.3.1 Logging In
Typically, someone has been authorized to establish the settings that production will use for the device and tool. To
input those settings, log in to the Advanced mode.

Select Settings>Advanced Mode to open the Advanced Mode login dialog. The password is case sensitive. Type in
the default password microchip and click Login.

 MPLAB IPE User's Guide
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Figure 3-5. Advanced Mode Login

3.3.2 Changing the Password
To change the password after the initial log on, click Change Password. A Change Password dialog opens.

If you forget the new password, click on Forgot Password under the Log in button. The Forgot Password dialog
opens where you can answer the security question used when you changed the default password (microchip) to a
new one. Once you enter the answer, click Submit and it displays your password.

 MPLAB IPE User's Guide
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3.3.3 Staying Logged In
To start up the MPLAB IPE directly in Advanced mode without entering the password again, type the password,
select the “Keep me logged in” check box, then click Log on. A new installation or first time usage will launch the
MPLAB IPE in basic mode. Once the “Keep me logged in” check box is selected, subsequent launches will open in
Advanced mode.

To cancel the automatic Advanced mode login, click Logout (see figure below) on the Advanced Settings dialog.

Figure 3-6. Cancel Keep Me Logged In

3.4 Advanced Mode Settings
Advanced mode settings must be set by someone authorized to do so. Some settings that are selected in these
dialogs will allow a production specialist to view and control certain commands from the IPE Menu bar, Settings
menu.

3.4.1 Operate
After validating the password to log in to the Advanced Mode, the dialog opens in the Operate view. This display is
similar to the main display, with the addition of option buttons located along the left side of the window. The dialog
shows the device and tool that has been selected (see Section 2.3 “Setting Up the Programmer”).

 MPLAB IPE User's Guide
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Figure 3-7. Advanced Mode, Operate Dialog

3.4.2 Power
The Power option is available only when a tool is connected. From the Advanced Mode dialog, click Power to display
the available settings. Depending on the tool and the device, only the options available for that combination display.

Memory options will vary for different device families and the tool selected. All of the settings and parameters are
similar to MPLAB X IDE.

Table 3-1. Power Settings

Setting Description

Note: The options available will vary depending on the device and too selected. The following may not show every
possible option.

Voltage Options

VDD Min/Max This voltage is used by the programmer to verify memory. The value should be the
minimum/maximum voltage for the designated circuit. The default is the device's
maximum voltage value.

VDD Nom The default value depends on the device. For example, PIC32 has 3.3V as default
VDD Nom.

VPP This is the voltage used to bring the device into a programming mode. Although this
is dependent on the device's programming specification, it can be changed.

VDD App This is the voltage used by the programmer to verify Flash memory. The default is
the device's nominal voltage value.

Power target circuit from (tool) This setting enables the tool to power the target.

Voltage Level Set the level you want to use.

 MPLAB IPE User's Guide
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...........continued
Setting Description

Programming Options

Programming mode entry Select “Use low voltage programming mode entry” or “Use high voltage
programming mode entry”.

Programming Method Select either “Apply Vdd before Vpp” or “Apply Vpp before Vdd.”

Reset to defaults Returns voltages to their default settings.

3.4.3 Memory
From the Advanced Mode dialog, click Memory to display the available settings for the device and tool you selected.
You can control the memory address and other parameters related to a programming operation. Some of the options
in this window are also available on the main screen, for viewing and to provide easy access to these settings.

Memory options will vary for different device families and the tool selected. All of the settings and parameters are
similar to MPLAB X IDE.

Note:  The memory settings for the MPLAB PM3 Programmer may be different in versions of MPLAB IPE prior to
v3.60.

Table 3-2. Memory Settings

Setting Description

Note: The options available will vary depending on the device and too selected. The following may not show every
possible option.

Allow select memories and
ranges

Select either “Allow (tool) to Select Memories” or “Manually select memories and
ranges.”

Configuration Memory When selected, this setting allows the tool to program the configuration memory.

Auxiliary Memory When selected, this setting allows the tool to program the auxiliary memory.

Flash Data When selected, this setting allows the tool to program the Flash data.

EEPROM When selected, this setting allows the tool to program the EEPROM.

ID When selected, this setting allows the tool to program the User IDs.

Boot Flash When selected, this setting allows the tool to program the Boot Flash.

Program Memory When selected, this setting allows the tool to program the program memory.

Program Memory Range(s)
(hex)

The address range in Hex of the program space that will be programmed.

Preserve Program Memory When selected, this setting allows the tool to preserve the program memory.
If you wish to use any of the Preserve Memory options, first ensure that your code is
not code-protected. For memory to be preserved, the programmer reads the section it
needs to save, performs a bulk erase of the device, reprograms the device and then
rewrites the area that is preserved with what was saved. Therefore, this area cannot
be code protected.

Note:  The MPLAB PM3 programmer does not support the Preserve Memory options
in the environment .pm3 files.

Preserve Program Memory
Range(s)(hex)

The address range in Hex of the program space that will be preserved.

Preserve ID Memory When selected, the ID memory will not be programmed with any new data that is
present in the ID memory. Only available if device has user ID memory.
Note:  PIC32M devices do not support preserving user ID or Boot memory.

 MPLAB IPE User's Guide
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...........continued
Setting Description

Reset Returns addresses to default settings.

The MPLAB PM3 programmer does not support the Preserve Memory options in the environment .pm3 files.

If you wish to use any of the Preserve Memory options, first ensure that your code is not code-protected. For memory
to be preserved, the programmer reads the section it needs to save, performs a bulk erase of the device, reprograms
the device and then rewrites the area that is preserved with what was saved. Therefore, this area cannot be code
protected.

PIC32M devices do not support preserving User ID or Boot Memory.

3.4.4 Environment
Environments allow you to save settings, so that all of the same settings can be reloaded in another programming
session. Environments are supported, under all tools, as either .pen files or .pm3 files.

Note:  MPLAB PM3 programmer does not support the Preserve Memory options in the environment .pm3 files.

From the Advanced Mode dialog, click Environment to display the available settings.

Table 3-3. Environment Settings

Setting Description

Note: The options available will vary depending on the device and too selected. The following may not show every
possible option.

Create Environment Tab

Environment Information

Name Enter a name for the environment.

.pm3 file For MPLAB PM3, select this type of file.

.pen file For MPLAB ICD 3/4, PICkit 3/4 and REAL ICE tools, select this type of file.

Description Enter the description for the environment.

Misc Files Add or remove other files used in the environment, for example, data sheets, instructions, etc.
Multiple files can be selected.

SQTP File Browse or enter the SQTP file name used in the environment.

Save to PM3 Card Saves the environment file to a MPLAB PM3 SD card destination. See ADD LINK TO
REFERENCE SECTION Save Firmware into PM3 SD Card for additional information on saving
multiple operating system firmware to the SD card.

Save to PC Saves the environment file to a destination on the PC

Copy Opens the Copy Environment dialog to select source and destination for copying the
environment.

Browse Environments Tab

Browse on: Select either PC or MPLAB PM3 Card.

PC When the PC is selected, it opens the PM3 Environment file selection browser for you to select
an environment to load into the MPLAB PM3.

 MPLAB IPE User's Guide
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...........continued
Setting Description

MPLAB PM3 Card When this option is selected, it opens the PM3 Card browser for you to select an environment
from the files on the PM3 Card. In the browser, you can:
view the properties of the PM3 SD Card

format the PM3 SD card

select an environment to load into the MPLAB PM3; the information displays in the Environment
Settings window

select an environment to delete from the PM3 Card

select an environment to view information; information displays in the Environment Settings
window

Environment 
Information

Displays information related to the selected environment file such as Name, Path and
Environment Description. From here, you can select to clear the information or load the
environment into the MPLAB PM3.

3.4.5 SQTP
SQTP (serial quick turn programming) is used to program a unique serial number into each device. This number can
be used as an entry code, password or ID number.From the Advanced Mode dialog, click SQTP to display the
available settings.

If using SQTP with MPLAB PM3, see “Using SQTP with MPLAB PM3” below for additional information. If using
PIC32 devices, see “Using SQTP with PIC32 Devices” below for information on the import methods. For information
about how the SQTP files are produced, refer to the SQTP File Format Specification (DS50002539).

Table 3-4. SQTP SETTINGS

Setting Description

Note: The options available will vary depending on the device and too selected. The following may not show every
possible option.

Generation Method:

Random Select this option to generate unique, random numbers for each part.
Also enter the start address, number of bytes and number of parts in the
corresponding fields.

Pseudo-Random
Seed Value (Hex):

Select this option to generate a pseudo-random set of non-repeating numbers
based on the Hex value you enter into the Seed Value field.
Also enter the start address, number of bytes and number of parts in the
corresponding fields.

Sequential
Start Value (Hex):

Increment (Dec):

Select this option to generate sequential numbers based on the starting value
specified and incrementing each number by the amount specified.
Also enter the start address, number of bytes and number of parts in the
corresponding fields.

Configuration:

Start Address (Hex) Enter the starting address (in Hex) for the serial number.

Number of Bytes (Dec) Enter the size of the serial number (in decimal).
Make sure a large enough serial number is specified for the number of parts
planned to program using this file.

Number of parts (Dec) Enter the number of parts to be programmed using this file.

Location:

 MPLAB IPE User's Guide
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...........continued
Setting Description

Program Memory Select this option to load the SQTP number in program memory.

EEPROM Select this option to load the SQTP number in EEPROM.

Auxiliary Memory Select this option to load the SQTP number in auxiliary memory.

User OTP Memory Select this option to load the SQTP number in One-Time Program memory.

User ID Memory Select this option to load the SQTP number in user ID memory.

Boot Memory Select this option to load the SQTP number in boot memory.

Flash Data Select this option to load the SQTP number in Flash memory.

Access Method:

RETLW Select this option to use a series of RETLW (Return Literal W) instructions with the
serial number bytes as the literal data.

Raw Data Select this option to use the raw data.

Format for PSV If the Raw Data option is selected, selecting Format for PSV formats SQTP data to
make it compatible with PSV (Program Space Visibility).

Programming Options:

Disable operations of SQTP
values are exhausted

Select this option to cease programming if there are no more SQTP values
available.

Display the next SQTP
sequence in the output
window

Select this option to display the information in the output window.

Generate Click Generate to create the SQTP (.num) file.

Using SQTP with MPLAB PM3

SQTP files for Flash Data memory that were generated prior to MPLAB IPE v2.20 will work with MPLAB PM3
firmware up to v3.00. SQTP file generation for Flash Data memory has been modified to the 32-bit byte order
(12345678) and the firmware is updated accordingly. A new SQTP file must be regenerated to work with MPLAB IPE
v3.00 and higher.

Using SQTP with PIC32 Devices

For PIC32 devices only, starting with MPLAB IPE v3.15, a dialog box, similar to the one below, is provided to choose
either 32-bit byte order (12345678) or 16-bit byte order (56781234) when loading an SQTP file.

Figure 3-8. Import SQTP File Dialog

3.4.6 Production
From the Advanced Mode dialog, click Production to display the available settings.

 MPLAB IPE User's Guide
General Setup

© 2020 Microchip Technology Inc.  User Guide DS50002227E-page 18



The Production Settings dialog enables authorized personnel to select the options that are available during
production programming. The options that are selected in the Production Settings (see table below) determine which
commands will be available under the main IPE menu bar’s File, View, and Settings menus when in Production
Mode.

Select the appropriate settings for your production programming project by checking or unchecking the settings.
Selecting a check box in the Production Settings dialog causes a check mark to display in front of that option under
the Settings menu on the main IPE menu bar.

A check mark indicates that an option has been set in the Advanced Mode. If the item is available and has a check
mark, then the production specialist can control this item by toggling it on or off.

Table 3-5. Production Settings

Setting Description

Allow Export Hex This setting enables a production specialist to export Hex files.
If checked, this option displays under the File>Export menu.

Allow Import Hex file Enables a production specialist to import Hex files.
If checked, this option displays under the File>Import menu.

Note:  If using a Hex file in the IPE and the file is modified using Notepad, MPLAB X
IDE, etc., outside of the IPE, a message displays: “File modified. The loaded hex file
has been modified externally. Would you like to reload hex file?”

Auto reset program stats
counter

Automatically resets the program statistics counter.

Allow Import Multiple Hex
files

This setting enables a production specialist to import multiple Hex files.
If checked, this option displays under the File>Import menu.

Allow Import Environment This setting enables a production specialist to import environments.
If checked, this option displays under the File>Import menu.

Allow Import SQTP file This setting enables a production specialist to import SQTP files.
If checked, this option displays under the File>Import menu.

Generate Reports This setting enables reports to be generated.
If Generate Reports is checked, click Browse to set the location where the reports
will be placed.

Limit the Program Count to If selected, this option limits the pass, fail, and total counts to the value that is
entered into the associated field.
This actually halts further programming operations from occurring.

To clear the counts on the main window, click Reset Counters.

Allow “Verify Device ID
before Program” under
Settings menu (Applicable
only for PM3)

This setting activates this option in the Settings menu and enables a production
specialist to control this option.
This setting is valid only for tools that are capable of performing this function, for
example, MPLAB PM3.

Allow “Auto Download
Firmware” under Settings
menu

If selected, this option displays in the Settings menu and can be controlled by a
production specialist.
If it is not selected, the IPE automatically downloads the latest firmware for the tool, if
needed.
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...........continued
Setting Description

Allow “Erase All before
Program” under Settings
menu (Applicable only for
PM3 and Gen4)

If selected, this option displays in the Settings menu and can be controlled by a
production specialist.
If it is not selected, the production specialist cannot control this option from the
Settings menu.

Note:  This option will only be enabled under the Settings menu if the PM3 is
connected. For all other tools, this setting is set to true by default and cannot be
changed.

Allow “PM3 Communication”
under Settings menu

If selected, this option is enabled and can be controlled by a production specialist.
If using the MPLAB PM3 programmer COM port (RS-232), you must select this
option in order to set the appropriate COM port.

Remove Read button from
main window

If this option is selected, the Read button is removed from the main window.

Audible notification on
successful program
completion

If selected, this option generates a sound when programming completes
successfully.

Allow memory editing and
filling

Enables memory editing and filling of Execution Memory, Configuration Bits, User ID
Memory or Device ID Memory.
If enabled, this option is accessed in Production Mode from the 
Window>Target Memory Views option.

Display EEPROM checksum
in the output window

If selected, the EEPROM checksum is displayed in the output window. “EEPROM
checksum” is the checksum of the EEPROM memory in the MCUs (PIC18F1220 for
example) and not the memory from the exclusive memory devices such as 11AA/
LCxxx, 24AA/LC/FCxxx.

Display imported hex file
checksum with CP=OFF

If selected, the non-code protected checksum is displayed in the Results area.
A checksum is a calculated value (see the device programming specification for
calculation) that should match the value of the programmed device when performing
a read of the device. If selected, the CP=OFF checksum setting displays the
checksum of the hex file with the code protection bit disabled. This allows for a
meaningful checksum value for hex images with enabled code protection bits.

Enable programming
operations only if hex file is
loaded

If selected,
If Hex file is not loaded: All the programming buttons (Program, Read, Erase, Verify,
Blank Check) will be disabled.

If Hex file is loaded, all the programming buttons will be enabled.

Allow Memory View

Program Memory If this option is selected, program memory can be displayed in the Windows>Target
Memory Views on the main window.

Auxiliary Memory If this option is selected, auxiliary memory can be displayed in the Windows>Target
Memory Views on the main window.

User IDs If this option is selected, user IDs can be displayed in the Windows>Target Memory
Views on the main window. This is only applicable if user IDs are supported by the
tool.

Config Memory If this option is selected, configuration memory can be displayed in the
Windows>Target Memory Views on the main window.

Flash Data If this option is selected, Flash memory can be displayed in the Windows>Target
Memory Views on the main window.
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...........continued
Setting Description

EEPROM If this option is selected, EEPROM memory can be displayed in the Windows>Target
Memory Views on the main window.

3.4.7 Settings
From the Advanced Mode dialog, click Settings to display the available options. If you are connected to a Microchip
tool there are additional options.

Table 3-6. Special Settings

Settings Description

Note: The options displayed are dependent on the device and tool selected. This table may not show every
possible option.

JTAG Communications method

JTAG Method Select 2-wire JTAG or 4-wire JTAG.

Communication settings for AVR or SAM devices

Interface Select JTAG or ISP.

Speed (MHz) Type in the appropriate speed.

Programming Options

Program calibration memory Select if you want to program calibration memory.

Diagnostics

Logging Level Set the message logging level.
OFF: No logging

SEVERE: Log severe (error) messages only.

WARNING: Log warning messages only.

INFO: Log informational messages only.

CONFIG: Log configuration information only.

FINE: Log some module-to-module communication.

FINER: Log more module-to-module communication.

FINEST: Log all module-to-module communication.

Log File Path and name of log file.

Tool Pack Selection

Tool pack update options Select from the available options:
Use latest installed tool pack (Recommended)

Use specific tool pack - opens a Select Tool Pack dialog showing the
available version(s).

Specifically selected version Displays the available versions.

Device Pack Selection

Device Packs The device pack for the currently selected device. Changing the device pack
selection is enabled only if the tool is disconnected.

Special Memory Regions

 MPLAB IPE User's Guide
General Setup

© 2020 Microchip Technology Inc.  User Guide DS50002227E-page 21



...........continued
Settings Description

Program Calibration Memory Enables programming of registers used to hold calibration values for a
device.

Program/Read User OTP Enables programming or reading of a serial user ID that is OTP (one time
programmable). Once programmed, it cannot be changed.

Secure Segments

Segments to Program Available only for devices with CodeGuard, for example,
dsPIC33FJ12GP202, etc. Supported by REAL ICE, MPLAB ICD 3 and PICkit
3.
Select the segments to program:

Full Chip Programming

Boot, Secure and General Segments

Secure and General Segments

General Segment Only

SQTP

Disable operations if SQTP values
are exhausted

Selecting the check box prohibits further programming if all SQTP values
from the specified .num file have been exhausted.

Display the next SQTP sequence in
the output window

Select this check box to display the next SQTP sequence in the output
window.

Programming Method

This option allows you to choose the Test mode entry method for devices. This feature is supported by the tools
which can power the target (except for PM3).This setting refers to the order in which the Vpp and Vdd voltages will
be applied when programming/reading the target device.

Apply Vpp before Vdd 
(Recommended)

This is the default setting.

Apply Vdd before Vpp Caution is recommended when using this setting as it may have adverse side
effects. This option is available only when powering the device from the
debug tool.

(Tool) Options

PGC Configuration Select either none, pull up or pull down. The default is pull down.

PGD resistor value (Kohms) Type in a resistor value from 0-50.The default value is 4.7 Kohms.

PGC resistor value (Kohms) Type in a resistor value from 0-50.The default value is 4.7 Kohms.

LED Brightness setting Select the level of brightness from 1 (darkest) to 10 (brightest); the default is
5.

PGD Configuration Select either none, pull up or pull down. The default is pull down.

Program Speed Select either Low, Normal or High. The default is Normal.

Programmer-To-Go

Image Name The default is “<your project name>_ptg,” but you can edit the name. This will
be the folder name on the microSDHC card that contains the appropriate files
for Programmer-To-Go.
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...........continued
Settings Description

Send image to tool The check box is selected by default. With the box checked, the PTG image
is created and then sent to the microSDHC card in the connected MPLAB
PICkit 4.

Program Device The check box is selected by default. When the check box selected, the
device connected to the MPLAB PICkit 4 is programmed.
Note:  If both the Send image to tool and Program Device check boxes are
unchecked, see the MPLAB PICkit 4 In-Circuit Debugger User’s Guide topic
on “Setting Up PTG Mode Without a Memory Card.”

3.4.8 Logout
After the settings are selected, click Logout to save your settings, exit the Advanced Mode, and return to the main
window.
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4. MPLAB IPE Reference

4.1 IPE Main Window
The following figure shows the main window of the IPE. The IPE Menu bar contains the following menus, with
commands:

• File Menu
• Settings Menu
• View Menu
• Tools Menu
• Window Menu
• Help Menu

Commands are available based on several factors, such as the device selected or the settings selected in Advanced
Mode.

Figure 4-1. IPE Main Window

Table 4-1. IPE Main Window Fields

Item Description

Select Device and Tool:
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...........continued
Item Description

Family Filters devices by family or recently used.

Device Specifies the device; click Apply to select.

Tool Specifies the tool; click Connect or Disconnect as appropriate.

Results:

CP=OFF Checksum This field displays only if enabled in Advanced Mode.
Displays the imported hex checksum as if code protect is off for the device with current
memory contents; value can be copied using CTRL+C.

Checksum Checksum value for the device with current memory contents; value can be copied using
CTRL+C

Pass Count Details the number of programming operations that passed.

Fail Count Details the number of programming operations that failed.

Total Count The total number of programming operations.

Command Buttons:

Program Programs the device.

Erase Erases the device.

Read Reads the device.

Verify Performs a verify operation on the device.

Blank Check Checks whether the device is blank.

Other:

Hex File The Hex file location, Browse to locate the file.

SQTP The SQTP file location, Browse to locate the file.

Output Tab Display of output data.
Right-click in the Output window to access additional options.

Tool Tab Display of specific tool data, for example, PM3, ICD 4, PICkit 4.

4.2 File Menu
On the IPE menu bar, the File menu provides three commands:

• Export
• Import
• Exit

4.2.1 File>Export
The Export menu item allows you to export data from IPE to storage media. By default, these commands are not
available in Production Mode. However, in Advanced Mode, an authorized user can change the default states of this
feature for the Production Mode.

File>Export>Hex – this command allows you to export all the memory contents into Intel® Hex file format.
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4.2.2 File>Import
The Import menu item allows you to import various files into the IPE. By default, these commands are not available in
Production Mode. However, in Advanced Mode, an authorized user can change the default states of this feature for
the Production Mode.

• File>Import>Environment – select to import (load) the environment (*.pen or .pm3 file).
• File>Import>Hex – select to import a hexadecimal file (*.hex).

Note:  If using a Hex file in the IPE and the file is modified using Notepad, MPLAB X IDE, etc., outside the IPE,
the following message displays:

• File>Import>Multiple Hex – select to import multiple hexadecimal files (*.hex).
Note:  If Hex files were generated for individual memories for EEPROM, Flash, etc., these Hex files can be
imported in the MPLAB IPE. These files are loaded in a FIFO (first in, first out) manner. When loaded into the
IPE, the contents are loaded into the respective memory regions of the selected device. If memory regions
overlap, a warning message displays in the Output window.

From the Hex File Selection dialog, click the + button to browse and add files, or click the - button to remove a
file. Select Load to import the files.

• File>Import>SQTP – select to load the SQTP file (*.num file).

4.2.3 File>Exit
This command closes the IPE application.

4.3 Settings Menu

4.3.1 Understanding the Settings Menu Commands
The Settings menu on the IPE Menu bar (see table below) contains commands available for production personnel.
Many of these commands are made available through the Advanced Mode, Production Mode dialog.

Menu commands are shown as active (black) or unavailable (grayed out).

Active commands with a check mark indicate that the production personnel can control these settings.

Active commands without a check mark indicate that only authorized personnel can access them.

Unavailable commands with or without a check mark indicate that production personnel cannot control these settings.

Table 4-2. Settings Menu Commands

Setting Description

Advanced Mode This command opens the Advanced Mode login dialog. Once the login is validated,
additional settings can be set by authorized personnel.
Refer to 3.2  Setting Up the Programmer and 3.4  Advanced Mode Settings for more
information.

Verify Device ID Before
Program

This command is only appropriate when using devices that have device IDs.
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...........continued
Setting Description

Erase All Before
Program

This command is used to control whether or not the contents of the device will be erased
before it is programmed.
It is not applicable to One-Time-Programmable (OTP). When the “Erase All Before
Program” command is enabled (check box is selected), the device will be erased before it
is programmed.

If it is disabled (unchecked), the device will not be erased before it is programmed

Auto Download
Firmware*

This command is available only for legacy tools (MPLAB ICD 3, PICkit 3 and PM3). If this
command is selected, the application verifies that the firmware is the latest available;
and, if needed, downloads the newer firmware automatically.

Manual Download
Firmware*

This command is available only for legacy tools (MPLAB ICD 3, PICkit 3 and PM3) and
enables manual download of firmware. The Firmware Browser dialog opens and locates
directory containing the latest PM3.jar firmware file. click on the Firmware File, then click
OK to download the firmware.

Save Firmware into SD
Card

This command downloads the operating system firmware into an SD Card that has been
inserted into the MPLAB PM3 programmer. See Section 3.3.2 “Save Firmware into PM3
SD Card”.

Hold in Reset This command prevents the code from running after programming.

Release from Reset This command removes the Reset and allows the code to run.

PM3 Communication This command is only used with the MPLAB PM3 programmer.
This command opens the PM3 Communication Setting dialog. Use this dialog to set
communications for COM or USB ports. See Section 3.3.3 “PM3 Communication Setting
Dialog” for more information.

*The download of firmware will not occur until the connect/disconnect button is clicked or a programming operation is
performed.

4.3.2 Save Firmware into PM3 SD Card
In production houses, there may be a need to program several different device family architectures without having
access to a computer.

Between MPLAB IPE v3.25 and v3.40, the PM3 operating system was split into two parts based on the device
architecture (32-bit vs all other devices). In MPLAB IPE v3.40, the PM3 operating system and database are split into
three parts based on the architectures for 8-, 16- and 32-bit devices.

MPLAB IPE v3.40 or greater enables you to save the three PM3 operating system firmwares supporting each of the
device family architectures into a PM3 SD card.

Once all the PM3 operating system firmwares are downloaded, when a PM3 environment is selected in Stand-Alone
mode, the MPLAB PM3 programmer will load the correct operating system and database for the device from the PM3
SD card.

This feature is available only in the MPLAB IPE v3.40 or greater, not in the MPLAB X IDE.

To save all three operating systems into the PM3 SD card:

1. Insert any supported SD card into PM3 SD card slot.
2. Open MPLAB IPE v3.40 or greater and connect the MPLAB PM3 programmer to the computer.
3. Select Settings>Save firmware into SD Card. The output window in the MPLAB IPE displays messages when

the operating systems and databases for the 8-bit, 16-bit and 32-bit MCUs are successfully saved onto the SD
card.

4.3.2.1 Points To Be Considered:
• Please ensure the PM3 operating system firmware version stored on the SD card matches the operating system

firmware version on the MPLAB PM3 programmer. A mismatch may occur if an upgrade of the PM3 operating
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system was performed but the SD card firmware was not updated. Use the MPLAB IPE v3.40 or greater to
select the Settings>Save firmware into SD Card option to load the PM3 SD card with the desired PM3 operating
system firmware version.

• Any firmware versions of v3.40 or greater are not compatible with earlier versions of MPLAB IPE. It is highly
recommended that the MPLAB PM3 use the firmware packaged within the same MPLAB IPE version.

Version Support

Prior to MPLAB IPE v3.25 One operating system supported.

MPLAB IPE v3.25-3.35 Two operating systems supported (32-bit and all other devices).

MPLAB IPE v3.40 or greater Three operating systems supported (8-, 16-, 32-bit devices).

4.3.3 PM3 Communication Setting Dialog
The PM3 Communication Setting dialog is available under the IPE Menu bar, Settings menu only when the
associated check box for Allow “Communication” under Settings menu is selected in the Advanced Mode, Production
Mode dialog.

The MPLAB PM3 must be connected to the PC, using the appropriate cable, prior to using the PM3 Communication
Setting dialog.

This dialog enables selecting the communication port for the MPLAB PM3 programmer through the IPE.

To use the RS-232 port on the MPLAB PM3, select the COM Port option and use the drop list to select the available
port. Click the refresh button if necessary to view available ports. Click the Test button to check communication
between the IPE and the MPLAB PM3.

To use USB for the communication port, select the USB Port option.

Setting up the COM Port Manually

On some systems, you may need to set up the communications port manually.

On Windows, from the Start menu, select Control Panel, then System and Security. Under the System settings, click
Device Manager. Expand the Ports drop-down list and double-click on the port you are trying to use. Click the Port
Settings tab, and select the following:

Bits per second: 57600 (baud rate)
Data bits: 8
Parity: None
Stop bits: 1
Flow control: Hardware

Click Advanced. Uncheck the Use FIFO buffers check box.

Reboot the PC to implement the change.

4.4 View Menu
The viewable memory types are determined by the Production settings that are selected in the Advanced Mode. The
View menu commands are described below:

• Clear All Memory
• 4.4.1  Memory Settings
• 4.4.2  Power Settings
• 4.4.3  Transfer from PM3
• 4.4.4  Transfer to PM3
• 4.4.5  Read Device ID
• 4.4.6  View PM3 Socket Info

Clear All Memory

Clears all of the memory views.
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4.4.1 Memory Settings
Displays the current memory settings (see example below). The Memory Settings are view-only and cannot be
changed from this window.

Figure 4-2. Memory Settings Display

4.4.2 Power Settings
Displays the current power settings (see example below).

Figure 4-3. Power Settings Display

4.4.3 Transfer from PM3
When selected, this option transfers the image from the connected MPLAB PM3 Programmer. The status displays in
the Output window.

4.4.4 Transfer to PM3
When selected, this option transfers the image to the connected MPLAB PM3 Programmer. The status displays in the
Output window.

4.4.5 Read Device ID
Displays the device ID of the selected device in the Output window.
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4.4.6 View PM3 Socket Info
Displays the PM3 socket information in the Output window.

4.5 Tools Menu
The Tools menu provides access to Plugins. Select Plugins to display the Plugins Manager. For details, see the
NetBeans help topic: Managing Plugins in the IDE found in http://wiki.netbeans.org/InstallingAPlugin. If MPLAB X IDE
is installed, see the MPLAB X IDE Help file, Additional Tasks, Add PlugIn Tools.

4.6 Window Menu

4.6.1 Output
This option opens the Output window at the bottom of the display. Right-click the tab title to display window options,
such as Close, Float, Move, etc. Right-click in the body of the window to display Output window content options, such
as Find, Wrap text, etc. See figure below.

Figure 4-4. Output Window Right-Click Menus

4.6.2 Target Memory Views
This option is available only if Production Settings are set in Advanced Mode to view the different types of memory.
Some of the possible memory views include Execution Memory, Configuration Bits, User ID Memory, Device ID
Memory, etc.

4.6.3 Reset Windows
Selecting this option will reset all the program windows to the default settings.

4.7 Help Menu
The Help menu provides access to the following online information:

• Read Me Docs - MPLAB IPE Readme and Programmer Command-line Readme
• Help Contents - displays the master set of all installed documentation.
• Tool Help Contents - lists help for several Microchip tools.
• About - displays information specific to the current version of MPLAB IPE.
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5. Revision History

5.1 Revision A (December 2013)
Initial release of this document.

5.2 Revision B (August 2015)
Modified “Software Installation Requirements”. The IPE is now a separate installation than the MPLAB X IDE.

Modified the description of Production Mode.

In the General Setup chapter:

• Added information on new features: Recently Used option in the Family list of devices and Creating Desktop
Shortcuts.

• Added information on Preserve Memory options.
• Added notes regarding MPLAB PM3 programmer environment files.
• Added a note in the description of the Allow Import Hex file option.
• Added information regarding using the MPLAB PM3 programmer with the option Allow “Communication” under

Settings menu.
• Added Special Memory Regions information.

In The MPLAB IPE Reference chapter:

• Added a note regarding the File>Import>Hex option.

5.3 Revision C (March 2017)
• Added Note with location of the Readme file for MPLAB IPE in “Software Installation Requirements”.
• Added a “Staying Logged In” topic to the Advanced Mode Login section.
• Updated memory range descriptions.
• Updated environment settings options.
• Revised “SQTP” section and added sections for using SQTP with MPLAB PM3 and with PIC32 devices.
• Added new SQTP setting.
• Updated field descriptions to the main IPE window.
• Added new Read Device ID option to the View menu.
• Added new settings menu command for saving firmware into SD card and added a revised information to “Save

Firmware into PM3 SD Card”.

5.4 Revision D (June 2018)
• In the Preface, added compatibility note that this document reflects the changes as of MPLAB X IDE v4.20 or

greater.
• Multiple updates throughout to reflect changes made to the program for the NetBeans platform. Added Tools

and Windows menus, updated graphics, text, and menu options.

5.5 Revision E (April 2020)
• Entire document has been reformatted and renumbered.
• In the Preface, added compatibility note that this document reflects the changes as of MPLAB X IDE v5.40 or

greater.
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• Replaced screen for Select Applications Dialog in the “Software Installation Requirements” section.
• Removed the “Feature Matrix” section.
• Added a new heading for “Multiple Instances of IPE” in Launching the MPLAB IPE Application section.
• Replaced screen for Advanced Mode Login and added screen for Change Password and Forgot Password

dialogs.
• Updated Production Settings table.
• Updated Special Settings table, added information for tool and device packs and other options including

Programmer-To-Go, JTAG, etc. Also removed PM3 program speed option and screen.
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6. Support
Please refer to the items discussed here for support issues.

• 6.1  Warranty Registration
• 6.2  Microchip Web Site
• 6.3  Personalized Notification Service
• 6.4  Customer Support

6.1 Warranty Registration
If your development tool package includes a Warranty Registration Card, please complete the card and mail it in
promptly. Sending in your Warranty Registration Card entitles you to receive new product updates. Interim software
releases are available at the Microchip web site.

6.2 Microchip Web Site
Microchip provides online support via our web site at https://www.microchip.com. This web site is used as a means to
make files and information easily available to customers. Accessible by using your favorite Internet browser, the web
site contains the following information:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online discussion
groups, Microchip consultant program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

6.3 Personalized Notification Service
Microchip's personal notification service helps keep customers current on their Microchip products of interest.
Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a
specified product family or development tool.

Please visit http://www.microchip.com/pcn to begin the registration process and select your preferences to receive
personalized notifications. A FAQ and registration details are available on the page, which can be opened by
selecting the link above.

When you are selecting your preferences, choosing “Development Systems” will populate the list with available
development tools. The main categories of tools are listed below:

• Compilers – The latest information on Microchip C compilers, assemblers, linkers and other language tools.
These include all MPLAB C compilers; all MPLAB assemblers (including MPASM™ assembler); all MPLAB
linkers (including MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object librarian).

• Emulators – The latest information on Microchip in-circuit emulators.These include the MPLAB REAL ICE in-
circuit emulators

• In-Circuit Debuggers – The latest information on Microchip in-circuit debuggers. These include the MPLAB ICD
3 and MPLAB ICD 4 in-circuit debuggers and PICkit™ 3 and MPLAB PICkit 4 in-circuit debuggers.

• MPLAB® X IDE – The latest information on Microchip MPLAB X IDE, the multi-platform (Windows®, macOS™,
Linux®) Integrated Development Environment for development systems tools.

• Programmers – The latest information on Microchip programmers. These include the device (production)
programmers MPLAB REAL ICE in-circuit emulator, MPLAB ICD 4 in-circuit debugger, MPLAB PICkit 4 in-circuit
debugger, MPLAB PM3 and development (non-production) programmer and PICkit 3.

• Starter/Demo Boards – These include MPLAB Starter Kit boards, PICDEM demo boards, and various other
evaluation boards.
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6.4 Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support

Customers should contact their distributor, representative or field application engineer (FAE) for support. Local sales
offices are also available to help customers. A listing of sales offices and locations is included in the back of this
document. See our web site for a complete, up-to-date listing of sales offices.

Technical support is available through the web site at http://support.microchip.com.

Documentation errors or comments may be emailed to docerrors@microchip.com.
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The Microchip Website
Microchip provides online support via our website at http://www.microchip.com/. This website is used to make files
and information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to http://www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: http://www.microchip.com/support
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Product Identification System
To order or obtain information, e.g., on pricing or delivery, refer to the factory or the listed sales office.



PART NO. X /XX XXX

PatternPackageTemperature
Range

Device

 
 

[X](1)

Tape and Reel
Option

-

Device: PIC16F18313, PIC16LF18313, PIC16F18323, PIC16LF18323

Tape and Reel Option: Blank = Standard packaging (tube or tray)

T = Tape and Reel(1)

Temperature Range: I = -40°C to +85°C (Industrial)

E = -40°C to +125°C (Extended)

Package:(2) JQ = UQFN

P = PDIP

ST = TSSOP

SL = SOIC-14

SN = SOIC-8

RF = UDFN

Pattern: QTP, SQTP, Code or Special Requirements (blank otherwise)

Examples:

• PIC16LF18313- I/P Industrial temperature, PDIP package
• PIC16F18313- E/SS Extended temperature, SSOP package

Note: 
1. Tape and Reel identifier only appears in the catalog part number description. This identifier is used for ordering

purposes and is not printed on the device package. Check with your Microchip Sales Office for package
availability with the Tape and Reel option.

2. Small form-factor packaging options may be available. Please check http://www.microchip.com/packaging for
small-form factor package availability, or contact your local Sales Office.

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specification contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is one of the most secure families of its kind on the market today,

when used in the intended manner and under normal conditions.
• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these

methods, to our knowledge, require using the Microchip products in a manner outside the operating
specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of
intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code

protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection
features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital
Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you
may have a right to sue for relief under that Act.

 MPLAB IPE User's Guide

© 2020 Microchip Technology Inc.  User Guide DS50002227E-page 36

http://www.microchip.com/packaging


Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your
convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with
your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER
EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend,
indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such
use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless
otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime,
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