Hot!MPLAB X IDE 3.45 crashing. (Disappears)

Author
Jose Diaz
Administrator
  • Total Posts : 1672
  • Reward points : 0
  • Joined: 2010/06/23 11:10:56
  • Location: 0
  • Status: offline
2016/11/30 15:03:25 (permalink)
4.75 (4)

MPLAB X IDE 3.45 crashing. (Disappears)

Intermittently the MPLAB X 3.45 IDE version will disappear on you when accessing the USB sub system. In this case there is an issue with the USBAcessLink dll.
 
Please download the zip file from the link provided.
http://ww1.microchip.com/downloads/mplab/x/v3.45/v3.45_replacements.zip
Then please follow these Attachments are not available: Download requirements not met
Note: you must be logged in to be able to download the instructions.
post edited by Jose Diaz - 2016/11/30 15:59:55

Attachment(s)

Attachments are not available: Download requirements not met
#1

5 Replies Related Threads

    Kopka
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2007/11/07 01:39:03
    • Location: Germany
    • Status: offline
    Re: MPLAB X IDE 3.45 crashing. (Disappears) 2016/12/07 10:46:50 (permalink)
    0
     
    Hi Jose,
    I had exactly the same problem. After the exchange of the two DLLs, there is no more crash.
    But:
    My REAL ICE is no longer recognized in the IDE or in the IPE.
    I tried it with two REAL ICE.
    In Windows, I see the correct MPLAB REAL ICE entries.

    My environment
    MPLAB X IDE v3.45
    WIN 7 Prof SP 1 64Bit

    How can I keep working?
    #2
    simong123
    Lab Member No. 003
    • Total Posts : 1114
    • Reward points : 0
    • Joined: 2012/02/07 18:21:03
    • Location: Future Gadget Lab (UK Branch)
    • Status: offline
    Re: MPLAB X IDE 3.45 crashing. (Disappears) 2016/12/07 12:54:12 (permalink)
    +1 (1)
    May be a silly question, but did you put the right  D L L in the right folder?
     
    The 32bit DLL goes in the SYSWOW64 folder and the 64bit DLL goes in the system 32 folder.
     
    I made that mistake, and it took me a while to figure it out....
    #3
    RISC
    Super Member
    • Total Posts : 4480
    • Reward points : 0
    • Status: offline
    Re: MPLAB X IDE 3.45 crashing. (Disappears) 2016/12/07 13:19:26 (permalink)
    0
    Hi,
     
    The instructions are correct :
    The 32bit DLL goes in the SYSWOW64 folder and the 64bit DLL goes in the system 32 folder :
    https://lmgtfy.com/?q=stackoverflow+syswow64
    Regards
    post edited by RISC - 2016/12/07 13:36:21
    #4
    Mysil
    Super Member
    • Total Posts : 2386
    • Reward points : 0
    • Joined: 2012/07/01 04:19:50
    • Location: Norway
    • Status: offline
    Re: MPLAB X IDE 3.45 crashing. (Disappears) 2016/12/07 13:23:04 (permalink)
    0
    Hi,
    Have downloaded and copied both files to destination according to instructions,
    but both files were already in place, same name, same size, same version number. 
    Are these files also distributed by Windows update, or some other means?
     
    Regards,
       Mysil
    #5
    Kopka
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2007/11/07 01:39:03
    • Location: Germany
    • Status: offline
    Re: MPLAB X IDE 3.45 crashing. (Disappears) 2016/12/08 00:16:33 (permalink)
    0
     
    It looks for a fault on my side.
    Thanks to simong123 and RISC.
    Now it works.
     
    Regards
    Michael
    post edited by Kopka - 2016/12/16 02:11:39
    #6
    Jump to:
    © 2017 APG vNext Commercial Version 4.5