Hot!Xpress board manufacturing error

Author
davidbear
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2010/01/04 22:07:31
  • Location: 0
  • Status: offline
2016/11/25 20:47:11 (permalink)
0

Xpress board manufacturing error

I was trying to run the temperature example program and my console flickered once per second, telling me that this was the "Temperature Sensor Demo." Started poking around a bit and discovered that I2C2_MasterTRBInsert was giving a "I2C2_DATA_NO_ACK", saw that the I2C address was 0x38 went to the EMC1001 datasheet and discovered that the address 0x38 is proper for a 20K pull-up resistor being attached to the ADDR/THERM pin. Checked the schematic and Resistor R20 is supposed to be 20.0K ohms. I thought maybe I had the EMC1001-1 device, in which case the address would be 0x3A, changed the code, same result. Then just for "fun" I decided to check all of the possible addresses and found that 0x49 worked. According to the datasheet, this should correspond to a 12K pull-up resistor. I have not been able to independently verify that this is the value of the resistor. Problem solved, but I thought someone else might have the same problem.
 
Edit: Went to measure the resistor and to my surprise found that it was indeed 20.0K. Plugged board back in and the program stopped working. Changed the address to 0x38, everything working. Board is fine case is closed.
post edited by davidbear - 2016/11/26 09:32:48
#1
Perkyguy
Starting Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2016/07/06 12:50:15
  • Location: 0
  • Status: offline
Re: Xpress board manufacturing error 2016/12/15 09:07:09 (permalink)
0
So no board mods were needed? It just worked after you unplugged and plugged the board in?
#2
Jump to:
© 2017 APG vNext Commercial Version 4.5