AnsweredFeedback about bugs in the Examples interface

Author
DavidEGrayson
Super Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2009/01/08 01:16:58
  • Location: Las Vegas, NV
  • Status: offline
2016/09/06 18:55:13 (permalink)
0

Feedback about bugs in the Examples interface

If you try to put any HTML in the Description field of an example in the MPLAB XPress IDE, it says "Error: You must own this example to make changes.".  That's clearly the wrong error message.  Also, you should allow HTML tags, but just be sure to escape them properly before rendering them.  Even better would be if you use Markdown formatting so we can have clickable links and other styling. The Markdown parsing library you pick should take care of any escaping of HTML that you need.

If I enter a comment on an example and put newlines in the comment, the newlines are converted to visible HTML tags ("<br />") when the comment is displayed. It would be nice if they would be displayed as proper line breaks instead.\
 
If I try to enter a comment on an example like "Hey <A>", I see a message saying that there was a problem entering my comment and it fails.
 
If I am looking at an example and I add one comment that says "foo", and then add another comment that says "bar" without leaving or refreshing the page, the comment that says "foo" is incorrectly displayed as "bar". Then, if I refresh the page, the comments are displayed correctly.
 
It looks like I cannot delete an example that I have added.  Am I missing something?
 
If an example has just one picture, you should not show the image thumbnail gallery because it makes the page look weird.  Here is an example of a page that looks weird: https://mplabxpress.micro...ud/example/details/162 . The image thumbnail gallery should perhaps have a thin gray border around each thumbnail so you can tell that it's a clickable element.\
 
 
#1
DavidEGrayson
Super Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2009/01/08 01:16:58
  • Location: Las Vegas, NV
  • Status: offline
Re: Feedback about bugs in the Examples interface 2016/09/06 18:58:34 (permalink)
0
Just so you know, those random back-slashes in the post above are not typos from me; I wrote my post in a different text editor before copying it into the forum, and I can see that those slashes are not present in my text editor's buffer.  This Microchip forum software must have added those slashes, and it gives me an "Access Denied" error if I try to edit the post.  
#2
Perkyguy
Starting Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2016/07/06 12:50:15
  • Location: 0
  • Status: offline
Re: Feedback about bugs in the Examples interface 2016/09/07 08:43:42 (permalink) ☼ Best Answerby mamun 2016/12/13 12:31:36
0
It looks like I cannot delete an example that I have added.  Am I missing something?

 
To answer one of your concerns, when you're looking at the main examples listing, if you click on the button "Manage My Examples", it gives you a listing of all the examples you've uploaded as well as the option to delete them.
post edited by Perkyguy - 2016/09/07 08:54:05
#3
Perkyguy
Starting Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2016/07/06 12:50:15
  • Location: 0
  • Status: offline
Re: Feedback about bugs in the Examples interface 2016/09/07 08:51:11 (permalink)
0
If I enter a comment on an example and put newlines in the comment, the newlines are converted to visible HTML tags ("<br />") when the comment is displayed. It would be nice if they would be displayed as proper line breaks instead.

 
I don't see the tags in comments either posted already, or new ones I'm inputting. Which OS/browser are you using?
#4
DavidEGrayson
Super Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2009/01/08 01:16:58
  • Location: Las Vegas, NV
  • Status: offline
Re: Feedback about bugs in the Examples interface 2016/09/07 09:25:07 (permalink)
0
Thanks, Perkyguy! I found the Delete button now.  It was confusing to me that the Delete button did no appear on this page, just an "Open" button:
 
https://mplabxpress.micro...4109-8bae-96dd3a10ce12
 
If I go to the following example in Chrome on Windows, and type "test" Enter Enter "bar", then it appears as "test<br/><br/>bar" until I refresh the page.  So there a multiple bugs with the Javascript that attempts to automatically update the page when I post a comment (see my first post for the other one).
#5
DavidEGrayson
Super Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2009/01/08 01:16:58
  • Location: Las Vegas, NV
  • Status: offline
Re: Feedback about bugs in the Examples interface 2016/09/07 09:32:43 (permalink)
0
Here is the example I meant to post a link to in my previous post.  (I still can't edit posts.)
 
https://mplabxpress.micro...ud/example/details/212
#6
Jump to:
© 2017 APG vNext Commercial Version 4.5