Helpful ReplyPickit 3 "connection failed" after upgrading to Windows 10 Pro

Author
Tabur
Senior Member
  • Total Posts : 125
  • Reward points : 0
  • Joined: 2013/10/18 13:11:06
  • Location: 0
  • Status: offline
2015/08/03 14:26:25 (permalink)
0

Pickit 3 "connection failed" after upgrading to Windows 10 Pro

Hi!
 
First of all, I'd like to explain the state of things here at the shop: Turmoil, desperation and anguish. Imagine fires, paper flying and everyone running with arms flailing in the air.
 
Now that that's out of the way, our current problem is that we're getting "Connection Failed" when trying to upload new firmware using our trusty Pickit3. The ICD was working perfectly two days ago, but yesterday we upgraded the machine to Windows 10 Pro, and today we realized the problem.
 
ICD: Pickit 3
IDE: MPLAB X IDE v 3.05
Compiler: XC8 v 1.34
Os: Windows 10 (x64) Pro
 
Update: We realized that the SN (Serial Number) isn't displaying correctly. In the Dashboard, under Debug Tool, we get the following -> Pickit3: None (VID 04D8, PID 900A)
Update2: Not sure if relevant, but we also noticed that in MPLAB X IDE's "About" menu, under Help, the program thinks we're running "Windows 8.1 version 6.3 running on amd64; Cp1252; en_US (mplab)", when we're running Windows 10 on Intel I7
#1
NorthGuy
Super Member
  • Total Posts : 5015
  • Reward points : 0
  • Joined: 2014/02/23 14:23:23
  • Location: Northern Canada
  • Status: online
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/03 14:54:13 (permalink)
3 (1)
Serial Numbers are (used to be) listed as sub-keys of
 
HKLM\System\CurrentControlSet\Enum\USB\VID_04D8&PID_900A
 
Are they still there?
 
Please keep us informed. Who knows what Win 10 can bring. Microsofts are unusually pushy with it. May be it's time to switch to Linux.
post edited by NorthGuy - 2015/08/03 14:56:34
#2
jstanle1_home
Starting Member
  • Total Posts : 39
  • Reward points : 0
  • Joined: 2008/12/18 14:51:47
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/03 14:56:49 (permalink)
0
I've had the same problem under Windows 8.1 just updating from MPLABX 2.2 to 3.05.  I would be interesting to see if there is a similar underlying cause, but I have no clue now where to look.
 
I agree with the paper flying and anguish...
#3
Tabur
Senior Member
  • Total Posts : 125
  • Reward points : 0
  • Joined: 2013/10/18 13:11:06
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/03 15:10:47 (permalink)
3 (1)
NorthGuy
Serial Numbers are (used to be) listed as sub-keys of
 
HKLM\System\CurrentControlSet\Enum\USB\VID_04D8&PID_900A
 
Are they still there?
 
Please keep us informed. Who knows what Win 10 can bring. Microsofts are unusually pushy with it. May be it's time to switch to Linux.




Well apparently it's still there, and with the correct SN... Weird...
 
 

Attached Image(s)

#4
Petar
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2015/08/04 00:46:24
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/04 13:14:15 (permalink)
5 (2)
I had the same issue and did some digging.
Here it is how I solved it:
1. I followed this tutorial
 
http://nerdclub-uk.blogspot.com/2013/07/pickit2-not-working-on-windows-8-you.html

 
 
2. Then I edited registry for the Pickit3 and I changed EnhancedPowerManagementEnabled value to 0
 
That was all. I am not sure if point 1 is needed.
 
Cheers
Petar
 
 
post edited by Petar - 2015/08/05 21:39:45

Attached Image(s)

#5
prj
Super Member
  • Total Posts : 197
  • Reward points : 0
  • Joined: 2009/12/01 14:35:45
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/04 15:12:32 (permalink)
3 (1)
Peter: Sorry, but I don't think the link to #1 came through to the forum. Can you give the link in plain text. Thanks.
#6
ric
Super Member
  • Total Posts : 22101
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/04 15:24:46 (permalink)
4 (2)
Peter, link in my signature explains how to post links if the forum is blocking you.

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#7
Petar
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2015/08/04 00:46:24
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/04 22:09:21 (permalink)
0
Sorry,
I put the link as plain text.
 
Petar
#8
ric
Super Member
  • Total Posts : 22101
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/05 16:04:04 (permalink)
4 (2)
peter_penchev
Sorry,
I put the link as plain text.
 
Petar


Where?
Did you read the explanation in my signature link?
 

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#9
Petar
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2015/08/04 00:46:24
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/05 21:41:45 (permalink)
0
ric
peter_penchev
Sorry,
I put the link as plain text.
 
Petar


Where?
Did you read the explanation in my signature link?
 


 Sorry , Now it is visible , I tried wrong bbcode.
 
#10
Maarten
New Member
  • Total Posts : 8
  • Reward points : 0
  • Joined: 2012/06/25 10:59:12
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/07 02:37:35 (permalink)
3 (1)
After upgrading from Windows 7 (MPLABX v 2.26) to Windows 10 (MPLABX v 3.05) I faced the same problem.
I tried the proposed solutions but these didn't work for me.
What did work was setting up MPLABX to run in compatibility mode (Windows 7).
 
I had to reboot my PC and disconnect the PICkit3. After MPLABX downloaded and installed new firmware for the PICkit3 and reconnecting the PICkit3 all seems to be working fine now.
 
Regards,
Maarten
 
#11
jdraughn
Senior Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2009/01/13 06:11:37
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/08/07 03:48:14 (permalink) ☄ Helpfulby ad5oj 2015/12/17 13:08:47
5 (2)
Thanks Petar,
 
Just editing my registry fixed it.
peter_penchev
 
2. Then I edited registry for the Pickit3 and I changed EnhancedPowerManagementEnabled value to 0
 
That was all. I am not sure if point 1 is needed.
 
Cheers
Petar
 
 




#12
blotfib
Starting Member
  • Total Posts : 89
  • Reward points : 0
  • Joined: 2005/12/15 07:13:47
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/10/31 12:57:22 (permalink)
4 (2)
Same problem here with Windows 10 64 bits and MPLAB X 3.05,
upgrading to MPLAB X 3.10 solved this issue of Pockit 3
#13
Ákiboy
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2015/11/17 18:59:37
  • Location: 0
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/11/17 22:25:53 (permalink)
0
Hi Evryone!


I had the same problem: The Pickit not connect to PC (MPLAB IPE Device windows empty!)
It was a simple solution: I rounded the USB HUB and the cable is connected directly to the motherboard!


#14
ad5oj
Starting Member
  • Total Posts : 44
  • Reward points : 0
  • Joined: 2005/04/25 10:27:04
  • Status: offline
Re: Pickit 3 "connection failed" after upgrading to Windows 10 Pro 2015/12/17 13:16:11 (permalink)
3 (1)
Yes, editing the registry value worked for me.  Thanks Petar.  For those needing to know how to find the PICKit device, it is in one of the sub directories under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB.
 
Jon
post edited by ad5oj - 2015/12/17 13:21:05
#15
Jump to:
© 2018 APG vNext Commercial Version 4.5