MPLAB X 1.2 Include Paths

Page: < 12 Showing page 2 of 2
Author
XGenerator
Administrator
  • Total Posts : 348
  • Reward points : 0
  • Joined: 2009/10/12 12:11:03
  • Location: 0
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/06/22 11:58:39 (permalink)
0
We have found an issue with the XC32 plugin that parses the system include files to the parser. This is fixed int he 1.30 version available soon.
Howewver we have also identified that at times (adding a file and others) the parser will not always refresh. We have a bug issue for this and will look at it for 1.40.
Thanks
 
#21
branek
Starting Member
  • Total Posts : 39
  • Reward points : 0
  • Joined: 2005/10/25 03:33:02
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/07/10 03:56:55 (permalink)
0
Hi to all,
 
I experienced same issue after migrating from Win version to Linux version of MPLAB X 1.30 and XC16 V1.0.
After changing backslashes into slashes under xc16-gcc include directory I spotted that on some places in /nbproject/configurations.xml these backslashes are not changed. I changed it manually and now I have parser working.
 
Backup configurations.xml before any edit.
 
Branko
#22
Steve S
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2006/12/06 11:44:47
  • Location: 0
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/07/11 22:31:30 (permalink)
0
I've been using MPLAB for many years and I cannot get MPLAB X to build unless I manually change each and every #include directive to include the full path.  Even that does not always work because MPLAB X invokes #includes that I don't want, can't use, and can't turn off.  The latest problem is that a project fails to build because it can't find "chip_select.h".  This header file is apparently used for MPLAB REAL-ICE related macros which I don't use.  How can I turn this bloody stupid feature off!!!  MPLAB X is not a usable product with this kind of problem.
 
Under MPLAB 8.x all you have to do is click on Project, Build, Project, and all of the paths can be set globally in a snap.  So this ability was removed in MPLAB X??  Seriously?

Steve S
Aegis Technology LLC
Microchip Consultant
Specializing in Power Supplies and Wireless Communication
#23
vloki
Jo, alla!
  • Total Posts : 6721
  • Reward points : 0
  • Joined: 2007/10/15 00:51:49
  • Location: Germany
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/07/11 23:56:14 (permalink)
0
Project Properties -> Categories: *your compiler* -> Include directories ...

Uffbasse !
#24
jjmontero9
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2011/05/11 11:26:07
  • Location: 0
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/08/04 09:08:05 (permalink)
0
I'm having the same problem.
1. I included headers in my project.
2. I declared them in the source.
 
This is what is happening

 
I thought Java 7 was the problem.
So I uninstalled Java 7 and installed Java 6 R33.
Still no luck.
 
Files are missing and this happens every time I try to include a header this way.
Any ideas?
#25
sggaunt
Super Member
  • Total Posts : 201
  • Reward points : 0
  • Joined: 2009/12/03 06:51:45
  • Location: Huddersfield
  • Status: offline
Re:MPLAB X 1.2 Include Paths 2012/08/06 01:17:33 (permalink)
0
Putting a header filer into the project tree, does not include it in your build. (same with any version of MPLab and most other IDEs)
It just so you can open the headers in the editor as required, Previous versions of MPLab had a means of specifying your library (headers etc) locations, In X is it not so clear.
If you type "#include" then add a Double quote or Left Arrow X will bring up a list of the '.h' files it can 'see' 
If it cannot see the ones you want well that's when the fun starts!
Here's a tip though look at the locations of the 'visible' headers and move your required headers to the same folder. Much simpler that trying to get the paths right (good grief)
 
#26
Page: < 12 Showing page 2 of 2
Jump to:
© 2018 APG vNext Commercial Version 4.5